aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils/sweeper/Makefile
diff options
context:
space:
mode:
authorgallatin <gallatin@FreeBSD.org>2002-05-21 23:03:32 +0800
committergallatin <gallatin@FreeBSD.org>2002-05-21 23:03:32 +0800
commit42ba5d1d17024e777f60bc0a87a4505b93a3ceb4 (patch)
tree4a0f668e7037816b47d70fcf359fb891538be548 /sysutils/sweeper/Makefile
parent144f4e5cb31020994fca6a862735ce1cd1b8905f (diff)
downloadfreebsd-ports-gnome-42ba5d1d17024e777f60bc0a87a4505b93a3ceb4.tar.gz
freebsd-ports-gnome-42ba5d1d17024e777f60bc0a87a4505b93a3ceb4.tar.zst
freebsd-ports-gnome-42ba5d1d17024e777f60bc0a87a4505b93a3ceb4.zip
Don't build klaptopdaemon on alpha.
Due to APM dependancies, its preventing the port from building on alpha. Since I can't see what use its features would be on a platform which doesn't support power mgmnt, it seems simplest to just yank it. Approved by: will
Diffstat (limited to 'sysutils/sweeper/Makefile')
-rw-r--r--sysutils/sweeper/Makefile11
1 files changed, 11 insertions, 0 deletions
diff --git a/sysutils/sweeper/Makefile b/sysutils/sweeper/Makefile
index 3163616cd341..afe2b84b5758 100644
--- a/sysutils/sweeper/Makefile
+++ b/sysutils/sweeper/Makefile
@@ -23,4 +23,15 @@ CONFIGURE_ARGS+=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
USE_GMAKE= yes
MAN1= efax.1 efix.1 fax.1
+#klaptop doesn't like alpha because alpha doesn't support apm
+.if ${MACHINE_ARCH} == "alpha"
+post-extract:
+ mv ${WRKSRC}/subdirs ${WRKSRC}/subdirs.orig
+ grep -v klaptopdaemon ${WRKSRC}/subdirs.orig > ${WRKSRC}/subdirs
+
+PLIST_SUB+= ALPHA_NA="@comment "
+.else
+PLIST_SUB+= ALPHA_NA=""
+.endif
+
.include <bsd.port.mk>