aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils/synergy/files/patch-CMakeLists.txt
diff options
context:
space:
mode:
authorkevlo <kevlo@FreeBSD.org>2014-05-30 17:00:03 +0800
committerkevlo <kevlo@FreeBSD.org>2014-05-30 17:00:03 +0800
commitc64ff188b74c70c247852eb1637f1b81c617fb27 (patch)
treeeb98d2725adf36734ff140958849f9d29945a43a /sysutils/synergy/files/patch-CMakeLists.txt
parentc29141ed58aa9e38d23d08de4da2862194690fb7 (diff)
downloadfreebsd-ports-gnome-c64ff188b74c70c247852eb1637f1b81c617fb27.tar.gz
freebsd-ports-gnome-c64ff188b74c70c247852eb1637f1b81c617fb27.tar.zst
freebsd-ports-gnome-c64ff188b74c70c247852eb1637f1b81c617fb27.zip
Update to 1.5.0
Diffstat (limited to 'sysutils/synergy/files/patch-CMakeLists.txt')
-rw-r--r--sysutils/synergy/files/patch-CMakeLists.txt13
1 files changed, 13 insertions, 0 deletions
diff --git a/sysutils/synergy/files/patch-CMakeLists.txt b/sysutils/synergy/files/patch-CMakeLists.txt
new file mode 100644
index 000000000000..316d9bf52ed9
--- /dev/null
+++ b/sysutils/synergy/files/patch-CMakeLists.txt
@@ -0,0 +1,13 @@
+--- CMakeLists.txt.orig 2014-05-23 23:43:58.000000000 +0800
++++ CMakeLists.txt 2014-05-30 13:55:26.000000000 +0800
+@@ -74,10 +74,6 @@
+ # Depending on the platform, pass in the required defines.
+ if (UNIX)
+
+- # warnings as errors:
+- # we have a problem with people checking in code with warnings.
+- set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Werror")
+-
+ # For config.h, detect the libraries, functions, etc.
+ include(CheckIncludeFiles)
+ include(CheckLibraryExists)