aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils/timelimit/Makefile
diff options
context:
space:
mode:
authorroam <roam@FreeBSD.org>2001-06-09 07:07:13 +0800
committerroam <roam@FreeBSD.org>2001-06-09 07:07:13 +0800
commitc8c05ea8a9d759b324e1749c7b1f2de4fa5616bd (patch)
tree56c9d0942f6f5def598188394d61351ff50ecd5e /sysutils/timelimit/Makefile
parentb1e4d6cb96350d160f3f0e8eb74086220b143e9c (diff)
downloadfreebsd-ports-gnome-c8c05ea8a9d759b324e1749c7b1f2de4fa5616bd.tar.gz
freebsd-ports-gnome-c8c05ea8a9d759b324e1749c7b1f2de4fa5616bd.tar.zst
freebsd-ports-gnome-c8c05ea8a9d759b324e1749c7b1f2de4fa5616bd.zip
timelimit executes a command and terminates the spawned process
after a given time with a given signal. A 'warning' signal is sent first, then, after a timeout, a 'kill' signal, similar to the way init(8) operates on shutdown. WWW: http://ringwraith.online.bg/devel/sys/timelimit/ Author: Peter Pentchev <roam@orbitel.bg>
Diffstat (limited to 'sysutils/timelimit/Makefile')
-rw-r--r--sysutils/timelimit/Makefile22
1 files changed, 22 insertions, 0 deletions
diff --git a/sysutils/timelimit/Makefile b/sysutils/timelimit/Makefile
new file mode 100644
index 000000000000..96505a75854f
--- /dev/null
+++ b/sysutils/timelimit/Makefile
@@ -0,0 +1,22 @@
+# New ports collection makefile for: timelimit
+# Date created: 9 June 2001
+# Whom: roam@FreeBSD.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= timelimit
+PORTVERSION= 1.0.b3
+CATEGORIES= sysutils
+MASTER_SITES= http://ringwraith.online.bg/~roam/devel/sys/timelimit/
+DISTNAME= ${PORTNAME}-${PORTVERSION:S/.b/pre/}
+
+MAINTAINER= roam@FreeBSD.org
+
+MAN8= timelimit.8
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/timelimit ${PREFIX}/bin
+ ${INSTALL_DATA} ${WRKSRC}/timelimit.8 ${PREFIX}/man/man8/
+
+.include <bsd.port.mk>