aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils/tmux
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2016-09-30 22:44:51 +0800
committermat <mat@FreeBSD.org>2016-09-30 22:44:51 +0800
commitebf164570988df9afb9405ff183b4fe86d96bd8f (patch)
tree614dc8769060ed04e21b085932424b738d92453f /sysutils/tmux
parent0631108148b4ebb8204a38843b514776ee1dfdd6 (diff)
downloadfreebsd-ports-gnome-ebf164570988df9afb9405ff183b4fe86d96bd8f.tar.gz
freebsd-ports-gnome-ebf164570988df9afb9405ff183b4fe86d96bd8f.tar.zst
freebsd-ports-gnome-ebf164570988df9afb9405ff183b4fe86d96bd8f.zip
Update to 2.3.
While there, update the completion. PR: 213119 Reported by: Piotr Kubaj Changes: https://github.com/tmux/tmux/blob/52869ed182482c26163799a7215139f4d81b6fca/CHANGES Sponsored by: Absolight
Diffstat (limited to 'sysutils/tmux')
-rw-r--r--sysutils/tmux/Makefile5
-rw-r--r--sysutils/tmux/distinfo10
-rw-r--r--sysutils/tmux/files/extra-patch-tty-keys.c12
-rw-r--r--sysutils/tmux/files/patch-utf8.c34
4 files changed, 13 insertions, 48 deletions
diff --git a/sysutils/tmux/Makefile b/sysutils/tmux/Makefile
index a065ba65f1e0..bae886f4f0ca 100644
--- a/sysutils/tmux/Makefile
+++ b/sysutils/tmux/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= tmux
-PORTVERSION= 2.2
-PORTREVISION= 1
+PORTVERSION= 2.3
CATEGORIES= sysutils
MASTER_SITES= https://github.com/tmux/tmux/releases/download/${PORTVERSION}/
DISTFILES= ${DISTNAME}${EXTRACT_SUFX}
@@ -17,7 +16,7 @@ LICENSE_FILE= ${WRKSRC}/COPYING
USES= pkgconfig ncurses
USE_GITHUB= nodefault
-GH_TUPLE= imomaliev:tmux-bash-completion:e0f7021:bash
+GH_TUPLE= imomaliev:tmux-bash-completion:ef56d3e:bash
GNU_CONFIGURE= yes
CONFIGURE_ARGS+=--sysconfdir=${PREFIX}/etc
diff --git a/sysutils/tmux/distinfo b/sysutils/tmux/distinfo
index a5723b236887..27bb56f5cb5e 100644
--- a/sysutils/tmux/distinfo
+++ b/sysutils/tmux/distinfo
@@ -1,5 +1,5 @@
-TIMESTAMP = 1468847551
-SHA256 (tmux-2.2.tar.gz) = bc28541b64f99929fe8e3ae7a02291263f3c97730781201824c0f05d7c8e19e4
-SIZE (tmux-2.2.tar.gz) = 466852
-SHA256 (imomaliev-tmux-bash-completion-e0f7021_GH0.tar.gz) = 5957606b43ec4010084e20d7028044e23cc516ea100c4138d48984de53a7941b
-SIZE (imomaliev-tmux-bash-completion-e0f7021_GH0.tar.gz) = 1661
+TIMESTAMP = 1475246504
+SHA256 (tmux-2.3.tar.gz) = 55313e132f0f42de7e020bf6323a1939ee02ab79c48634aa07475db41573852b
+SIZE (tmux-2.3.tar.gz) = 473944
+SHA256 (imomaliev-tmux-bash-completion-ef56d3e_GH0.tar.gz) = 2f8f3fe586bbdeec9b251ce3ef74f5edef19ba371968a8011acef860ddac59e1
+SIZE (imomaliev-tmux-bash-completion-ef56d3e_GH0.tar.gz) = 1526
diff --git a/sysutils/tmux/files/extra-patch-tty-keys.c b/sysutils/tmux/files/extra-patch-tty-keys.c
index ba869f1f16df..663d128b1a66 100644
--- a/sysutils/tmux/files/extra-patch-tty-keys.c
+++ b/sysutils/tmux/files/extra-patch-tty-keys.c
@@ -1,11 +1,11 @@
---- tty-keys.c.orig 2016-03-02 18:08:46 UTC
+--- tty-keys.c.orig 2016-04-30 12:46:35 UTC
+++ tty-keys.c
-@@ -572,8 +572,6 @@ first_key:
+@@ -628,8 +628,6 @@ complete_key:
* used. termios should have a better idea.
*/
bspace = tty->tio.c_cc[VERASE];
-- if (bspace != _POSIX_VDISABLE && key == bspace)
-- key = KEYC_BSPACE;
-
- goto complete_key;
+- if (bspace != _POSIX_VDISABLE && (key & KEYC_MASK_KEY) == bspace)
+- key = (key & KEYC_MASK_MOD) | KEYC_BSPACE;
+ /* Remove data from buffer. */
+ evbuffer_drain(tty->event->input, size);
diff --git a/sysutils/tmux/files/patch-utf8.c b/sysutils/tmux/files/patch-utf8.c
deleted file mode 100644
index 68c21ae0f9ac..000000000000
--- a/sysutils/tmux/files/patch-utf8.c
+++ /dev/null
@@ -1,34 +0,0 @@
-commit 65e4c57d3a554940ed5cada6dfeff403ae8d9572
-Author: Nicholas Marriott <nicholas.marriott@gmail.com>
-Date: 2016-04-29 12:47:15 +0100
-
- Only assume width 1 when wcwidth() returns -1 on non-OpenBSD platforms.
-
---- utf8.c.orig 2016-03-02 18:29:06 UTC
-+++ utf8.c
-@@ -115,8 +115,24 @@ utf8_width(wchar_t wc)
- int width;
-
- width = wcwidth(wc);
-- if (width < 0 || width > 0xff)
-+ if (width < 0 || width > 0xff) {
-+ log_debug("Unicode %04x, wcwidth() %d", wc, width);
-+
-+#ifndef __OpenBSD__
-+ /*
-+ * Many platforms (particularly and inevitably OS X) have no
-+ * width for relatively common characters (wcwidth() returns
-+ * -1); assume width 1 in this case. This will be wrong for
-+ * genuinely nonprintable characters, but they should be
-+ * rare. We may pass through stuff that ideally we would block,
-+ * but this is no worse than sending the same to the terminal
-+ * without tmux.
-+ */
-+ if (width < 0)
-+ return (1);
-+#endif
- return (-1);
-+ }
- return (width);
- }
-