aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils/u-boot-a13-olinuxino/Makefile
diff options
context:
space:
mode:
authorpawel <pawel@FreeBSD.org>2016-08-19 01:46:06 +0800
committerpawel <pawel@FreeBSD.org>2016-08-19 01:46:06 +0800
commit2cddf0f924e41f7175bbfc6540865092424e6080 (patch)
tree260169e6fc8ce499de99400badce177b44516460 /sysutils/u-boot-a13-olinuxino/Makefile
parentada297e25f2f496348d50a7cb4d4e0735f31b11c (diff)
downloadfreebsd-ports-gnome-2cddf0f924e41f7175bbfc6540865092424e6080.tar.gz
freebsd-ports-gnome-2cddf0f924e41f7175bbfc6540865092424e6080.tar.zst
freebsd-ports-gnome-2cddf0f924e41f7175bbfc6540865092424e6080.zip
U-Boot loader for A13 Olinuxino.
To install this bootloader on an sdcard just do : dd if=/usr/local/share/u-boot/u-boot-boardname/u-boot-sunxi-with-spl.bin of=/path/to/sdcarddevice bs=1k seek=8 conv=notrunc,sync This version is patched so that: * ELF and API features are enabled. * The default environment is trimmed to just what's needed to boot. * The saveenv command writes to the file u-boot.env on the FAT partition. * The DTB file name is chosen based on the board model and passed to ubldr.bin using the fdtfile env variable. ubldr.bin loads the DTB from /boot/dtb/ on the FreeBSD partition. * By default, it loads PIE ubldr.bin from file ubldr.bin on the FAT partition to address 0x42000000, and launches it. For information about running FreeBSD on Allwinner boards, see https://wiki.freebsd.org/FreeBSD/arm/Allwinner For general information about U-Boot see WWW: http://www.denx.de/wiki/U-Boot PR: 211951 Submitted by: Emmanuel Vadot
Diffstat (limited to 'sysutils/u-boot-a13-olinuxino/Makefile')
-rw-r--r--sysutils/u-boot-a13-olinuxino/Makefile14
1 files changed, 14 insertions, 0 deletions
diff --git a/sysutils/u-boot-a13-olinuxino/Makefile b/sysutils/u-boot-a13-olinuxino/Makefile
new file mode 100644
index 000000000000..2d4cebe3565b
--- /dev/null
+++ b/sysutils/u-boot-a13-olinuxino/Makefile
@@ -0,0 +1,14 @@
+# $FreeBSD$
+
+PKGNAMESUFFIX= -a13-olinuxino
+
+COMMENT= Cross-build U-Boot loader for A13 Olinuxino
+
+LICENSE= GPLv2
+
+MASTERDIR= ${.CURDIR}/../u-boot-olimex-a20-som-evb
+DESCR= ${.CURDIR}/pkg-descr
+MODEL= sun5i-a13-olinuxino
+BOARD_CONFIG= A13-OLinuXino_defconfig
+
+.include "${MASTERDIR}/Makefile"