aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils/u-boot-olinuxino-lime
diff options
context:
space:
mode:
authorpawel <pawel@FreeBSD.org>2016-08-19 01:23:00 +0800
committerpawel <pawel@FreeBSD.org>2016-08-19 01:23:00 +0800
commita14349d839064ac23267f5fbce6257e6c98d8786 (patch)
tree5be19bbfef6457090f2c60451adefa2c3751804a /sysutils/u-boot-olinuxino-lime
parent8bfa1656e2703fcb38339a534d4f600f8cb5c156 (diff)
downloadfreebsd-ports-gnome-a14349d839064ac23267f5fbce6257e6c98d8786.tar.gz
freebsd-ports-gnome-a14349d839064ac23267f5fbce6257e6c98d8786.tar.zst
freebsd-ports-gnome-a14349d839064ac23267f5fbce6257e6c98d8786.zip
U-Boot loader for Olinuxino Lime.
To install this bootloader on an sdcard just do : dd if=/usr/local/share/u-boot/u-boot-boardname/u-boot-sunxi-with-spl.bin of=/path/to/sdcarddevice bs=1k seek=8 conv=notrunc,sync This version is patched so that: * ELF and API features are enabled. * The default environment is trimmed to just what's needed to boot. * The saveenv command writes to the file u-boot.env on the FAT partition. * The DTB file name is chosen based on the board model and passed to ubldr.bin using the fdtfile env variable. ubldr.bin loads the DTB from /boot/dtb/ on the FreeBSD partition. * By default, it loads PIE ubldr.bin from file ubldr.bin on the FAT partition to address 0x42000000, and launches it. For information about running FreeBSD on Allwinner boards, see https://wiki.freebsd.org/FreeBSD/arm/Allwinner For general information about U-Boot see WWW: http://www.denx.de/wiki/U-Boot PR: 211950 Submitted by: Emmanuel Vadot
Diffstat (limited to 'sysutils/u-boot-olinuxino-lime')
-rw-r--r--sysutils/u-boot-olinuxino-lime/Makefile14
-rw-r--r--sysutils/u-boot-olinuxino-lime/pkg-descr19
2 files changed, 33 insertions, 0 deletions
diff --git a/sysutils/u-boot-olinuxino-lime/Makefile b/sysutils/u-boot-olinuxino-lime/Makefile
new file mode 100644
index 000000000000..104e95e34733
--- /dev/null
+++ b/sysutils/u-boot-olinuxino-lime/Makefile
@@ -0,0 +1,14 @@
+# $FreeBSD$
+
+PKGNAMESUFFIX= -${MODEL}
+
+COMMENT= Cross-build U-Boot loader for Olinuxino Lime
+
+LICENSE= GPLv2
+
+MASTERDIR= ${.CURDIR}/../u-boot-olimex-a20-som-evb
+DESCR= ${.CURDIR}/pkg-descr
+MODEL= olinuxino-lime
+BOARD_CONFIG= A10-OLinuXino-Lime_defconfig
+
+.include "${MASTERDIR}/Makefile"
diff --git a/sysutils/u-boot-olinuxino-lime/pkg-descr b/sysutils/u-boot-olinuxino-lime/pkg-descr
new file mode 100644
index 000000000000..1880c52a991b
--- /dev/null
+++ b/sysutils/u-boot-olinuxino-lime/pkg-descr
@@ -0,0 +1,19 @@
+U-Boot loader for Olinuxino Lime.
+
+To install this bootloader on an sdcard just do :
+dd if=/usr/local/share/u-boot/u-boot-boardname/u-boot-sunxi-with-spl.bin of=/path/to/sdcarddevice bs=1k seek=8 conv=notrunc,sync
+
+This version is patched so that:
+ * ELF and API features are enabled.
+ * The default environment is trimmed to just what's needed to boot.
+ * The saveenv command writes to the file u-boot.env on the FAT partition.
+ * The DTB file name is chosen based on the board model and passed to ubldr.bin
+ using the fdtfile env variable. ubldr.bin loads the DTB from /boot/dtb/ on
+ the FreeBSD partition.
+ * By default, it loads PIE ubldr.bin from file ubldr.bin on the FAT partition
+ to address 0x42000000, and launches it.
+
+For information about running FreeBSD on Allwinner boards, see
+ https://wiki.freebsd.org/FreeBSD/arm/Allwinner
+
+For general information about U-Boot see WWW: http://www.denx.de/wiki/U-Boot