aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils/u-boot-pine64
diff options
context:
space:
mode:
authorimp <imp@FreeBSD.org>2017-08-02 23:21:02 +0800
committerimp <imp@FreeBSD.org>2017-08-02 23:21:02 +0800
commit8dd913011e02825450bd9b3b2b5c326a543bf4cc (patch)
tree464e7d6cb82cd32b358866a2c3b8e40c8813bd52 /sysutils/u-boot-pine64
parente61499b878febf027db1fddbc7c3df1b6e542b0d (diff)
downloadfreebsd-ports-gnome-8dd913011e02825450bd9b3b2b5c326a543bf4cc.tar.gz
freebsd-ports-gnome-8dd913011e02825450bd9b3b2b5c326a543bf4cc.tar.zst
freebsd-ports-gnome-8dd913011e02825450bd9b3b2b5c326a543bf4cc.zip
Cut pine port over to u-boot-master.
Submitted by: Emmanuel Vadot
Diffstat (limited to 'sysutils/u-boot-pine64')
-rw-r--r--sysutils/u-boot-pine64/Makefile55
1 files changed, 9 insertions, 46 deletions
diff --git a/sysutils/u-boot-pine64/Makefile b/sysutils/u-boot-pine64/Makefile
index 6f071a0ef736..4e802ebb4c8b 100644
--- a/sysutils/u-boot-pine64/Makefile
+++ b/sysutils/u-boot-pine64/Makefile
@@ -1,53 +1,16 @@
# $FreeBSD$
-PORTNAME= u-boot
-PORTVERSION= 2016.05
-PORTREVISION= 1
-CATEGORIES= sysutils
-MASTER_SITES= ftp://ftp.denx.de/pub/u-boot/:uboot \
- http://download.opensuse.org/repositories/devel:/ARM:/Factory:/Contrib:/Pine64/standard/src/:firmware
-PKGNAMESUFFIX= -pine64
-DISTFILES= u-boot-${PORTVERSION}.tar.bz2:uboot \
- firmware-pine64-20160329-6.1.src.rpm:firmware
+MAINTAINER= manu@FreeBSD.org
+MASTERDIR= ${.CURDIR}/../u-boot-master
-MAINTAINER= brd@FreeBSD.org
-COMMENT= Cross-build U-Boot loader for Pine64
+MODEL= pine64
+BOARD_CONFIG= pine64_plus_defconfig
+FAMILY= allwinner64
-LICENSE= GPLv2
-
-BUILD_DEPENDS= aarch64-none-elf-gcc:devel/aarch64-none-elf-gcc
-
-WRKSRC= ${WRKDIR}/u-boot-${DISTVERSION}
-USES= gmake tar:bzip2
-SSP_UNSAFE= yes # cross-LD does not support -fstack-protector
-
-U_BOOT_DIR= share/u-boot/${PORTNAME}${PKGNAMESUFFIX}
-PLIST_FILES= ${U_BOOT_DIR}/pine64.img \
- ${U_BOOT_DIR}/README
-
-MAKE_ARGS+= ARCH=arm \
- CROSS_COMPILE=aarch64-none-elf- \
- PLAT=sun50iw1p1 \
- CONFIG_EFI=y
-
-post-extract:
- (cd ${WRKSRC}; ${EXTRACT_CMD} xvf ${DISTDIR}/firmware-pine64-20160329-6.1.src.rpm)
- ${RM} -r ${WRKSRC}/arm-trusted-firmware
- (cd ${WRKSRC}; ${EXTRACT_CMD} xvf pine64atf.tar.xz)
-
-do-configure:
- (cd ${WRKSRC}; ${MAKE_CMD} pine64_plus_defconfig)
+BUILD_DEPENDS= ${LOCALBASE}/share/atf-allwinner/bl31.bin:sysutils/atf-allwinner
+MAKE_ENV+= BL31=${LOCALBASE}/share/atf-allwinner/bl31.bin
post-build:
- (cd ${WRKSRC}/arm-trusted-firmware; ${GMAKE} ${MAKE_ARGS} DEBUG=1)
- (cd ${WRKSRC}; ${CC} -o pine64_image pine64_image.c)
- (cd ${WRKSRC}; ${CAT} arm-trusted-firmware/build/sun50iw1p1/debug/bl31.bin u-boot-dtb.bin > bl31uboot.bin)
- (cd ${WRKSRC}; ./pine64_image scp.bin bl31uboot.bin u-boot.img)
- (cd ${WRKSRC}; ${CAT} boot0.bin u-boot.img > pine64.img)
-
-do-install:
- ${MKDIR} ${STAGEDIR}/${PREFIX}/${U_BOOT_DIR}
- ${INSTALL_DATA} ${WRKSRC}/pine64.img ${STAGEDIR}/${PREFIX}/${U_BOOT_DIR}
- ${INSTALL_DATA} ${DESCR} ${STAGEDIR}/${PREFIX}/${U_BOOT_DIR}/README
+ ${CAT} ${WRKSRC}/spl/sunxi-spl.bin ${WRKSRC}/u-boot.itb > ${WRKSRC}/u-boot-sunxi-with-spl.bin
-.include <bsd.port.mk>
+.include "${MASTERDIR}/Makefile"