aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils/u-boot-rpi3
diff options
context:
space:
mode:
authorimp <imp@FreeBSD.org>2018-07-23 11:04:07 +0800
committerimp <imp@FreeBSD.org>2018-07-23 11:04:07 +0800
commit0b52f528eb261b82ad2074728ab522e104e70b93 (patch)
tree7fa9bb3b60bff83bba4d6dfd5ad349630d4d0b00 /sysutils/u-boot-rpi3
parent1e881fb54e07cf4e6635009248f1601286868c92 (diff)
downloadfreebsd-ports-gnome-0b52f528eb261b82ad2074728ab522e104e70b93.tar.gz
freebsd-ports-gnome-0b52f528eb261b82ad2074728ab522e104e70b93.tar.zst
freebsd-ports-gnome-0b52f528eb261b82ad2074728ab522e104e70b93.zip
Revert r475122, r475123 and r475124.
To manage upstream, we use the exact patches we've submitted upstream via their patchwork server. This deviates a little from a standard port, but it's what we do with all the other u-boot ports and isn't grossly out of line (many other ports pull patches during the build). We do it this way because the standard way was an unmanageable nightmare and resulted in divergence of u-boot ports. Approved by: uboot@ (maintainer of these ports) Differential Revision: https://reviews.freebsd.org/D16397
Diffstat (limited to 'sysutils/u-boot-rpi3')
-rw-r--r--sysutils/u-boot-rpi3/Makefile9
-rw-r--r--sysutils/u-boot-rpi3/files/patch-include_configs_rpi.h19
2 files changed, 7 insertions, 21 deletions
diff --git a/sysutils/u-boot-rpi3/Makefile b/sysutils/u-boot-rpi3/Makefile
index 8c1943db2050..7d7c8624c4fd 100644
--- a/sysutils/u-boot-rpi3/Makefile
+++ b/sysutils/u-boot-rpi3/Makefile
@@ -1,5 +1,6 @@
# $FreeBSD$
+MAINTAINER= uboot@FreeBSD.org
MASTERDIR= ${.CURDIR}/../u-boot-master
MODEL= rpi3
@@ -9,7 +10,11 @@ UBOOT_ARCH= aarch64
DEPENDS= ${LOCALBASE}/share/rpi-firmware/bootcode.bin:sysutils/rpi-firmware
-FRAGMENT_NAME= rpi3_fragment
-CONFIG_FRAGMENT= ${.CURDIR}/files/${FRAGMENT_NAME}
+EXTRA_PATCHES= ${.CURDIR}/files/
+PATCHFILES+= 937869/mbox/? \
+ 939129/mbox/?
+
+CONFIG_FRAGMENT= ${.CURDIR}/files/rpi3_fragment
+FRAGMENT_NAME= rpi3_fragment
.include "${MASTERDIR}/Makefile"
diff --git a/sysutils/u-boot-rpi3/files/patch-include_configs_rpi.h b/sysutils/u-boot-rpi3/files/patch-include_configs_rpi.h
deleted file mode 100644
index e3bd81d3d280..000000000000
--- a/sysutils/u-boot-rpi3/files/patch-include_configs_rpi.h
+++ /dev/null
@@ -1,19 +0,0 @@
---- include/configs/rpi.h.orig 2018-07-09 14:24:14 UTC
-+++ include/configs/rpi.h
-@@ -69,6 +69,8 @@
- #define CONFIG_MISC_INIT_R
- #endif
-
-+#define CONFIG_SYS_MMC_MAX_DEVICE 2
-+
- /* Console configuration */
- #define CONFIG_SYS_CBSIZE 1024
-
-@@ -150,6 +152,7 @@
-
- #define BOOT_TARGET_DEVICES(func) \
- func(MMC, mmc, 0) \
-+ func(MMC, mmc, 1) \
- func(USB, usb, 0) \
- func(PXE, pxe, na) \
- func(DHCP, dhcp, na)