aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils/unieject
diff options
context:
space:
mode:
authorsat <sat@FreeBSD.org>2006-07-23 22:19:52 +0800
committersat <sat@FreeBSD.org>2006-07-23 22:19:52 +0800
commit5eedc074d1e16b04d6b32d337e3f767bf034bb88 (patch)
tree0c8b1821b788372271fa7559a4a42401f4c13b6f /sysutils/unieject
parent77c82e383446ad1804820fa2550667f6f2316135 (diff)
downloadfreebsd-ports-gnome-5eedc074d1e16b04d6b32d337e3f767bf034bb88.tar.gz
freebsd-ports-gnome-5eedc074d1e16b04d6b32d337e3f767bf034bb88.tar.zst
freebsd-ports-gnome-5eedc074d1e16b04d6b32d337e3f767bf034bb88.zip
Add port sysutils/unieject:
Unieject is a drop-in replacement for usual eject command, which works on Linux and FreeBSD. It has more functionalities than FreeBSD's eject command, and it's partially compatible with Linux's one. It also features a library to access functions to lookup devices and mountpoints, unmount and eject devices. WWW: http://flameeyes.is-a-geek.org/projects#unieject
Diffstat (limited to 'sysutils/unieject')
-rw-r--r--sysutils/unieject/Makefile41
-rw-r--r--sysutils/unieject/distinfo3
-rw-r--r--sysutils/unieject/pkg-descr8
-rw-r--r--sysutils/unieject/pkg-plist17
4 files changed, 69 insertions, 0 deletions
diff --git a/sysutils/unieject/Makefile b/sysutils/unieject/Makefile
new file mode 100644
index 000000000000..e730a909b366
--- /dev/null
+++ b/sysutils/unieject/Makefile
@@ -0,0 +1,41 @@
+# New ports collection makefile for: unieject
+# Date created: 23 July 2006
+# Whom: Andrew Pantyukhin <infofarmer@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= unieject
+DISTVERSION= 5.3.2
+CATEGORIES= sysutils
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
+ ${MASTER_SITE_BERLIOS}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= infofarmer@FreeBSD.org
+COMMENT= Eject(1) replacement
+
+LIB_DEPENDS= cdio.7:${PORTSDIR}/sysutils/libcdio \
+ confuse.0:${PORTSDIR}/devel/libconfuse \
+ popt.0:${PORTSDIR}/devel/popt
+
+USE_GNOME= pkgconfig
+USE_LDCONFIG= yes
+USE_BZIP2= yes
+USE_GETTEXT= yes
+GNU_CONFIGURE= yes
+MAN1= unieject.1
+MAN5= unieject.conf.5
+
+CONFIGURE_ARGS= --with-libintl-prefix=${LOCALBASE} \
+ --with-libpopt-prefix=${LOCALBASE} --mandir=${MANPREFIX}/man
+
+post-patch:
+ ${REINPLACE_CMD} -e 's#if.*<<<$$DOXYFORMATS#if false#' ${WRKSRC}/configure
+ ${REINPLACE_CMD} -e 's#$$(libdir)/pkgconfig#${PREFIX}/libdata/pkgconfig#' ${WRKSRC}/Makefile.in
+ ${REINPLACE_CMD} -Ee 's#install-htmlDATA (install-man)#\1#' ${WRKSRC}/manpages/Makefile.in
+
+post-install:
+ ${INSTALL_DATA} ${WRKSRC}/unieject.conf.sample ${PREFIX}/etc/
+
+.include <bsd.port.mk>
diff --git a/sysutils/unieject/distinfo b/sysutils/unieject/distinfo
new file mode 100644
index 000000000000..103a91b38c36
--- /dev/null
+++ b/sysutils/unieject/distinfo
@@ -0,0 +1,3 @@
+MD5 (unieject-5.3.2.tar.bz2) = 57dd3ef72c72adf4cbe610ce3d52a25b
+SHA256 (unieject-5.3.2.tar.bz2) = b32077ffd9e1af94a048afc55591b4ec43ca67fa720218d47f9120cd00105c51
+SIZE (unieject-5.3.2.tar.bz2) = 337274
diff --git a/sysutils/unieject/pkg-descr b/sysutils/unieject/pkg-descr
new file mode 100644
index 000000000000..fa29d7e2e6a6
--- /dev/null
+++ b/sysutils/unieject/pkg-descr
@@ -0,0 +1,8 @@
+Unieject is a drop-in replacement for usual eject command, which works
+on Linux and FreeBSD. It has more functionalities than FreeBSD's eject
+command, and it's partially compatible with Linux's one.
+
+It also features a library to access functions to lookup devices and
+mountpoints, unmount and eject devices.
+
+WWW: http://flameeyes.is-a-geek.org/projects#unieject
diff --git a/sysutils/unieject/pkg-plist b/sysutils/unieject/pkg-plist
new file mode 100644
index 000000000000..59acbac798e0
--- /dev/null
+++ b/sysutils/unieject/pkg-plist
@@ -0,0 +1,17 @@
+bin/loadcd
+bin/unieject
+etc/unieject.conf.sample
+include/unieject/unieject.h
+lib/libunieject.a
+lib/libunieject.la
+lib/libunieject.so
+lib/libunieject.so.3
+libdata/pkgconfig/libunieject.pc
+share/locale/de/LC_MESSAGES/unieject.mo
+share/locale/es_AR/LC_MESSAGES/unieject.mo
+share/locale/es_ES/LC_MESSAGES/unieject.mo
+share/locale/it/LC_MESSAGES/unieject.mo
+share/locale/nl/LC_MESSAGES/unieject.mo
+share/locale/pt_BR/LC_MESSAGES/unieject.mo
+share/locale/pt/LC_MESSAGES/unieject.mo
+@dirrm include/unieject