aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils/usbhotkey
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2013-04-29 04:01:07 +0800
committerbapt <bapt@FreeBSD.org>2013-04-29 04:01:07 +0800
commit839ca29ce3909cfe75f51f01c6bfd6263cca79ac (patch)
tree8462df47de7a523e2debd710ebc0516911e33a43 /sysutils/usbhotkey
parent7a2d41eb20684123f01fb37f8af0b0c0bdfd1f26 (diff)
downloadfreebsd-ports-gnome-839ca29ce3909cfe75f51f01c6bfd6263cca79ac.tar.gz
freebsd-ports-gnome-839ca29ce3909cfe75f51f01c6bfd6263cca79ac.tar.zst
freebsd-ports-gnome-839ca29ce3909cfe75f51f01c6bfd6263cca79ac.zip
Convert left sysutils ports to new options framework
Diffstat (limited to 'sysutils/usbhotkey')
-rw-r--r--sysutils/usbhotkey/Makefile10
1 files changed, 7 insertions, 3 deletions
diff --git a/sysutils/usbhotkey/Makefile b/sysutils/usbhotkey/Makefile
index c32a6e923136..08e2afa56ec0 100644
--- a/sysutils/usbhotkey/Makefile
+++ b/sysutils/usbhotkey/Makefile
@@ -12,25 +12,29 @@ COMMENT= A utility to remap USB keyboards under X11
LIB_DEPENDS= hid.0:${PORTSDIR}/devel/libhid \
Xtst.6:${PORTSDIR}/x11/libXtst
-OPTIONS= GUI "Enable GUI bits (Imlib dependency)" on
+OPTIONS_DEFINE= GUI
+OPTIONS_DEFAULT= GUI
+GUI_DESC= Enable GUI bits (Imlib dependency)
USE_RUBY= yes
USE_GMAKE= yes
HAS_CONFIGURE= yes
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
CPPFLAGS+= -I${LOCALBASE}/include \
-I${LOCALBASE}/include/ruby-${RUBY_VER} \
-I${LOCALBASE}/include/ruby-${RUBY_VER}/${RUBY_ARCH}
LDFLAGS+= -L${LOCALBASE}/lib
-.if !defined(WITHOUT_GUI)
+.if ${PORT_OPTIONS:MGUI}
LIB_DEPENDS+= Imlib.5:${PORTSDIR}/graphics/imlib
.else
CONFIGURE_ARGS+= --without-Imlib
.endif
+.include <bsd.port.pre.mk>
+
.if ${RUBY_VER} == 1.9
EXTRA_PATCHES+= ${PATCHDIR}/extra-patch-main.c
.endif