aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils/usermin
diff options
context:
space:
mode:
authorolgeni <olgeni@FreeBSD.org>2004-06-20 18:53:14 +0800
committerolgeni <olgeni@FreeBSD.org>2004-06-20 18:53:14 +0800
commita7ac796f60cccb0286d078e6df42579b4a204801 (patch)
tree0ceabdb388792cf9ac8b2e79ffdb246f282692df /sysutils/usermin
parent86ea316834492f8fb55abf480bd0ae6fd2060761 (diff)
downloadfreebsd-ports-gnome-a7ac796f60cccb0286d078e6df42579b4a204801.tar.gz
freebsd-ports-gnome-a7ac796f60cccb0286d078e6df42579b4a204801.tar.zst
freebsd-ports-gnome-a7ac796f60cccb0286d078e6df42579b4a204801.zip
Fix ${PERL} insertion (unbreak -STABLE).
Diffstat (limited to 'sysutils/usermin')
-rw-r--r--sysutils/usermin/Makefile6
1 files changed, 4 insertions, 2 deletions
diff --git a/sysutils/usermin/Makefile b/sysutils/usermin/Makefile
index a02493a5ae8f..2b7bb2304f43 100644
--- a/sysutils/usermin/Makefile
+++ b/sysutils/usermin/Makefile
@@ -7,7 +7,7 @@
PORTNAME= usermin
PORTVERSION= 1.080
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= sysutils
MASTER_SITES= http://www.webmin.com/uupdates/ \
${MASTER_SITE_SOURCEFORGE}
@@ -41,7 +41,9 @@ post-extract:
post-patch:
@${REINPLACE_CMD} -e "s=%%PREFIX%%=${PREFIX}=" ${WRKSRC}/setup.sh
@${FIND} ${WRKSRC} -name "*.cgi" -print \
- | ${XARGS} ${REINPLACE_CMD} -e "s@/usr/local/bin/perl@${PERL}@"
+ | ${XARGS} ${REINPLACE_CMD} -e "s@#!/usr/local/bin/perl@#!${PERL}@"
+ @${FIND} ${WRKSRC} -name "*.pl" -print \
+ | ${XARGS} ${REINPLACE_CMD} -e "s@#!/usr/local/bin/perl@#!${PERL}@"
@${FIND} ${WRKSRC} -name "*.orig" -print | ${XARGS} ${RM}
@${FIND} ${WRKSRC} -name "*.bak" -print | ${XARGS} ${RM}
# we may have 2 levels of empty directories which cause the plist generation