aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils/wait_on
diff options
context:
space:
mode:
authorkris <kris@FreeBSD.org>2002-05-25 19:33:55 +0800
committerkris <kris@FreeBSD.org>2002-05-25 19:33:55 +0800
commit0df058a020026dd5c732804764f72e2313694efd (patch)
tree7bdb3be7569c38a75197d278de8090f67ed46af9 /sysutils/wait_on
parent6f72992f8b3d82ebf0da93245b80dcaefda2082f (diff)
downloadfreebsd-ports-gnome-0df058a020026dd5c732804764f72e2313694efd.tar.gz
freebsd-ports-gnome-0df058a020026dd5c732804764f72e2313694efd.tar.zst
freebsd-ports-gnome-0df058a020026dd5c732804764f72e2313694efd.zip
Add wait_on-1.0
The wait_on command allows shell scripts to access the facilities provided by kqueue(3). This allows scripts to detect files being added to directories, data appended to files and many other things - all without polling. Submitted by: Andrew Stevenson <andrew@ugh.net.au> PR: ports/34414
Diffstat (limited to 'sysutils/wait_on')
-rw-r--r--sysutils/wait_on/Makefile22
-rw-r--r--sysutils/wait_on/distinfo1
-rw-r--r--sysutils/wait_on/pkg-comment1
-rw-r--r--sysutils/wait_on/pkg-descr6
-rw-r--r--sysutils/wait_on/pkg-plist1
5 files changed, 31 insertions, 0 deletions
diff --git a/sysutils/wait_on/Makefile b/sysutils/wait_on/Makefile
new file mode 100644
index 000000000000..30341203acf9
--- /dev/null
+++ b/sysutils/wait_on/Makefile
@@ -0,0 +1,22 @@
+# New ports collection makefile for: wait_on
+# Date created: 29 Jan 2002
+# Whom: Andrew Stevenson <andrew@ugh.net.au>
+#
+# $FreeBSD$
+#
+
+PORTNAME= wait_on
+PORTVERSION= 1.0
+CATEGORIES= sysutils
+MASTER_SITES= ftp://ftp.ugh.net.au/pub/unix/wait_on/ \
+ ftp://ftp.megamirror.com/pub/ugh/unix/wait_on/ \
+ http://ftp.megamirror.com/pub/ugh/unix/wait_on/
+
+MAINTAINER= andrew@ugh.net.au
+
+WRKSRC= ${WRKDIR}/wait_on
+
+MAN1= wait_on.1
+MANCOMPRESSED= maybe
+
+.include <bsd.port.mk>
diff --git a/sysutils/wait_on/distinfo b/sysutils/wait_on/distinfo
new file mode 100644
index 000000000000..807c256aed80
--- /dev/null
+++ b/sysutils/wait_on/distinfo
@@ -0,0 +1 @@
+MD5 (wait_on-1.0.tar.gz) = 5cfb10e02ca7665c75d378bbe3218ff6
diff --git a/sysutils/wait_on/pkg-comment b/sysutils/wait_on/pkg-comment
new file mode 100644
index 000000000000..8068003d6d37
--- /dev/null
+++ b/sysutils/wait_on/pkg-comment
@@ -0,0 +1 @@
+Enable shell scripts to monitor directories for new files
diff --git a/sysutils/wait_on/pkg-descr b/sysutils/wait_on/pkg-descr
new file mode 100644
index 000000000000..873e2a8fc26d
--- /dev/null
+++ b/sysutils/wait_on/pkg-descr
@@ -0,0 +1,6 @@
+The wait_on command allows shell scripts to access the facilities provided by
+kqueue(3). This allows scripts to detect files being added to directories, data
+appended to files and many other things - all without polling.
+
+Andrew Stevenson
+andrew@ugh.net.au
diff --git a/sysutils/wait_on/pkg-plist b/sysutils/wait_on/pkg-plist
new file mode 100644
index 000000000000..6dff146139ee
--- /dev/null
+++ b/sysutils/wait_on/pkg-plist
@@ -0,0 +1 @@
+bin/wait_on