aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils/webmin/Makefile
diff options
context:
space:
mode:
authorandreas <andreas@FreeBSD.org>1998-11-20 05:38:24 +0800
committerandreas <andreas@FreeBSD.org>1998-11-20 05:38:24 +0800
commitdfc51b8a5449ceffb0d67f747299e8863e096407 (patch)
treebc76f0b46f1b1f264896fd2610cbf33f6aec9bb2 /sysutils/webmin/Makefile
parent5c2b44797c280ad7d533dcc3945b10737a5dc8ab (diff)
downloadfreebsd-ports-gnome-dfc51b8a5449ceffb0d67f747299e8863e096407.tar.gz
freebsd-ports-gnome-dfc51b8a5449ceffb0d67f747299e8863e096407.tar.zst
freebsd-ports-gnome-dfc51b8a5449ceffb0d67f747299e8863e096407.zip
new port webmin v0.64
Webmin is a web-based interface for system administration for Unix. Using any browser that supports tables and forms, you can setup user accounts, Apache, DNS, file sharing and so on. Webmin consists of a simple web server, and a number of CGI programs which directly update system files like /etc/inetd.conf and /etc/passwd. The web server and all CGI programs are written in Perl version 5, and use no external modules. This means that you only need a Perl binary to run Webmin. More infos: http://www.webmin.com/webmin/
Diffstat (limited to 'sysutils/webmin/Makefile')
-rw-r--r--sysutils/webmin/Makefile24
1 files changed, 24 insertions, 0 deletions
diff --git a/sysutils/webmin/Makefile b/sysutils/webmin/Makefile
new file mode 100644
index 000000000000..1c98e6836686
--- /dev/null
+++ b/sysutils/webmin/Makefile
@@ -0,0 +1,24 @@
+# New ports collection makefile for: webmin
+# Version required: 0.64
+# Date created: Do 19 Nov 1998 21:13:55 CET
+# Whom: Andreas Klemm <andreas@klemm.gtn.com>
+#
+# $Id: Makefile,v 1.6 1997/10/09 21:04:45 andreas Exp $
+#
+
+DISTNAME= webmin-0.64
+CATEGORIES= sysutils
+MASTER_SITES= http://www.webmin.com/webmin/download/
+
+MAINTAINER= andreas@FreeBSD.ORG
+
+NO_BUILD= yes
+IS_INTERACTIVE= yes
+
+do-install:
+ ${MKDIR} ${PREFIX}/lib/webmin
+ ${CP} -r ${WRKSRC}/* ${PREFIX}/lib/webmin
+ @cd ${PREFIX}/lib/webmin && find . -name "*.orig" -print | xargs rm
+ @cd ${PREFIX}/lib/webmin && ./setup.sh
+
+.include <bsd.port.mk>