aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils/webmin/Makefile
diff options
context:
space:
mode:
authorandreas <andreas@FreeBSD.org>2000-11-01 21:09:35 +0800
committerandreas <andreas@FreeBSD.org>2000-11-01 21:09:35 +0800
commit06e490fef5a37671b42d393474a527c34ed5bf61 (patch)
tree3384e48bed3668518fc9ade08ef4d437db758033 /sysutils/webmin/Makefile
parent44f0799a42a26be2f3e67144433ec6f988169210 (diff)
downloadfreebsd-ports-gnome-06e490fef5a37671b42d393474a527c34ed5bf61.tar.gz
freebsd-ports-gnome-06e490fef5a37671b42d393474a527c34ed5bf61.tar.zst
freebsd-ports-gnome-06e490fef5a37671b42d393474a527c34ed5bf61.zip
Upgrade webmin port from 0.80 to 0.82
Obtained patches from James (see PR) Further enhancements from me: - make port portlint clean - remove webmins behaviour, to write its startup code to /etc/rc.local a) this behaviour is discouraged now in FreeBSD b) it blindly appended the startup code at the end of rc.local ... my last line is exit 0, so startup code never has been executed. - wrote simple startup script that will be installed in our usual place. did that PREFIX-clean(tm) - added FreeBSD 4.1 and 4.2 to the os-list ... PR: 22312 Submitted by: "James E. Housley" <jeh@FreeBSD.org>
Diffstat (limited to 'sysutils/webmin/Makefile')
-rw-r--r--sysutils/webmin/Makefile14
1 files changed, 8 insertions, 6 deletions
diff --git a/sysutils/webmin/Makefile b/sysutils/webmin/Makefile
index 00ae071df4af..364b5e52e713 100644
--- a/sysutils/webmin/Makefile
+++ b/sysutils/webmin/Makefile
@@ -6,13 +6,13 @@
#
PORTNAME= webmin
-PORTVERSION= 0.80
+PORTVERSION= 0.82
CATEGORIES= sysutils
MASTER_SITES= http://www.webmin.com/webmin/download/
MAINTAINER= andreas@FreeBSD.org
-BUILD_DEPENDS= ${PREFIX}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/Net/SSLeay.pm:${PORTSDIR}/security/p5-Net-SSLeay
+BUILD_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/Net/SSLeay.pm:${PORTSDIR}/security/p5-Net-SSLeay
NO_BUILD= yes
IS_INTERACTIVE= yes
@@ -29,9 +29,11 @@ post-patch:
${WRKDIR}/webmin-${PORTVERSION}/bind8/config-freebsd-3.4
do-install:
- ${MKDIR} ${PREFIX}/lib/webmin
- ${CP} -r ${WRKSRC}/* ${PREFIX}/lib/webmin
- @cd ${PREFIX}/lib/webmin && find . -name "*.orig" -print | xargs ${RM}
- @cd ${PREFIX}/lib/webmin && ./setup.sh
+ ${MKDIR} ${LOCALBASE}/lib/webmin
+ ${CP} -r ${WRKSRC}/* ${LOCALBASE}/lib/webmin
+ @cd ${LOCALBASE}/lib/webmin && find . -name "*.orig" -print \
+ | xargs ${RM}
+ @cd ${LOCALBASE}/lib/webmin && ./setup.sh
+ ${MV} /tmp/webmin.sh ${LOCALBASE}/etc/rc.d/webmin.sh
.include <bsd.port.mk>