aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils/webmin
diff options
context:
space:
mode:
authorknu <knu@FreeBSD.org>2002-01-29 19:58:52 +0800
committerknu <knu@FreeBSD.org>2002-01-29 19:58:52 +0800
commit0178e4d2a90833e31a5bb31c9387dd658f3dbfb5 (patch)
treeb3f1b0618b200ee64749bca7efebf43d80503638 /sysutils/webmin
parent5b243306947e74184be0fc39cd0f0d1eb8063940 (diff)
downloadfreebsd-ports-gnome-0178e4d2a90833e31a5bb31c9387dd658f3dbfb5.tar.gz
freebsd-ports-gnome-0178e4d2a90833e31a5bb31c9387dd658f3dbfb5.tar.zst
freebsd-ports-gnome-0178e4d2a90833e31a5bb31c9387dd658f3dbfb5.zip
Use ${ECHO_CMD} instead of ${ECHO} where you mean the echo command;
the ECHO macro is set to "echo" by default, but it is set to "true" if make(1) is invoked with the -s option while ECHO_CMD is always set to the echo command.
Diffstat (limited to 'sysutils/webmin')
-rw-r--r--sysutils/webmin/Makefile10
1 files changed, 5 insertions, 5 deletions
diff --git a/sysutils/webmin/Makefile b/sysutils/webmin/Makefile
index 299613219cbb..8c72fcb045c9 100644
--- a/sysutils/webmin/Makefile
+++ b/sysutils/webmin/Makefile
@@ -79,11 +79,11 @@ post-install:
| ${SED} -e 's/^/@dirrm /g' \
>> ${WRKDIR}/PLIST.lib-webmin
- @${ECHO} "r ${TMPPLIST}" > ${WRKDIR}/ex.script
- @${ECHO} "/Insert PLIST.lib-webmin" >> ${WRKDIR}/ex.script
- @${ECHO} "d" >> ${WRKDIR}/ex.script
- @${ECHO} "r ${WRKDIR}/PLIST.lib-webmin" >> ${WRKDIR}/ex.script
- @${ECHO} "x!" >> ${WRKDIR}/ex.script
+ @${ECHO_CMD} "r ${TMPPLIST}" > ${WRKDIR}/ex.script
+ @${ECHO_CMD} "/Insert PLIST.lib-webmin" >> ${WRKDIR}/ex.script
+ @${ECHO_CMD} "d" >> ${WRKDIR}/ex.script
+ @${ECHO_CMD} "r ${WRKDIR}/PLIST.lib-webmin" >> ${WRKDIR}/ex.script
+ @${ECHO_CMD} "x!" >> ${WRKDIR}/ex.script
@${CP} -p ${TMPPLIST} ${TMPPLIST}.pre-lib-webmin
@cd ${WRKDIR} ; ex < ex.script
# upgrade configuration if etc/webmin exists