aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils/xbattbar
diff options
context:
space:
mode:
authornaddy <naddy@FreeBSD.org>2012-04-06 00:23:24 +0800
committernaddy <naddy@FreeBSD.org>2012-04-06 00:23:24 +0800
commit5ef96f83d7fec552031cbe089985dc7421b3090b (patch)
tree33053fc60368400055bcfe061b440ee8c6d4dd8a /sysutils/xbattbar
parentd4241ec330ac85dbf018dafb6a8ba595846703cf (diff)
downloadfreebsd-ports-gnome-5ef96f83d7fec552031cbe089985dc7421b3090b.tar.gz
freebsd-ports-gnome-5ef96f83d7fec552031cbe089985dc7421b3090b.tar.zst
freebsd-ports-gnome-5ef96f83d7fec552031cbe089985dc7421b3090b.zip
* Include proper prototypes for exit() and strlen().
* Fix a spelling error in the description of a command line argument. Approved by: sumikawa Feature safe: yes
Diffstat (limited to 'sysutils/xbattbar')
-rw-r--r--sysutils/xbattbar/Makefile2
-rw-r--r--sysutils/xbattbar/files/patch-xbattbar.c17
-rw-r--r--sysutils/xbattbar/files/patch-xbattbar.man11
3 files changed, 25 insertions, 5 deletions
diff --git a/sysutils/xbattbar/Makefile b/sysutils/xbattbar/Makefile
index 0681645811f5..93d1f2b62077 100644
--- a/sysutils/xbattbar/Makefile
+++ b/sysutils/xbattbar/Makefile
@@ -7,7 +7,7 @@
PORTNAME= xbattbar
PORTVERSION= 1.4.2
-PORTREVISION= 6
+PORTREVISION= 7
CATEGORIES= sysutils
MASTER_SITES= http://iplab.aist-nara.ac.jp/member/suguru/
DISTNAME= ${PORTNAME}_${PORTVERSION}
diff --git a/sysutils/xbattbar/files/patch-xbattbar.c b/sysutils/xbattbar/files/patch-xbattbar.c
index 3b26d420158e..65d3eaa7b1f8 100644
--- a/sysutils/xbattbar/files/patch-xbattbar.c
+++ b/sysutils/xbattbar/files/patch-xbattbar.c
@@ -1,6 +1,15 @@
---- xbattbar.c.orig Fri Feb 2 13:25:29 2001
-+++ xbattbar.c Wed Dec 13 00:35:49 2006
-@@ -501,6 +501,10 @@
+--- xbattbar.c.orig 2001-02-02 06:25:29.000000000 +0100
++++ xbattbar.c 2012-04-04 17:47:34.000000000 +0200
+@@ -29,6 +29,8 @@ static char *ReleaseVersion="1.4.2";
+ #include <sys/time.h>
+ #include <signal.h>
+ #include <stdio.h>
++#include <stdlib.h>
++#include <string.h>
+ #include <unistd.h>
+ #include <sys/file.h>
+ #include <sys/ioctl.h>
+@@ -501,6 +503,10 @@ void battery_check(void)
#ifdef __FreeBSD__
@@ -11,7 +20,7 @@
#include <machine/apm_bios.h>
#define APMDEV21 "/dev/apm0"
-@@ -515,54 +519,90 @@
+@@ -515,54 +521,90 @@ void battery_check(void)
#define APM_STAT_BATT_LOW 1
#define APM_STAT_BATT_CRITICAL 2
#define APM_STAT_BATT_CHARGING 3
diff --git a/sysutils/xbattbar/files/patch-xbattbar.man b/sysutils/xbattbar/files/patch-xbattbar.man
new file mode 100644
index 000000000000..dfc205599164
--- /dev/null
+++ b/sysutils/xbattbar/files/patch-xbattbar.man
@@ -0,0 +1,11 @@
+--- xbattbar.man.orig 2012-04-04 17:49:01.000000000 +0200
++++ xbattbar.man 2012-04-04 17:49:17.000000000 +0200
+@@ -58,7 +58,7 @@ forces the status indicator to be at the
+ display,
+ respectively.
+ Though it's a default, you can also use
+-.Nm buttom
++.Nm bottom
+ as the option.
+ .Pp
+ In the case the AC line is on-line (plugged in),