aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils/xfce4-battery-plugin/Makefile
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2011-03-17 23:46:49 +0800
committermiwi <miwi@FreeBSD.org>2011-03-17 23:46:49 +0800
commite892783202238963206f1146cf23f5ca326028bf (patch)
tree3da842e1526e8599998d06a1aaea1c303f28b6b0 /sysutils/xfce4-battery-plugin/Makefile
parent2eceaae6c042276836508ad38d3388984816517f (diff)
downloadfreebsd-ports-gnome-e892783202238963206f1146cf23f5ca326028bf.tar.gz
freebsd-ports-gnome-e892783202238963206f1146cf23f5ca326028bf.tar.zst
freebsd-ports-gnome-e892783202238963206f1146cf23f5ca326028bf.zip
- Update to 1.0.0
PR: 153661 Submitted by: Olivier Duchateau <duchateau.olivier@gmail.com>
Diffstat (limited to 'sysutils/xfce4-battery-plugin/Makefile')
-rw-r--r--sysutils/xfce4-battery-plugin/Makefile27
1 files changed, 21 insertions, 6 deletions
diff --git a/sysutils/xfce4-battery-plugin/Makefile b/sysutils/xfce4-battery-plugin/Makefile
index 437475bf31ca..267c428a3fcf 100644
--- a/sysutils/xfce4-battery-plugin/Makefile
+++ b/sysutils/xfce4-battery-plugin/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= xfce4-battery-plugin
-PORTVERSION= 0.5.1
-PORTREVISION= 9
+PORTVERSION= 1.0.0
CATEGORIES= sysutils xfce
MASTER_SITES= ${MASTER_SITE_XFCE}
MASTER_SITE_SUBDIR=/src/panel-plugins/${PORTNAME}/${PORTVERSION:R}
@@ -18,11 +17,27 @@ COMMENT= Battery monitor panel plugin for XFce4
ONLY_FOR_ARCHS= i386 amd64
+USE_AUTOTOOLS= libtool
GNU_CONFIGURE= yes
USE_BZIP2= yes
-USE_GETTEXT= yes
USE_GMAKE= yes
-USE_GNOME= gnometarget gtk20 intltool intlhack pkgconfig
-USE_XFCE= configenv panel
+USE_GNOME= gnomehack gtk20 glib20 intltool intlhack pkgconfig
+USE_XFCE= configenv libgui libutil panel
+INSTALLS_ICONS= yes
+
+CONFIGURE_ARGS= --disable-debug
+
+OPTIONS= NLS "Enable Native Language Support" on
+
+.include <bsd.port.pre.mk>
+
+.if !defined(WITHOUT_NLS)
+USE_GETTEXT= yes
+CONFIGURE_ARGS+=--enable-nls
+PLIST_SUB+= NLS=""
+.else
+CONFIGURE_ARGS+=--disable-nls
+PLIST_SUB+= NLS="@comment "
+.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>