aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils/xfce4-battery-plugin
diff options
context:
space:
mode:
authorlawrance <lawrance@FreeBSD.org>2006-02-11 22:43:19 +0800
committerlawrance <lawrance@FreeBSD.org>2006-02-11 22:43:19 +0800
commit815ff22036a23a62ef261eb8f4c0ce3ee2b39406 (patch)
treee252c7570c70017376bfd582977e7bf7607a8c4a /sysutils/xfce4-battery-plugin
parentdf3c5dfecb62e6294f64e14b246087dc6cc3e60a (diff)
downloadfreebsd-ports-gnome-815ff22036a23a62ef261eb8f4c0ce3ee2b39406.tar.gz
freebsd-ports-gnome-815ff22036a23a62ef261eb8f4c0ce3ee2b39406.tar.zst
freebsd-ports-gnome-815ff22036a23a62ef261eb8f4c0ce3ee2b39406.zip
Correctly define APMDEVICE for FreeBSD.
PR: ports/91815 Submitted by: Darren L. LaChausse <dlachausse@yahoo.com> Approved by: thorsten.greiner@web.de (maintainer, timeout 4 weeks)
Diffstat (limited to 'sysutils/xfce4-battery-plugin')
-rw-r--r--sysutils/xfce4-battery-plugin/Makefile2
-rw-r--r--sysutils/xfce4-battery-plugin/files/patch-panel-plugin::battmon.c14
2 files changed, 12 insertions, 4 deletions
diff --git a/sysutils/xfce4-battery-plugin/Makefile b/sysutils/xfce4-battery-plugin/Makefile
index 642a15b432bd..18b32c4bc514 100644
--- a/sysutils/xfce4-battery-plugin/Makefile
+++ b/sysutils/xfce4-battery-plugin/Makefile
@@ -7,7 +7,7 @@
PORTNAME= xfce4-battery-plugin
PORTVERSION= 0.2.0
-PORTREVISION= 6
+PORTREVISION= 7
CATEGORIES= sysutils xfce
MASTER_SITES= http://download.berlios.de/xfce-goodies/
DIST_SUBDIR= xfce4
diff --git a/sysutils/xfce4-battery-plugin/files/patch-panel-plugin::battmon.c b/sysutils/xfce4-battery-plugin/files/patch-panel-plugin::battmon.c
index eb040a1e0f44..b6ac06a7275f 100644
--- a/sysutils/xfce4-battery-plugin/files/patch-panel-plugin::battmon.c
+++ b/sysutils/xfce4-battery-plugin/files/patch-panel-plugin::battmon.c
@@ -1,6 +1,14 @@
---- panel-plugin/battmon.c.orig Fri Sep 12 23:38:01 2003
-+++ panel-plugin/battmon.c Fri Sep 12 23:38:24 2003
-@@ -362,6 +362,7 @@
+--- panel-plugin/battmon.c.orig Sat Feb 11 23:43:01 2006
++++ panel-plugin/battmon.c Sat Feb 11 23:43:07 2006
+@@ -33,6 +33,7 @@
+
+ #ifdef __FreeBSD__
+ #include <machine/apm_bios.h>
++#define APMDEVICE "/dev/apm"
+ #elif __OpenBSD__
+ #include <sys/param.h>
+ #include <machine/apmvar.h>
+@@ -362,6 +363,7 @@
if(charge < 0) charge = 0;