aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils/xfce4-systemload-plugin/Makefile
diff options
context:
space:
mode:
authoroliver <oliver@FreeBSD.org>2003-08-01 22:35:59 +0800
committeroliver <oliver@FreeBSD.org>2003-08-01 22:35:59 +0800
commit79d38f88e343b835f409e50fa08f5d7bbc7e0d72 (patch)
tree6cbfc1a9c0b81effb062923b8a6cdcabf1d0a377 /sysutils/xfce4-systemload-plugin/Makefile
parent338bde0281a87d5c0554e09d5205987e13740ad9 (diff)
downloadfreebsd-ports-gnome-79d38f88e343b835f409e50fa08f5d7bbc7e0d72.tar.gz
freebsd-ports-gnome-79d38f88e343b835f409e50fa08f5d7bbc7e0d72.tar.zst
freebsd-ports-gnome-79d38f88e343b835f409e50fa08f5d7bbc7e0d72.zip
Add xfce4-systemload-plugin 0.3.2, system Load plugin for XFce4.
PR: 55133 Submitted by: Thorsten Greiner <thorsten.greiner@web.de>
Diffstat (limited to 'sysutils/xfce4-systemload-plugin/Makefile')
-rw-r--r--sysutils/xfce4-systemload-plugin/Makefile29
1 files changed, 29 insertions, 0 deletions
diff --git a/sysutils/xfce4-systemload-plugin/Makefile b/sysutils/xfce4-systemload-plugin/Makefile
new file mode 100644
index 000000000000..110ea648d8f2
--- /dev/null
+++ b/sysutils/xfce4-systemload-plugin/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: xfce-systemload-plugin
+# Date created: 31 June 2003
+# Whom: Thorsten Greiner <thorsten.greiner@web.de>
+#
+# $FreeBSD$
+#
+
+PORTNAME= xfce4-systemload-plugin
+PORTVERSION= 0.3.2
+CATEGORIES= sysutils
+MASTER_SITES= http://download.berlios.de/xfce-goodies/
+DIST_SUBDIR= xfce4
+
+MAINTAINER= thorsten.greiner@web.de
+COMMENT= System Load plugin for XFce4
+
+BUILD_DEPENDS= xfce4-panel:${PORTSDIR}/x11-wm/xfce4-panel
+LIB_DEPENDS= xml2.5:${PORTSDIR}/textproc/libxml2 \
+ xfce4util.1:${PORTSDIR}/x11/libxfce4util \
+ xfcegui4.1:${PORTSDIR}/x11-toolkits/libxfce4gui
+
+USE_GNOME= gtk20
+USE_X_PREFIX= yes
+GNU_CONFIGURE= yes
+USE_LIBTOOL= yes
+INSTALLS_SHLIB= yes
+CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
+
+.include <bsd.port.mk>