aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils/xfsprogs
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2015-02-26 09:26:49 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2015-02-26 09:26:49 +0800
commit5c8af82adaeea0f8dd4cbba0b279bf87b7f3e466 (patch)
treeeadf2895da5819a607848e01d78b3d28c47a5408 /sysutils/xfsprogs
parent1ae4a0171d5c669dea99bb3a9c1aa62fa777c980 (diff)
downloadfreebsd-ports-gnome-5c8af82adaeea0f8dd4cbba0b279bf87b7f3e466.tar.gz
freebsd-ports-gnome-5c8af82adaeea0f8dd4cbba0b279bf87b7f3e466.tar.zst
freebsd-ports-gnome-5c8af82adaeea0f8dd4cbba0b279bf87b7f3e466.zip
- Strip binaries
Diffstat (limited to 'sysutils/xfsprogs')
-rw-r--r--sysutils/xfsprogs/Makefile10
1 files changed, 9 insertions, 1 deletions
diff --git a/sysutils/xfsprogs/Makefile b/sysutils/xfsprogs/Makefile
index c4f05f340dac..05191d2a0a93 100644
--- a/sysutils/xfsprogs/Makefile
+++ b/sysutils/xfsprogs/Makefile
@@ -21,7 +21,7 @@ USES= gettext gmake libtool:build readline
GNU_CONFIGURE= yes
CONFIGURE_ENV= OPTIMIZER=" "
CONFIGURE_ARGS= --disable-shared --enable-readline
-ALL_TARGET=
+ALL_TARGET= # empty
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
@@ -46,4 +46,12 @@ post-patch:
@${REINPLACE_CMD} 's|$$(PKG_LOCALE_DIR)|$$(DESTDIR)&|' \
${WRKSRC}/include/buildmacros
+post-install:
+.for f in xfs_db xfs_growfs xfs_io xfs_logprint xfs_mdrestore xfs_quota xfs_rtcp
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/${f}
+.endfor
+.for f in xfs_repair mkfs.xfs
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/sbin/${f}
+.endfor
+
.include <bsd.port.mk>