aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils/xorriso
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2008-12-07 22:33:16 +0800
committermiwi <miwi@FreeBSD.org>2008-12-07 22:33:16 +0800
commit0ea62e5c06ee08f6a81cdc797f6c10bcc7df36d5 (patch)
treecb25f72d5c42358dfbc13649b71d3d0149feff1c /sysutils/xorriso
parent864e911647c28f57f4004f3c82476fb2ed5e5943 (diff)
downloadfreebsd-ports-gnome-0ea62e5c06ee08f6a81cdc797f6c10bcc7df36d5.tar.gz
freebsd-ports-gnome-0ea62e5c06ee08f6a81cdc797f6c10bcc7df36d5.tar.zst
freebsd-ports-gnome-0ea62e5c06ee08f6a81cdc797f6c10bcc7df36d5.zip
Libisoburn is a front-end for libraries libburn and libisofs of
the libburnia project. Xorriso copies file objects from POSIX compliant filesystems into Rock Ridge enhanced ISO 9660 filesystems and allows session-wise manipulation of such filesystems. It can load the management information of existing ISO images and it writes the session results to optical media or to filesystem objects. Vice versa xorriso is able to restore file objects from ISO 9660 filesystems. WWW: http://libburnia-project.org/ WWW: http://scdbackup.sourceforge.net/xorriso_eng.html PR: ports/129265 Submitted by: J.R. Oldroyd <fbsd at opal.com>
Diffstat (limited to 'sysutils/xorriso')
-rw-r--r--sysutils/xorriso/Makefile36
-rw-r--r--sysutils/xorriso/distinfo3
-rw-r--r--sysutils/xorriso/files/patch-xorriso-xorriso.c11
-rw-r--r--sysutils/xorriso/pkg-descr12
-rw-r--r--sysutils/xorriso/pkg-plist12
5 files changed, 74 insertions, 0 deletions
diff --git a/sysutils/xorriso/Makefile b/sysutils/xorriso/Makefile
new file mode 100644
index 000000000000..66bf3a750466
--- /dev/null
+++ b/sysutils/xorriso/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: libisoburn
+# Date created: 2008 November 13
+# Whom: J.R. Oldroyd <fbsd@opal.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= libisoburn
+PORTVERSION= 0.2.8
+CATEGORIES= sysutils
+MASTER_SITES= http://files.libburnia-project.org/releases/
+DISTFILES= ${PORTNAME}-${PORTVERSION}.pl00${EXTRACT_SUFX}
+
+MAINTAINER= fbsd@opal.com
+COMMENT= ISO image manipulation tool based on Libburnia
+
+LIB_DEPENDS= burn.23:${PORTSDIR}/devel/libburn \
+ isofs.12:${PORTSDIR}/devel/libisofs
+
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= CFLAGS="-I${PREFIX}/include" \
+ LDFLAGS="-lcam -L${PREFIX}/lib -liconv"
+
+WANT_GNOME= yes
+USE_GNOME= pkgconfig
+USE_GMAKE= yes
+USE_ICONV= yes
+USE_LDCONFIG= yes
+
+MAN1= xorriso.1
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|(libdir)/pkgconfig|(prefix)/libdata/pkgconfig|;' \
+ ${WRKSRC}/Makefile.in
+
+.include <bsd.port.mk>
diff --git a/sysutils/xorriso/distinfo b/sysutils/xorriso/distinfo
new file mode 100644
index 000000000000..0f0a553dd7a2
--- /dev/null
+++ b/sysutils/xorriso/distinfo
@@ -0,0 +1,3 @@
+MD5 (libisoburn-0.2.8.pl00.tar.gz) = cbdb7f3787a1f92f65083540de1e9724
+SHA256 (libisoburn-0.2.8.pl00.tar.gz) = dbaa674e5e436b7234bb65847ea4fe7a9561ee6440603ff97638b5c72b83c555
+SIZE (libisoburn-0.2.8.pl00.tar.gz) = 565381
diff --git a/sysutils/xorriso/files/patch-xorriso-xorriso.c b/sysutils/xorriso/files/patch-xorriso-xorriso.c
new file mode 100644
index 000000000000..858d4cf9a5db
--- /dev/null
+++ b/sysutils/xorriso/files/patch-xorriso-xorriso.c
@@ -0,0 +1,11 @@
+--- xorriso/xorriso.c.orig 2008-10-12 08:44:35.000000000 -0400
++++ xorriso/xorriso.c 2008-11-13 18:24:49.000000000 -0500
+@@ -89,6 +89,8 @@
+ #include <utime.h>
+ #include <pwd.h>
+ #include <grp.h>
++#include <sys/types.h>
++#include <signal.h>
+
+ /* eventually, this is done in xorriso_private.h : #include <regex.h> */
+
diff --git a/sysutils/xorriso/pkg-descr b/sysutils/xorriso/pkg-descr
new file mode 100644
index 000000000000..18a67e619dec
--- /dev/null
+++ b/sysutils/xorriso/pkg-descr
@@ -0,0 +1,12 @@
+Libisoburn is a front-end for libraries libburn and libisofs of
+the libburnia project.
+
+Xorriso copies file objects from POSIX compliant filesystems into
+Rock Ridge enhanced ISO 9660 filesystems and allows session-wise
+manipulation of such filesystems. It can load the management
+information of existing ISO images and it writes the session results
+to optical media or to filesystem objects. Vice versa xorriso is
+able to restore file objects from ISO 9660 filesystems.
+
+WWW: http://libburnia-project.org/
+WWW: http://scdbackup.sourceforge.net/xorriso_eng.html
diff --git a/sysutils/xorriso/pkg-plist b/sysutils/xorriso/pkg-plist
new file mode 100644
index 000000000000..d4b9d3db9dfb
--- /dev/null
+++ b/sysutils/xorriso/pkg-plist
@@ -0,0 +1,12 @@
+bin/osirrox
+bin/xorrecord
+bin/xorriso
+bin/xorrisofs
+include/libisoburn/libisoburn.h
+lib/libisoburn.a
+lib/libisoburn.la
+lib/libisoburn.so
+lib/libisoburn.so.18
+libdata/pkgconfig/libisoburn-1.pc
+@dirrm include/libisoburn
+@dirrmtry libdata/pkgconfig