aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils/zfsnap
diff options
context:
space:
mode:
authoreugen <eugen@FreeBSD.org>2018-01-23 01:05:49 +0800
committereugen <eugen@FreeBSD.org>2018-01-23 01:05:49 +0800
commiteef66c4f9f1707366b06c210ae165aabc3d90fc3 (patch)
tree73e5ced4ac8644f2327c252d3242dfa5df57827a /sysutils/zfsnap
parente8a7e8637c7426a163d6c4462b2dc21436f9f500 (diff)
downloadfreebsd-ports-gnome-eef66c4f9f1707366b06c210ae165aabc3d90fc3.tar.gz
freebsd-ports-gnome-eef66c4f9f1707366b06c210ae165aabc3d90fc3.tar.zst
freebsd-ports-gnome-eef66c4f9f1707366b06c210ae165aabc3d90fc3.zip
sysutils/zfsnap: fix -s/-S mode.
Move creation of files from "do-patch" to "post-extract" target, so that patches from files/ directory get applied. While here, add LICENSE. PR: 223951 Submitted by: Anton Sayetsky <vsasjason@gmail.com> (based on) Approved by: yamagi@yamagi.org (maintainer timeout, 7 weeks)
Diffstat (limited to 'sysutils/zfsnap')
-rw-r--r--sysutils/zfsnap/Makefile5
-rw-r--r--sysutils/zfsnap/files/patch-zfSnap.sh11
2 files changed, 15 insertions, 1 deletions
diff --git a/sysutils/zfsnap/Makefile b/sysutils/zfsnap/Makefile
index 47ae2c774567..5c8302ccacdc 100644
--- a/sysutils/zfsnap/Makefile
+++ b/sysutils/zfsnap/Makefile
@@ -4,18 +4,21 @@
PORTNAME= zfsnap
PORTVERSION= 1.11.1
DISTVERSIONPREFIX= v
+PORTREVISION= 1
CATEGORIES= sysutils
MAINTAINER= yamagi@yamagi.org
COMMENT= Simple sh script to make zfs rolling snaphosts with cron
+LICENSE= BSD3CLAUSE
+
NO_BUILD= yes
USE_GITHUB= yes
PERIODICDIR?= ${PREFIX}/etc/periodic
PLIST_SUB+= PERIODICDIR="${PERIODICDIR:S,^${PREFIX}/,,}"
-do-patch:
+post-extract:
.for period in hourly daily weekly monthly reboot
@${SED} -e "s/xPERIODICx/${period}/g" -e "s#xPREFIXx#${PREFIX}/sbin#g" ${WRKSRC}/xPERIODICx_zfSnap.sh > ${WRKSRC}/${period}_zfSnap.sh
.endfor
diff --git a/sysutils/zfsnap/files/patch-zfSnap.sh b/sysutils/zfsnap/files/patch-zfSnap.sh
new file mode 100644
index 000000000000..1cdd609dd8b3
--- /dev/null
+++ b/sysutils/zfsnap/files/patch-zfSnap.sh
@@ -0,0 +1,11 @@
+--- zfSnap.sh.orig 2013-01-18 03:37:09.000000000 +0700
++++ zfSnap.sh 2018-01-22 23:20:20.257104000 +0700
+@@ -199,6 +199,8 @@ rm_zfs_snapshot() {
+ }
+
+ skip_pool() {
++ local i
++
+ # more like skip pool???
+ if is_true $scrub_skip; then
+ for i in $scrub_pools; do