aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2004-07-05 05:46:17 +0800
committerpav <pav@FreeBSD.org>2004-07-05 05:46:17 +0800
commit0206ffca65a69387f7bdd2c86077497a309929dd (patch)
tree57a79c40e5f9798b0bbf707ba31fe0036a96e4d9 /sysutils
parent8fd095c333a5c905380cc69f340d6e3d6edb74b5 (diff)
downloadfreebsd-ports-gnome-0206ffca65a69387f7bdd2c86077497a309929dd.tar.gz
freebsd-ports-gnome-0206ffca65a69387f7bdd2c86077497a309929dd.tar.zst
freebsd-ports-gnome-0206ffca65a69387f7bdd2c86077497a309929dd.zip
- Update to 12
added rule bsd.port.pre.mk depends on bsd.port.mk use real describe file path when generating readme.html added freebsd port of debian package history tracker, you can optionally install it minorupdates can be optionaly installed PR: ports/68664 Submitted by: Radim Kolar <hsn@netmag.cz> (maintainer)
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/portindex/Makefile57
-rw-r--r--sysutils/portindex/distinfo4
-rw-r--r--sysutils/portindex/files/loadindex.sh2
-rw-r--r--sysutils/portindex/files/minorupdates.sh2
-rw-r--r--sysutils/portindex/files/portindex.sh2
-rw-r--r--sysutils/portindex/files/portreadmes.sh2
-rw-r--r--sysutils/portindex/files/query.sh2
-rw-r--r--sysutils/portindex/files/updateall.sh2
-rw-r--r--sysutils/portindex/files/updinst.sh2
9 files changed, 63 insertions, 12 deletions
diff --git a/sysutils/portindex/Makefile b/sysutils/portindex/Makefile
index 8461cbc589be..de4f915d4b8a 100644
--- a/sysutils/portindex/Makefile
+++ b/sysutils/portindex/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= portindex
-PORTVERSION= 11
+PORTVERSION= 12
CATEGORIES= sysutils
MASTER_SITES= http://home.tiscali.cz:8080/~cz210552/distfiles/
DISTNAME= bsdportsutils-${PORTVERSION}
@@ -19,29 +19,70 @@ NO_WRKSUBDIR= yes
USE_REINPLACE= yes
PORTDOCS= *.TXT
-PLIST_FILES= bin/portreadmes bin/portindex
PLIST_DIRS= share/${PORTNAME}
-SOURCES= bsdpkg freebsdports indexer minorupdates updateall updatereadmes
+PORTINDEX= bsdpkg freebsdports indexer updatereadmes
+MINORUPDATES= minorupdates
+MISCTOOLS= updateall
+PKGHISTORY= loadindex query updinst
+
+SOURCES= ${PORTINDEX}
+EXECUTABLES= portindex portreadmes
+
+OPTIONS= MINOR "Install minorupdates program" off \
+ MISCTOOLS "Install misc. tools" off \
+ PKGHISTORY "Install pkghistory package" off
+
+.include <bsd.port.pre.mk>
+
+.ifdef WITH_MINOR
+RUN_DEPENDS+= ${LOCALBASE}/sbin/portversion:${PORTSDIR}/sysutils/portupgrade
+SOURCES+= ${MINORUPDATES}
+EXECUTABLES+= ${MINORUPDATES}
+.endif
+
+.ifdef WITH_MISCTOOLS
+SOURCES+= ${MISCTOOLS}
+EXECUTABLES+= ${MISCTOOLS}
+.endif
+
+.ifdef WITH_PKGHISTORY
+SOURCES+= ${PKGHISTORY}
+EXECUTABLES+= ${PKGHISTORY}
+RUN_DEPENDS+= ${PYTHON_SITELIBDIR}/pg.py:${PORTSDIR}/databases/py-PyGreSQL
+PLIST_FILES+= share/${PORTNAME}/create.sql
+.endif
.for i in ${SOURCES}
PLIST_FILES+= share/${PORTNAME}/${i}.py
PLIST_FILES+= share/${PORTNAME}/${i}.pyc
.endfor
+.for i in ${EXECUTABLES}
+PLIST_FILES+= bin/${i}
+.endfor
+
do-build:
${REINPLACE_CMD} -e "s,ports.pck,/var/db/portindex.pck," ${WRKSRC}/freebsdports.py
- ${SED} -e "s,%%DATADIR%%,${DATADIR}," ${FILESDIR}/portindex.sh > ${WRKSRC}/portindex
- ${SED} -e "s,%%DATADIR%%,${DATADIR}," ${FILESDIR}/portreadmes.sh > ${WRKSRC}/portreadmes
+.for i in ${EXECUTABLES}
+ ${SED} -e "s,%%DATADIR%%,${DATADIR}," ${FILESDIR}/${i}.sh > ${WRKSRC}/${i}
+.endfor
do-install:
${MKDIR} ${DATADIR}
- ${INSTALL_DATA} ${WRKSRC}/*.py ${DATADIR}
+.for i in ${SOURCES}
+ ${INSTALL_DATA} ${WRKSRC}/${i}.py ${DATADIR}
+.endfor
${PYTHON_CMD} -c "import compileall;compileall.compile_dir('${DATADIR}')"
- ${INSTALL_SCRIPT} ${WRKSRC}/portindex ${WRKSRC}/portreadmes ${PREFIX}/bin
+.for i in ${EXECUTABLES}
+ ${INSTALL_SCRIPT} ${WRKSRC}/${i} ${PREFIX}/bin
+.endfor
+.ifdef WITH_PKGHISTORY
+ ${INSTALL_DATA} ${WRKSRC}/create.sql ${DATADIR}
+.endif
.if !defined(NOPORTDOCS)
${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/*.TXT ${DOCSDIR}
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/sysutils/portindex/distinfo b/sysutils/portindex/distinfo
index f48a41773f0d..7d13200d33ad 100644
--- a/sysutils/portindex/distinfo
+++ b/sysutils/portindex/distinfo
@@ -1,2 +1,2 @@
-MD5 (bsdportsutils-11.tar.gz) = 22545b9a88c04120562a36aa6e60faa5
-SIZE (bsdportsutils-11.tar.gz) = 8320
+MD5 (bsdportsutils-12.tar.gz) = d675196215b308d7dadb3535689173cd
+SIZE (bsdportsutils-12.tar.gz) = 13405
diff --git a/sysutils/portindex/files/loadindex.sh b/sysutils/portindex/files/loadindex.sh
new file mode 100644
index 000000000000..2072247c6854
--- /dev/null
+++ b/sysutils/portindex/files/loadindex.sh
@@ -0,0 +1,2 @@
+#! /bin/sh
+exec /usr/bin/env python %%DATADIR%%/loadindex.py $*
diff --git a/sysutils/portindex/files/minorupdates.sh b/sysutils/portindex/files/minorupdates.sh
new file mode 100644
index 000000000000..119495b62e04
--- /dev/null
+++ b/sysutils/portindex/files/minorupdates.sh
@@ -0,0 +1,2 @@
+#! /bin/sh
+exec /usr/bin/env python %%DATADIR%%/minorupdates.py $*
diff --git a/sysutils/portindex/files/portindex.sh b/sysutils/portindex/files/portindex.sh
index 22235cee80d0..d3cd388531e5 100644
--- a/sysutils/portindex/files/portindex.sh
+++ b/sysutils/portindex/files/portindex.sh
@@ -1,2 +1,2 @@
#! /bin/sh
-exec /usr/bin/env python %%DATADIR%%/indexer.py
+exec /usr/bin/env python %%DATADIR%%/indexer.py $*
diff --git a/sysutils/portindex/files/portreadmes.sh b/sysutils/portindex/files/portreadmes.sh
index 7af6e634c356..8cecf8a55474 100644
--- a/sysutils/portindex/files/portreadmes.sh
+++ b/sysutils/portindex/files/portreadmes.sh
@@ -1,2 +1,2 @@
#! /bin/sh
-exec /usr/bin/env python %%DATADIR%%/updatereadmes.py
+exec /usr/bin/env python %%DATADIR%%/updatereadmes.py $*
diff --git a/sysutils/portindex/files/query.sh b/sysutils/portindex/files/query.sh
new file mode 100644
index 000000000000..faf160604d46
--- /dev/null
+++ b/sysutils/portindex/files/query.sh
@@ -0,0 +1,2 @@
+#! /bin/sh
+exec /usr/bin/env python %%DATADIR%%/query.py $*
diff --git a/sysutils/portindex/files/updateall.sh b/sysutils/portindex/files/updateall.sh
new file mode 100644
index 000000000000..67eae4fc9fe4
--- /dev/null
+++ b/sysutils/portindex/files/updateall.sh
@@ -0,0 +1,2 @@
+#! /bin/sh
+exec /usr/bin/env python %%DATADIR%%/updateall.py $*
diff --git a/sysutils/portindex/files/updinst.sh b/sysutils/portindex/files/updinst.sh
new file mode 100644
index 000000000000..51349381ad6b
--- /dev/null
+++ b/sysutils/portindex/files/updinst.sh
@@ -0,0 +1,2 @@
+#! /bin/sh
+exec /usr/bin/env python %%DATADIR%%/updinst.py $*