aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils
diff options
context:
space:
mode:
authorolivierd <olivierd@FreeBSD.org>2016-11-13 18:40:53 +0800
committerolivierd <olivierd@FreeBSD.org>2016-11-13 18:40:53 +0800
commit0d1d2b8edbed67782d00a7648c43ef59da236af9 (patch)
tree1914806ded01127f81862ff21f229823a28a9fb5 /sysutils
parent4f1f74cc1247006b8cb7e7aad460fd4ca02f5b8e (diff)
downloadfreebsd-ports-gnome-0d1d2b8edbed67782d00a7648c43ef59da236af9.tar.gz
freebsd-ports-gnome-0d1d2b8edbed67782d00a7648c43ef59da236af9.tar.zst
freebsd-ports-gnome-0d1d2b8edbed67782d00a7648c43ef59da236af9.zip
- Don't call fusermount for fuse mount points
- Bump PORTREVISION While I'm here, adjust dependencies (reported by QA script) PR: 214336 Submitted by: <rozhuk.im@gmail.com> MFH: 2016Q4
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/xfce4-mount-plugin/Makefile7
-rw-r--r--sysutils/xfce4-mount-plugin/files/patch-panel-plugin_devices.c14
2 files changed, 19 insertions, 2 deletions
diff --git a/sysutils/xfce4-mount-plugin/Makefile b/sysutils/xfce4-mount-plugin/Makefile
index 94b68bbf8916..95f38589e016 100644
--- a/sysutils/xfce4-mount-plugin/Makefile
+++ b/sysutils/xfce4-mount-plugin/Makefile
@@ -3,7 +3,7 @@
PORTNAME= xfce4-mount-plugin
PORTVERSION= 0.6.7
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= sysutils xfce
MASTER_SITES= XFCE/src/panel-plugins/${PORTNAME}/${PORTVERSION:R}
DIST_SUBDIR= xfce4
@@ -13,11 +13,14 @@ COMMENT= Mount and umount utility for the Xfce4 panel
LICENSE= GPLv2
+LIB_DEPENDS= libfontconfig.so:x11-fonts/fontconfig \
+ libfreetype.so:print/freetype2
+
GNU_CONFIGURE= yes
INSTALLS_ICONS= yes
INSTALL_TARGET= install-strip
USES= gettext gmake libtool pkgconfig xfce tar:bzip2
-USE_GNOME= intltool intlhack
+USE_GNOME= gtk20 cairo intltool intlhack
USE_LDCONFIG= yes
USE_XFCE= panel
diff --git a/sysutils/xfce4-mount-plugin/files/patch-panel-plugin_devices.c b/sysutils/xfce4-mount-plugin/files/patch-panel-plugin_devices.c
new file mode 100644
index 000000000000..f53de7e3cdfe
--- /dev/null
+++ b/sysutils/xfce4-mount-plugin/files/patch-panel-plugin_devices.c
@@ -0,0 +1,14 @@
+--- panel-plugin/devices.c.orig 2014-04-26 21:31:42 UTC
++++ panel-plugin/devices.c
+@@ -329,9 +329,11 @@ disk_umount (t_disk *pdisk, char* umount
+ {
+
+ DBG("disk_umount: dev=%s, mountpoint=%s, umount_command=%s, show_message_dialog=%d, eject=%d, type=%s", pdisk->device, pdisk->mount_point, umount_command, show_message_dialog, eject, pdisk->mount_info->type);
++#if !defined(__FreeBSD__) || !defined(__DragonFly__)
+ if (strstr(pdisk->mount_info->type, "fuse"))
+ deviceprintf(&tmp, "fusermount -u %m", pdisk->device);
+ else
++#endif
+ deviceprintf(&tmp, umount_command, pdisk->device);
+
+ mountpointprintf(&cmd, tmp, pdisk->mount_point);