aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils
diff options
context:
space:
mode:
authorolgeni <olgeni@FreeBSD.org>2001-04-28 21:34:35 +0800
committerolgeni <olgeni@FreeBSD.org>2001-04-28 21:34:35 +0800
commit16e4a516bd594f781649f2736ee171f1164d145e (patch)
tree2eb8537a0ecd0f9ff853e8910e2a536ffeff3939 /sysutils
parent90726043eb68f6d2e995011c2c9782564dfd812c (diff)
downloadfreebsd-ports-gnome-16e4a516bd594f781649f2736ee171f1164d145e.tar.gz
freebsd-ports-gnome-16e4a516bd594f781649f2736ee171f1164d145e.tar.zst
freebsd-ports-gnome-16e4a516bd594f781649f2736ee171f1164d145e.zip
Fix a bug that prevented updates to be installed.
The line: for webmin_module in "${WEBMIN_MODULES}" must be rewritten as: for webmin_module in ${WEBMIN_MODULES} else the port will not unpack the update tarball. This is a very stupid bug by me. Pass the pointy hat :-( PORTREVISION bump: people using the WITH_UPDATES option should upgrade to this version of the port. People who do not use WITH_UPDATES and run the stock webmin release, or update it by hand, are unaffected by this patch.
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/webmin/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/sysutils/webmin/Makefile b/sysutils/webmin/Makefile
index d83658d32298..4c6efc0fd032 100644
--- a/sysutils/webmin/Makefile
+++ b/sysutils/webmin/Makefile
@@ -7,7 +7,7 @@
PORTNAME= webmin
PORTVERSION= 0.85
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= sysutils
MASTER_SITES= http://webadmin.sourceforge.net/webmin/updates/ \
http://webadmin.sourceforge.net/webmin/download/
@@ -29,7 +29,7 @@ WEBMIN_MODULES= squid-0.85-1.wbm.gz useradmin-0.85-1.wbm.gz net-0.85-1.wbm.gz ap
post-extract:
.if defined(WITH_UPDATES)
if [ "${WEBMIN_MODULES}" != "" ]; then \
- for webmin_module in "${WEBMIN_MODULES}"; do \
+ for webmin_module in ${WEBMIN_MODULES}; do \
${TAR} xfz ${DISTDIR}/$${webmin_module} -C ${WRKSRC}; \
done; \
fi