aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils
diff options
context:
space:
mode:
authorehaupt <ehaupt@FreeBSD.org>2014-02-27 17:26:09 +0800
committerehaupt <ehaupt@FreeBSD.org>2014-02-27 17:26:09 +0800
commit2d700d5e770e8977ad27de263282843a4fda6340 (patch)
tree6461f096fcc47effb72be1b6ffd57739045d8d17 /sysutils
parent9f1f9d2b26079f12dcfc31f1736fc62e1abc7c34 (diff)
downloadfreebsd-ports-gnome-2d700d5e770e8977ad27de263282843a4fda6340.tar.gz
freebsd-ports-gnome-2d700d5e770e8977ad27de263282843a4fda6340.tar.zst
freebsd-ports-gnome-2d700d5e770e8977ad27de263282843a4fda6340.zip
- Support staging
- Use shebangfix
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/geteltorito/Makefile11
1 files changed, 8 insertions, 3 deletions
diff --git a/sysutils/geteltorito/Makefile b/sysutils/geteltorito/Makefile
index 4d1500799665..f5963e222abb 100644
--- a/sysutils/geteltorito/Makefile
+++ b/sysutils/geteltorito/Makefile
@@ -12,13 +12,18 @@ MAINTAINER= valerio.daelli@gmail.com
COMMENT= El Torito image extractor
NO_BUILD= yes
-USES= perl5
+USES= perl5 shebangfix
USE_PERL5= run
PLIST_FILES= bin/${PORTNAME}
+SHEBANG_FILES= geteltorito.pl
+
+do-extract:
+ @${MKDIR} ${WRKSRC}
+ @${CP} ${DISTDIR}/${DISTFILES} ${WRKSRC}
-NO_STAGE= yes
do-install:
- ${INSTALL_SCRIPT} ${DISTDIR}/${PORTNAME}.pl ${PREFIX}/bin/${PORTNAME}
+ ${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME}.pl \
+ ${STAGEDIR}${PREFIX}/bin/${PORTNAME}
.include <bsd.port.mk>