aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2016-10-21 20:51:40 +0800
committermat <mat@FreeBSD.org>2016-10-21 20:51:40 +0800
commit316cf6317eb621c4567d3b8e337fa9ba3097ea56 (patch)
tree5b70e6802d6d9dfe8b4564fc4f09f2d0a5156343 /sysutils
parent5b45061f15be292aed8143f0ec15163936e69baf (diff)
downloadfreebsd-ports-gnome-316cf6317eb621c4567d3b8e337fa9ba3097ea56.tar.gz
freebsd-ports-gnome-316cf6317eb621c4567d3b8e337fa9ba3097ea56.tar.zst
freebsd-ports-gnome-316cf6317eb621c4567d3b8e337fa9ba3097ea56.zip
${RM} already has -f.
PR: 213570 Submitted by: mat Exp-run by: antoine Sponsored by: Absolight
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/amrstat/Makefile2
-rw-r--r--sysutils/bsdadminscripts/Makefile2
-rw-r--r--sysutils/duplicity/Makefile12
-rw-r--r--sysutils/e2fsprogs/Makefile4
-rw-r--r--sysutils/freesbie/Makefile2
-rw-r--r--sysutils/gosa/Makefile2
-rw-r--r--sysutils/grub2-pcbsd/Makefile2
-rw-r--r--sysutils/ldap-account-manager/Makefile4
-rw-r--r--sysutils/radmind/Makefile2
-rw-r--r--sysutils/scprotect/Makefile2
-rw-r--r--sysutils/u-boot-pine64/Makefile2
-rw-r--r--sysutils/webmin/Makefile2
-rw-r--r--sysutils/xvidcap/Makefile2
13 files changed, 20 insertions, 20 deletions
diff --git a/sysutils/amrstat/Makefile b/sysutils/amrstat/Makefile
index b4b072d69fcf..0e74e2565f2a 100644
--- a/sysutils/amrstat/Makefile
+++ b/sysutils/amrstat/Makefile
@@ -35,7 +35,7 @@ NO_WRKSUBDIR= yes
SUB_FILES+= ${PERIODICSCRIPT}
post-extract:
- ${RM} -f ${WRKSRC}/amrstat
+ ${RM} ${WRKSRC}/amrstat
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/amrstat ${STAGEDIR}${PREFIX}/sbin
diff --git a/sysutils/bsdadminscripts/Makefile b/sysutils/bsdadminscripts/Makefile
index 8a382398f1a7..c39f309b67bb 100644
--- a/sysutils/bsdadminscripts/Makefile
+++ b/sysutils/bsdadminscripts/Makefile
@@ -49,7 +49,7 @@ do-install:
.endfor
${MKDIR} ${STAGEDIR}${ETCDIR}
${MV} ${STAGEDIR}${PREFIX}/etc/*.sample ${STAGEDIR}${ETCDIR}
- ${RM} -rf ${STAGEDIR}${PREFIX}/etc/*.sample
+ ${RM} -r ${STAGEDIR}${PREFIX}/etc/*.sample
post-install-DOCS-on:
${MKDIR} ${STAGEDIR}${DOCSDIR}
diff --git a/sysutils/duplicity/Makefile b/sysutils/duplicity/Makefile
index 344a9ce6e0a1..d1ca2f067800 100644
--- a/sysutils/duplicity/Makefile
+++ b/sysutils/duplicity/Makefile
@@ -63,22 +63,22 @@ post-patch-PEXPECT-off:
-name '*ssh_pexpect*' -delete
post-patch-FTP-off:
- @${RM} -f ${WRKSRC}/${PORTNAME}/backends/ftpbackend.py
+ @${RM} ${WRKSRC}/${PORTNAME}/backends/ftpbackend.py
post-patch-FTPS-off:
- @${RM} -f ${WRKSRC}/${PORTNAME}/backends/ftpsbackend.py
+ @${RM} ${WRKSRC}/${PORTNAME}/backends/ftpsbackend.py
post-patch-S3-off:
.for f in botobackend _boto_multi _boto_single
- @${RM} -f ${WRKSRC}/${PORTNAME}/backends/${f}.py
+ @${RM} ${WRKSRC}/${PORTNAME}/backends/${f}.py
.endfor
post-patch-GDOCS-off:
- @${RM} -f ${WRKSRC}/${PORTNAME}/backends/gdocsbackend.py
+ @${RM} ${WRKSRC}/${PORTNAME}/backends/gdocsbackend.py
post-patch-CLOUDFILES-off:
.for f in cfbackend _cf_cloudfiles _cf_pyrax
- @${RM} -f ${WRKSRC}/${PORTNAME}/backends/${f}.py
+ @${RM} ${WRKSRC}/${PORTNAME}/backends/${f}.py
.endfor
post-patch-CLOUDFILES-on:
@@ -87,7 +87,7 @@ post-patch-CLOUDFILES-on:
@${REINPLACE_CMD} 's|"pyrax"|"cloudfiles"|' ${WRKSRC}/${PORTNAME}/globals.py
post-patch-GIO-off:
- @${RM} -f ${WRKSRC}/${PORTNAME}/backends/giobackend.py
+ @${RM} ${WRKSRC}/${PORTNAME}/backends/giobackend.py
post-install:
@${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/python2.7/site-packages/duplicity/_librsync.so
diff --git a/sysutils/e2fsprogs/Makefile b/sysutils/e2fsprogs/Makefile
index dbdeaa923ef7..4bbcbe22564f 100644
--- a/sysutils/e2fsprogs/Makefile
+++ b/sysutils/e2fsprogs/Makefile
@@ -162,7 +162,7 @@ post-build:
# system are statically linked against anything that is outside the root fs,
# else we're in trouble if e2fsck is needed for boot:
# (we don't use e2fsck.static, since we can link libc.so dynamically)
- cd ${WRKSRC}/e2fsck && ${RM} -f e2fsck \
+ cd ${WRKSRC}/e2fsck && ${RM} e2fsck \
&& ${MAKE_CMD} e2fsck \
STATIC_LIBS="../lib/libext2fs.a ../lib/libcom_err.a \
../lib/libblkid.a ../lib/libuuid.a" \
@@ -202,7 +202,7 @@ post-build:
.endif
post-install:
- ${RM} -f ${STAGEDIR}${PREFIX}/sbin/uuidd
+ ${RM} ${STAGEDIR}${PREFIX}/sbin/uuidd
${INSTALL_PROGRAM} ${WRKSRC}/fsck_ext2fs ${STAGEDIR}${PREFIX}/sbin/
${INSTALL_MAN} ${FILESDIR}/fsck_ext2fs.8 ${STAGEDIR}${PREFIX}/man/man8/
.if ${PORT_OPTIONS:MDOCS}
diff --git a/sysutils/freesbie/Makefile b/sysutils/freesbie/Makefile
index d27a7035f90c..7240dfeea701 100644
--- a/sysutils/freesbie/Makefile
+++ b/sysutils/freesbie/Makefile
@@ -30,7 +30,7 @@ pre-configure:
do-install:
@ ${MKDIR} ${STAGEDIR}${DATADIR}
- @ ${RM} -f ${WRKSRC}/scripts/iso.sh.orig \
+ @ ${RM} ${WRKSRC}/scripts/iso.sh.orig \
${WRKSRC}/scripts/pkginstall.sh.orig \
${WRKSRC}/scripts/pkgselect.sh.orig
@ cd ${WRKSRC} && ${FIND} . -type f -print | tar -cf - -T - | \
diff --git a/sysutils/gosa/Makefile b/sysutils/gosa/Makefile
index 3c67f1d39679..ed420a418b98 100644
--- a/sysutils/gosa/Makefile
+++ b/sysutils/gosa/Makefile
@@ -53,7 +53,7 @@ post-patch:
.endfor
@${MV} -f ${WRKSRC}/contrib/gosa.conf.5 ${WRKSRC}
- @${FIND} ${WRKSRC} -type f -name '*.orig' -exec ${RM} -f {} +
+ @${FIND} ${WRKSRC} -type f -name '*.orig' -exec ${RM} {} +
do-install:
@${MKDIR} ${STAGEDIR}${WWWDIR}
diff --git a/sysutils/grub2-pcbsd/Makefile b/sysutils/grub2-pcbsd/Makefile
index a5c9b87ca908..5600c8b8bd4c 100644
--- a/sysutils/grub2-pcbsd/Makefile
+++ b/sysutils/grub2-pcbsd/Makefile
@@ -85,7 +85,7 @@ post-configure:
@${LN} -sfh /usr/include/machine /usr/include/sys /usr/include/x86 ${WRKSRC}/grub-core
post-install:
- ${RM} -rf ${STAGEDIR}${PREFIX}/lib/charset.alias
+ ${RM} -r ${STAGEDIR}${PREFIX}/lib/charset.alias
${INSTALL_SCRIPT} ${WRKDIR}/00_header ${STAGEDIR}${PREFIX}/etc/grub.d/
${INSTALL_SCRIPT} ${WRKDIR}/10_kfreebsd ${STAGEDIR}${PREFIX}/etc/grub.d/
${INSTALL_SCRIPT} ${WRKDIR}/10_ktrueos ${STAGEDIR}${PREFIX}/etc/grub.d/
diff --git a/sysutils/ldap-account-manager/Makefile b/sysutils/ldap-account-manager/Makefile
index 83fa328785c0..a627a2e6a6a4 100644
--- a/sysutils/ldap-account-manager/Makefile
+++ b/sysutils/ldap-account-manager/Makefile
@@ -30,10 +30,10 @@ WRITEABLES= config sess tmp
OPTIONS_DEFINE= DOCS
do-install:
- @${ECHO_CMD} '@exec if [ -f %D/${WWWDIR_REL}/config/shells ]; then ${RM} -f %D/${WWWDIR_REL}/config/shells; fi' >> ${TMPPLIST}
+ @${ECHO_CMD} '@exec if [ -f %D/${WWWDIR_REL}/config/shells ]; then ${RM} %D/${WWWDIR_REL}/config/shells; fi' >> ${TMPPLIST}
.for CONFIG in ${CONFIGS}
@${ECHO_CMD} '@sample ${WWWDIR_REL}/config/${CONFIG}.sample' >> ${TMPPLIST}
- @${ECHO_CMD} '@exec if [ -f %D/${WWWDIR_REL}/config/${CONFIG}_sample ]; then ${RM} -f %D/${WWWDIR_REL}/config/${CONFIG}_sample; fi' >> ${TMPPLIST}
+ @${ECHO_CMD} '@exec if [ -f %D/${WWWDIR_REL}/config/${CONFIG}_sample ]; then ${RM} %D/${WWWDIR_REL}/config/${CONFIG}_sample; fi' >> ${TMPPLIST}
.endfor
.for I in ${LAMDATA}
@${FIND} -s ${WRKSRC}/${I} -type f -not -name '*.sample' | ${SED} -e 's,^${WRKSRC},${WWWDIR_REL},' >> ${TMPPLIST}
diff --git a/sysutils/radmind/Makefile b/sysutils/radmind/Makefile
index 2817f7495c0e..bf5bde5b01b6 100644
--- a/sysutils/radmind/Makefile
+++ b/sysutils/radmind/Makefile
@@ -40,7 +40,7 @@ IGNORE_TIMESTAMPS_DESC= Add '-t' option to fsdiff
post-install:
# Ugly hack to remove generated man pages
- ${RM} -rf ${WRKSRC}/tmp
+ ${RM} -r ${WRKSRC}/tmp
# Port's Docs (Copyright & wire protocol info)
${MKDIR} ${STAGEDIR}${DOCSDIR}
diff --git a/sysutils/scprotect/Makefile b/sysutils/scprotect/Makefile
index 80061f11492a..226c2791cb87 100644
--- a/sysutils/scprotect/Makefile
+++ b/sysutils/scprotect/Makefile
@@ -22,6 +22,6 @@ BROKEN= does not build on 11.x
.endif
post-extract:
- @cd ${WRKSRC}/kmod && ${RM} -f machine
+ @cd ${WRKSRC}/kmod && ${RM} machine
.include <bsd.port.post.mk>
diff --git a/sysutils/u-boot-pine64/Makefile b/sysutils/u-boot-pine64/Makefile
index 7b5bff065abb..bd0b3022c026 100644
--- a/sysutils/u-boot-pine64/Makefile
+++ b/sysutils/u-boot-pine64/Makefile
@@ -38,7 +38,7 @@ IGNORE= requires FreeBSD 10 or later
post-extract:
(cd ${WRKSRC}; ${EXTRACT_CMD} xvf ${DISTDIR}/firmware-pine64-20160329-6.1.src.rpm)
- ${RM} -fr ${WRKSRC}/arm-trusted-firmware
+ ${RM} -r ${WRKSRC}/arm-trusted-firmware
(cd ${WRKSRC}; ${EXTRACT_CMD} xvf pine64atf.tar.xz)
do-configure:
diff --git a/sysutils/webmin/Makefile b/sysutils/webmin/Makefile
index e51de613a9a8..bfe4bf634730 100644
--- a/sysutils/webmin/Makefile
+++ b/sysutils/webmin/Makefile
@@ -26,7 +26,7 @@ SUB_FILES= pkg-message
WEBMIN_MODULES=
post-extract:
- @${RM} -f ${WRKSRC}/mount/freebsd-mounts-?
+ @${RM} ${WRKSRC}/mount/freebsd-mounts-?
@if [ "${WEBMIN_MODULES}" != "" ]; then \
for webmin_module in ${WEBMIN_MODULES}; do \
${ECHO} "===> Unpacking updated module: $${webmin_module}"; \
diff --git a/sysutils/xvidcap/Makefile b/sysutils/xvidcap/Makefile
index 5dc3f6e05f10..d3605bb4a77e 100644
--- a/sysutils/xvidcap/Makefile
+++ b/sysutils/xvidcap/Makefile
@@ -54,7 +54,7 @@ post-patch:
post-install:
.if ${PORT_OPTIONS:MDOCS}
- ${RM} -f ${NULLDOCS:S|^|${STAGEDIR}${DOCSDIR}/|}
+ ${RM} ${NULLDOCS:S|^|${STAGEDIR}${DOCSDIR}/|}
.endif
.include <bsd.port.mk>