aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2009-03-24 02:52:25 +0800
committermiwi <miwi@FreeBSD.org>2009-03-24 02:52:25 +0800
commit34463dbca625d8d9f1a1a40ffa6821e770ab64d9 (patch)
tree6fbc2d1c42c2020a5ada2677cd2ceacb53111a27 /sysutils
parent49cf75959081a72ed4b09f9c6a61b9fecb696173 (diff)
downloadfreebsd-ports-gnome-34463dbca625d8d9f1a1a40ffa6821e770ab64d9.tar.gz
freebsd-ports-gnome-34463dbca625d8d9f1a1a40ffa6821e770ab64d9.tar.zst
freebsd-ports-gnome-34463dbca625d8d9f1a1a40ffa6821e770ab64d9.zip
FUR is an application that let the user mount a Windows CE based device on your
file system: it uses the brilliant FUSE and the librapi2 of the Synce Project to give you the illusion that the storage of your Pocket PC is mounted on a directory on your local filesystem. WWW: http://www.infis.univ.ts.it/~riccardo/FUR.html PR: ports/132972 Submitted by: Alexander Logvinov <ports at logvinov.com>
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/Makefile1
-rw-r--r--sysutils/fusefs-fur/Makefile44
-rw-r--r--sysutils/fusefs-fur/distinfo3
-rw-r--r--sysutils/fusefs-fur/files/patch-fur.c19
-rw-r--r--sysutils/fusefs-fur/files/patch-fur_utils.c10
-rw-r--r--sysutils/fusefs-fur/pkg-descr6
6 files changed, 83 insertions, 0 deletions
diff --git a/sysutils/Makefile b/sysutils/Makefile
index 8f22f475b987..98167554fbe9 100644
--- a/sysutils/Makefile
+++ b/sysutils/Makefile
@@ -242,6 +242,7 @@
SUBDIR += fusefs-curlftpfs
SUBDIR += fusefs-encfs
SUBDIR += fusefs-funionfs
+ SUBDIR += fusefs-fur
SUBDIR += fusefs-gnome-vfs
SUBDIR += fusefs-gstfs
SUBDIR += fusefs-gunzip
diff --git a/sysutils/fusefs-fur/Makefile b/sysutils/fusefs-fur/Makefile
new file mode 100644
index 000000000000..82664642b8d3
--- /dev/null
+++ b/sysutils/fusefs-fur/Makefile
@@ -0,0 +1,44 @@
+# New ports collection makefile for: fusefs-fur
+# Date created: 10 March 2009
+# Whom: Alexander Logvinov <ports@logvinov.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= fur
+PORTVERSION= 0.4.5
+CATEGORIES= sysutils palm
+MASTER_SITES= http://www.infis.univ.ts.it/~riccardo/downloads/
+PKGNAMEPREFIX= fusefs-
+DISTNAME= FUR-${PORTVERSION}
+
+MAINTAINER= ports@logvinov.com
+COMMENT= FUSE-based filesystem for Windows CE based devices
+
+LIB_DEPENDS= rapi.2:${PORTSDIR}/palm/synce-librapi2 \
+ fuse.2:${PORTSDIR}/sysutils/fusefs-libs
+RUN_DEPENDS= ${LOCALBASE}/modules/fuse.ko:${PORTSDIR}/sysutils/fusefs-kmod
+
+OPTIONS= VCHMOD "Enable a fake hook for chmod that just returns 0" on
+
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+USE_ICONV= yes
+USE_GNOME= pkgconfig
+LDFLAGS+= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
+CFLAGS+= -I${LOCALBASE}/include ${PTHREAD_CFLAGS} -DFUSE_USE_VERSION=26
+CONFIGURE_ENV= CFLAGS="${CFLAGS}" \
+ LDFLAGS="${LDFLAGS}"
+
+PLIST_FILES= bin/${PORTNAME}
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_VCHMOD)
+CONFIGURE_ARGS+= --enable-void-chmod
+.endif
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/Fur ${PREFIX}/bin/${PORTNAME}
+
+.include <bsd.port.post.mk>
diff --git a/sysutils/fusefs-fur/distinfo b/sysutils/fusefs-fur/distinfo
new file mode 100644
index 000000000000..644513e0e49b
--- /dev/null
+++ b/sysutils/fusefs-fur/distinfo
@@ -0,0 +1,3 @@
+MD5 (FUR-0.4.5.tar.gz) = efe43cda7d50ed71810e9b284d89bde1
+SHA256 (FUR-0.4.5.tar.gz) = 20535d126823a183ac2bbe7a2b8b24adf93b276566567f3c2c4e343a3cfef8db
+SIZE (FUR-0.4.5.tar.gz) = 86706
diff --git a/sysutils/fusefs-fur/files/patch-fur.c b/sysutils/fusefs-fur/files/patch-fur.c
new file mode 100644
index 000000000000..db56d11a4d24
--- /dev/null
+++ b/sysutils/fusefs-fur/files/patch-fur.c
@@ -0,0 +1,19 @@
+--- fur.c.orig 2009-03-21 02:19:24.000000000 +0900
++++ fur.c 2009-03-21 08:02:46.000000000 +0900
+@@ -88,7 +88,6 @@
+
+
+ #define SIMIL_PROC
+-#define FUSE_USE_VERSION 22
+ #include <time.h>
+ #include <fuse.h>
+ #include <stdlib.h>
+@@ -385,7 +384,7 @@
+ init();
+ fuse_opt_parse(&args, NULL, NULL, NULL);
+ fuse_opt_add_arg(&args, "-s");
+- retval=fuse_main(args.argc, args.argv, &hello_oper);
++ retval=fuse_main(args.argc, args.argv, &hello_oper, NULL);
+
+ fuse_opt_free_args(&args);
+ // Finalize RAPI
diff --git a/sysutils/fusefs-fur/files/patch-fur_utils.c b/sysutils/fusefs-fur/files/patch-fur_utils.c
new file mode 100644
index 000000000000..20451924bd0b
--- /dev/null
+++ b/sysutils/fusefs-fur/files/patch-fur_utils.c
@@ -0,0 +1,10 @@
+--- fur_utils.c.orig 2008-11-24 01:14:49.000000000 +0900
++++ fur_utils.c 2009-03-13 17:42:56.000000000 +0900
+@@ -476,7 +476,6 @@
+ return attrib & FILE_ATTRIBUTE_DIRECTORY?1:0;
+ }
+
+-extern long int timezone;
+ extern int daylight;
+ extern char * tzname [2];
+
diff --git a/sysutils/fusefs-fur/pkg-descr b/sysutils/fusefs-fur/pkg-descr
new file mode 100644
index 000000000000..9394bb656b89
--- /dev/null
+++ b/sysutils/fusefs-fur/pkg-descr
@@ -0,0 +1,6 @@
+FUR is an application that let the user mount a Windows CE based device on your
+file system: it uses the brilliant FUSE and the librapi2 of the Synce Project
+to give you the illusion that the storage of your Pocket PC is mounted on
+a directory on your local filesystem.
+
+WWW: http://www.infis.univ.ts.it/~riccardo/FUR.html