aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2015-06-11 00:46:46 +0800
committersunpoet <sunpoet@FreeBSD.org>2015-06-11 00:46:46 +0800
commit3b2c413c09474fccfe83f94dd8ff14e89603d74c (patch)
tree403fb646641b6eb5c573e3ba004d0974b379d8c7 /sysutils
parent1e8b1a83f97dbb63e862687b99cac07bf49b75c1 (diff)
downloadfreebsd-ports-gnome-3b2c413c09474fccfe83f94dd8ff14e89603d74c.tar.gz
freebsd-ports-gnome-3b2c413c09474fccfe83f94dd8ff14e89603d74c.tar.zst
freebsd-ports-gnome-3b2c413c09474fccfe83f94dd8ff14e89603d74c.zip
- Update to 0.56
- Update manpages - Update maintainer section Changes: http://joeyh.name/code/moreutils/news/version_0.56/
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/moreutils/Makefile4
-rw-r--r--sysutils/moreutils/distinfo4
-rw-r--r--sysutils/moreutils/files/errno.12
-rw-r--r--sysutils/moreutils/files/moreutils-parallel.13
-rw-r--r--sysutils/moreutils/files/patch-ifdata.c35
-rw-r--r--sysutils/moreutils/files/sponge.128
6 files changed, 66 insertions, 10 deletions
diff --git a/sysutils/moreutils/Makefile b/sysutils/moreutils/Makefile
index 417321a3c0e3..7433f82c7586 100644
--- a/sysutils/moreutils/Makefile
+++ b/sysutils/moreutils/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= moreutils
-PORTVERSION= 0.55
+PORTVERSION= 0.56
CATEGORIES= sysutils
MASTER_SITES= DEBIAN_POOL
DISTNAME= ${PORTNAME}_${PORTVERSION}.orig
@@ -64,10 +64,10 @@ do-install:
# require: docbook-xsl, libxml2, libxslt
updateman: do-clean extract
- ${MV} ${WRKSRC}/parallel.docbook ${WRKSRC}/moreutils-parallel.docbook
.for man in ${CANNED_MANPAGES:R}
${LOCALBASE}/bin/xmllint --noout --valid ${WRKSRC}/${man}.docbook && \
${LOCALBASE}/bin/xsltproc --output ${FILESDIR}/${man}.1 --param man.authors.section.enabled 0 ${LOCALBASE}/share/xsl/docbook/manpages/docbook.xsl ${WRKSRC}/${man}.docbook
.endfor
+ ${MV} ${FILESDIR}/parallel.1 ${FILESDIR}/moreutils-parallel.1
.include <bsd.port.mk>
diff --git a/sysutils/moreutils/distinfo b/sysutils/moreutils/distinfo
index 1e274015d521..6ccfffe49a43 100644
--- a/sysutils/moreutils/distinfo
+++ b/sysutils/moreutils/distinfo
@@ -1,2 +1,2 @@
-SHA256 (moreutils_0.55.orig.tar.gz) = da9d5cd145ceea967a65dd50031d168d66199c3eb41b9390b57f35d4a5808ab5
-SIZE (moreutils_0.55.orig.tar.gz) = 46500
+SHA256 (moreutils_0.56.orig.tar.gz) = ec4b7a1e1d1e1d6ec606d2877301ec06c6cf4091776687d9b76f4d019705e77f
+SIZE (moreutils_0.56.orig.tar.gz) = 46704
diff --git a/sysutils/moreutils/files/errno.1 b/sysutils/moreutils/files/errno.1
index 6bcb6e233600..3944240b4f62 100644
--- a/sysutils/moreutils/files/errno.1
+++ b/sysutils/moreutils/files/errno.1
@@ -43,7 +43,7 @@ errno \- look up errno names and descriptions
\fBerrno\fR
looks up errno macro names, errno codes, and the corresponding descriptions\&. For example, if given
ENOENT
-on a Linux system, it prints out the code 2 and the description "No such file or directory"\&. If given the code 2, it printes
+on a Linux system, it prints out the code 2 and the description "No such file or directory"\&. If given the code 2, it prints
ENOENT
and the same description\&.
.SH "OPTIONS"
diff --git a/sysutils/moreutils/files/moreutils-parallel.1 b/sysutils/moreutils/files/moreutils-parallel.1
index 3856042d8fd1..796dba7324a2 100644
--- a/sysutils/moreutils/files/moreutils-parallel.1
+++ b/sysutils/moreutils/files/moreutils-parallel.1
@@ -82,6 +82,9 @@ This runs three independent commands in parallel\&.
Its exit status is the combination of the exit statuses of each command ran, ORed together\&. (Thus, if any one command exits nonzero,
\fBparallel\fR
as a whole will exit nonzero\&.)
+.SH "NOTES"
+.PP
+All output to stdout and stderr is serialised through a corresponding internal pipe, in order to prevent annoying concurrent output behaviour\&. Note that serialisation is not done on any other file descriptors and file position based access to a nonstandard file descriptor might have unexpected results\&.
.SH "AUTHOR"
.PP
Tollef Fog Heen
diff --git a/sysutils/moreutils/files/patch-ifdata.c b/sysutils/moreutils/files/patch-ifdata.c
new file mode 100644
index 000000000000..1ae89835fd07
--- /dev/null
+++ b/sysutils/moreutils/files/patch-ifdata.c
@@ -0,0 +1,35 @@
+--- ifdata.c.orig 2015-06-03 16:04:42 UTC
++++ ifdata.c
+@@ -1,4 +1,4 @@
+-#include <error.h>
++#include <err.h>
+ #include <stdlib.h>
+ #include <sys/types.h>
+ #include <sys/socket.h>
+@@ -19,7 +19,7 @@
+ #include <net/if.h>
+ #endif
+
+-#if defined(__APPLE__)
++#if defined(__FreeBSD__)
+ #define s6_addr16 __u6_addr.__u6_addr16
+ #include <net/if.h>
+ #endif
+@@ -130,7 +130,7 @@ static int do_socket_ioctl(const char *i
+ *ioctl_errno = errno;
+ if (print_error == PRINT_ERROR) {
+ if (errno == ENODEV)
+- error(EXIT_FAILURE, 0,
++ err(EXIT_FAILURE,
+ "No such network interface: %s", ifname);
+ else
+ fprintf(stderr, "ioctl on %s: %s\n", ifname,
+@@ -392,7 +392,7 @@ void please_do(int ndo, int *todo, const
+ for (i=0; i<ndo; i++) {
+ if (!exists &&
+ (todo[i] != DO_EXISTS) && (todo[i] != DO_PEXISTS))
+- error(EXIT_FAILURE, 0, "No such network interface: %s",
++ err(EXIT_FAILURE, "No such network interface: %s",
+ ifname);
+
+ switch (todo[i]) {
diff --git a/sysutils/moreutils/files/sponge.1 b/sysutils/moreutils/files/sponge.1
index 3f74fe959c7d..5da2e73cb1c1 100644
--- a/sysutils/moreutils/files/sponge.1
+++ b/sysutils/moreutils/files/sponge.1
@@ -30,16 +30,34 @@
.SH "NAME"
sponge \- soak up standard input and write to a file
.SH "SYNOPSIS"
-.HP \w'\fBsed\ \*(Aq\&.\&.\&.\*(Aq\ file\ |\ grep\ \*(Aq\&.\&.\&.\*(Aq\ |\ sponge\ file\fR\ 'u
-\fBsed \*(Aq\&.\&.\&.\*(Aq file | grep \*(Aq\&.\&.\&.\*(Aq | sponge file\fR
+.HP \w'\fBsed\ \*(Aq\&.\&.\&.\*(Aq\ file\ |\ grep\ \*(Aq\&.\&.\&.\*(Aq\ |\ sponge\ [\-a]\ file\fR\ 'u
+\fBsed \*(Aq\&.\&.\&.\*(Aq file | grep \*(Aq\&.\&.\&.\*(Aq | sponge [\-a] file\fR
.SH "DESCRIPTION"
.PP
\fBsponge\fR
-reads standard input and writes it out to the specified file\&. Unlike a shell redirect, sponge soaks up all its input before opening the output file\&. This allows constructing pipelines that read from and write to the same file\&.
+reads standard input and writes it out to the specified file\&. Unlike a shell redirect,
+\fBsponge\fR
+soaks up all its input before writing the output file\&. This allows constructing pipelines that read from and write to the same file\&.
+.PP
+
+\fBsponge\fR
+preserves the permissions of the output file if it already exists\&.
.PP
-It also creates the output file atomically by renaming a temp file into place, and preserves the permissions of the output file if it already exists\&. If the output file is a special file or symlink, the data will be written to it\&.
+When possible,
+\fBsponge\fR
+creates or updates the output file atomically by renaming a temp file into place\&. (This cannot be done if TMPDIR is not in the same filesystem\&.)
+.PP
+If the output file is a special file or symlink, the data will be written to it, non\-atomically\&.
+.PP
+If no file is specified,
+\fBsponge\fR
+outputs to stdout\&.
+.SH "OPTIONS"
.PP
-If no output file is specified, sponge outputs to stdout\&.
+\fB\-a\fR
+.RS 4
+Replace the file with a new file that contains the file\*(Aqs original content, with the standard input appended to it\&. This is done atomically when possible\&.
+.RE
.SH "AUTHOR"
.PP
Colin Watson and Tollef Fog Heen