aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils
diff options
context:
space:
mode:
authoraraujo <araujo@FreeBSD.org>2007-06-30 09:41:22 +0800
committeraraujo <araujo@FreeBSD.org>2007-06-30 09:41:22 +0800
commit3b3b98c98167326b6f2c83674f6cba9243a475f0 (patch)
treeeb2eb67fb31fecbe13472f6834f24af3e0bdfc30 /sysutils
parenta1ee05e7e52863a36614252d8c2db2c36e62bc1a (diff)
downloadfreebsd-ports-gnome-3b3b98c98167326b6f2c83674f6cba9243a475f0.tar.gz
freebsd-ports-gnome-3b3b98c98167326b6f2c83674f6cba9243a475f0.tar.zst
freebsd-ports-gnome-3b3b98c98167326b6f2c83674f6cba9243a475f0.zip
GoogLog is a easy and simple web tool to search inside your syslog files.
The goal of Googlog is to be simple to install and use. so there's not a lot of functionnality, but, from my point of vue, it is simple to install and use and fast to search into syslog's files. WWW: http://www.googlog.org/ Approved by: stas (mentor)
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/Makefile1
-rw-r--r--sysutils/googlog/Makefile43
-rw-r--r--sysutils/googlog/distinfo3
-rw-r--r--sysutils/googlog/pkg-descr6
-rw-r--r--sysutils/googlog/pkg-plist7
5 files changed, 60 insertions, 0 deletions
diff --git a/sysutils/Makefile b/sysutils/Makefile
index ff74b8608525..88f5aafe3ca8 100644
--- a/sysutils/Makefile
+++ b/sysutils/Makefile
@@ -260,6 +260,7 @@
SUBDIR += gnome_subr
SUBDIR += gnomebaker
SUBDIR += gnomefind
+ SUBDIR += googlog
SUBDIR += gpart
SUBDIR += gpkgdep
SUBDIR += gpte
diff --git a/sysutils/googlog/Makefile b/sysutils/googlog/Makefile
new file mode 100644
index 000000000000..3e8147ac6219
--- /dev/null
+++ b/sysutils/googlog/Makefile
@@ -0,0 +1,43 @@
+# New ports collection makefile for: googlog
+# Date created: 19 Jun 2007
+# Whom: araujo
+#
+# $FreeBSD$
+#
+
+PORTNAME= googlog
+PORTVERSION= 1.18
+CATEGORIES= sysutils
+MASTER_SITES= http://www.googlog.org/download/
+DISTNAME= GoogLog-${PORTVERSION}
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= araujo@FreeBSD.org
+COMMENT= GoogLog is a simple tool to search inside your syslog files
+
+RUN_DEPENDS= ${SITE_PERL}/Config/Tiny.pm:${PORTSDIR}/devel/p5-Config-Tiny \
+ ${SITE_PERL}/Compress/Zlib.pm:${PORTSDIR}/archivers/p5-Compress-Zlib \
+ ${SITE_PERL}/HTML/Template.pm:${PORTSDIR}/www/p5-HTML-Template
+
+NO_BUILD= yes
+USE_PERL5= yes
+
+.include <bsd.port.pre.mk>
+
+do-install:
+ @${MKDIR} ${WWWDIR}
+ ${INSTALL_SCRIPT} ${WRKSRC}/GoogLog_cgi.pl ${WWWDIR}/
+ ${INSTALL_DATA} ${WRKSRC}/googlog.ini ${WWWDIR}/
+ ${INSTALL_DATA} ${WRKSRC}/index.html ${WWWDIR}/
+
+.if !exists(${INSTALL_PATH}/googlog.ini)
+ ${INSTALL_DATA} ${WRKSRC}/googlog.ini ${WWWDIR}/
+.endif
+
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README.html ${DOCSDIR}
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/sysutils/googlog/distinfo b/sysutils/googlog/distinfo
new file mode 100644
index 000000000000..7426b50e2e63
--- /dev/null
+++ b/sysutils/googlog/distinfo
@@ -0,0 +1,3 @@
+MD5 (GoogLog-1.18.tgz) = 036fd18b9ecb2325436cbd30d6869c24
+SHA256 (GoogLog-1.18.tgz) = d0d9512aba5ff91f8ed5d3447097125e09c954b69fc3ccac3bcc71e906019981
+SIZE (GoogLog-1.18.tgz) = 10678
diff --git a/sysutils/googlog/pkg-descr b/sysutils/googlog/pkg-descr
new file mode 100644
index 000000000000..afaeac5d93fe
--- /dev/null
+++ b/sysutils/googlog/pkg-descr
@@ -0,0 +1,6 @@
+GoogLog - GoogLog is a easy and simple web tool to search inside your syslog files.
+
+The goal of Googlog is to be simple to install and use. so there's not a lot of functionnality,
+but, from my point of vue, it is simple to install and use and fast to search into syslog's files.
+
+WWW: http://www.googlog.org/
diff --git a/sysutils/googlog/pkg-plist b/sysutils/googlog/pkg-plist
new file mode 100644
index 000000000000..c669718624f9
--- /dev/null
+++ b/sysutils/googlog/pkg-plist
@@ -0,0 +1,7 @@
+%%WWWDIR%%/GoogLog_cgi.pl
+%%WWWDIR%%/googlog.ini
+%%WWWDIR%%/index.html
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%%%DOCSDIR%%/README.html
+@dirrmtry %%WWWDIR%%
+%%PORTDOCS%%@dirrm %%DOCSDIR%%