aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2003-08-12 04:39:31 +0800
committermarcus <marcus@FreeBSD.org>2003-08-12 04:39:31 +0800
commit4532e5d1877001022a323a3d8d8f7e945ac6b75a (patch)
treecfee505ed1d5efc7dd79a138995c2adf9e803691 /sysutils
parentbfafeed7997672f012c1156f96122e156d299ad6 (diff)
downloadfreebsd-ports-gnome-4532e5d1877001022a323a3d8d8f7e945ac6b75a.tar.gz
freebsd-ports-gnome-4532e5d1877001022a323a3d8d8f7e945ac6b75a.tar.zst
freebsd-ports-gnome-4532e5d1877001022a323a3d8d8f7e945ac6b75a.zip
Add nvclock, a utility that allows users to overclock their nVidia-based
graphics cards. PR: 55478 Submitted by: Samy Al Bahra <samy@tommy.sdodson.com>
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/Makefile1
-rw-r--r--sysutils/nvclock/Makefile39
-rw-r--r--sysutils/nvclock/distinfo1
-rw-r--r--sysutils/nvclock/pkg-descr12
-rw-r--r--sysutils/nvclock/pkg-plist2
5 files changed, 55 insertions, 0 deletions
diff --git a/sysutils/Makefile b/sysutils/Makefile
index 6504bf3b69fb..ba6b1d53d2b3 100644
--- a/sysutils/Makefile
+++ b/sysutils/Makefile
@@ -180,6 +180,7 @@
SUBDIR += no-login
SUBDIR += npadmin
SUBDIR += nut
+ SUBDIR += nvclock
SUBDIR += nwclient
SUBDIR += nwclient602
SUBDIR += obliterate
diff --git a/sysutils/nvclock/Makefile b/sysutils/nvclock/Makefile
new file mode 100644
index 000000000000..5b8b0ceb0494
--- /dev/null
+++ b/sysutils/nvclock/Makefile
@@ -0,0 +1,39 @@
+# New ports collection makefile for: nvclock
+# Date created: August 4, 2003
+# Whom: Samy Al Bahra <samy@kerneled.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= nvclock
+PORTVERSION= 0.7
+CATEGORIES= sysutils
+MASTER_SITES= http://www.linuxhardware.org/nvclock/ \
+ http://www.kerneled.com/freebsd/ports/
+DISTNAME= nvclock${PORTVERSION}
+
+MAINTAINER= samy@kerneled.com
+COMMENT= nVidia graphic card status and overclocking tool
+
+USE_GMAKE= yes
+USE_GETOPT_LONG=yes
+GNU_CONFIGURE= yes
+USE_GNOME= pkgconfig
+
+.if defined(WITHOUT_GUI)
+PLIST_SUB+= GTK="@comment "
+CONFIGURE_ARGS+= "--enable-gtk=no"
+.else
+USE_GNOME+= gtk20
+PLIST_SUB+= GTK=""
+.endif
+
+pre-everything::
+ @${ECHO_MSG} ""
+ @${ECHO_MSG} "************************************************"
+ @${ECHO_MSG} "* You can disable nvclock's GTK user interface *"
+ @${ECHO_MSG} "* by defining WITHOUT_GUI. *"
+ @${ECHO_MSG} "************************************************"
+ @${ECHO_MSG} ""
+
+.include <bsd.port.mk>
diff --git a/sysutils/nvclock/distinfo b/sysutils/nvclock/distinfo
new file mode 100644
index 000000000000..3e60fe5b71d7
--- /dev/null
+++ b/sysutils/nvclock/distinfo
@@ -0,0 +1 @@
+MD5 (nvclock0.7.tar.gz) = a3bb5ff1c2638317f1a69c7c2442b9e4
diff --git a/sysutils/nvclock/pkg-descr b/sysutils/nvclock/pkg-descr
new file mode 100644
index 000000000000..3ddaccb2a660
--- /dev/null
+++ b/sysutils/nvclock/pkg-descr
@@ -0,0 +1,12 @@
+NVClock is a small utility that allows users to
+overclock NVIDIA based video cards running on
+*nix platforms. The original code used in building
+this application was borrowed from the nvcs
+application. That code has been extensively reworked
+in order to make the utility much more user friendly
+and to make it play nice with current distros and
+drivers.
+
+ WWW: http://www.linuxhardware.org/nvclock
+
+- Samy Al Bahra <samy@kerneled.com>
diff --git a/sysutils/nvclock/pkg-plist b/sysutils/nvclock/pkg-plist
new file mode 100644
index 000000000000..03b977056f8b
--- /dev/null
+++ b/sysutils/nvclock/pkg-plist
@@ -0,0 +1,2 @@
+bin/nvclock
+%%GTK%%bin/nvclock_gtk