aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils
diff options
context:
space:
mode:
authorale <ale@FreeBSD.org>2013-06-24 22:32:11 +0800
committerale <ale@FreeBSD.org>2013-06-24 22:32:11 +0800
commit48d5fb51023dbbe8f2a70121c289e1849e7e14eb (patch)
treefd816d2c8b34ef7db2d6bcabe7358eaa7fb2d04f /sysutils
parent19160cd533a64299fc9d3710c4d21307ce72df91 (diff)
downloadfreebsd-ports-gnome-48d5fb51023dbbe8f2a70121c289e1849e7e14eb.tar.gz
freebsd-ports-gnome-48d5fb51023dbbe8f2a70121c289e1849e7e14eb.tar.zst
freebsd-ports-gnome-48d5fb51023dbbe8f2a70121c289e1849e7e14eb.zip
Welcome PHP 5.5!
Future steps: - rename current php5 ports to php54 - make php55 the default one after an exp-run
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/Makefile2
-rw-r--r--sysutils/php55-fileinfo/Makefile10
-rw-r--r--sysutils/php55-fileinfo/files/patch-config.m421
-rw-r--r--sysutils/php55-posix/Makefile10
-rw-r--r--sysutils/php55-posix/files/patch-posix.c38
5 files changed, 81 insertions, 0 deletions
diff --git a/sysutils/Makefile b/sysutils/Makefile
index 49f3da6f13c8..9f3528e038f2 100644
--- a/sysutils/Makefile
+++ b/sysutils/Makefile
@@ -699,6 +699,8 @@
SUBDIR += php52-posix
SUBDIR += php53-fileinfo
SUBDIR += php53-posix
+ SUBDIR += php55-fileinfo
+ SUBDIR += php55-posix
SUBDIR += pidof
SUBDIR += pipemeter
SUBDIR += plasma-applet-apcups
diff --git a/sysutils/php55-fileinfo/Makefile b/sysutils/php55-fileinfo/Makefile
new file mode 100644
index 000000000000..ef2883c4ba1b
--- /dev/null
+++ b/sysutils/php55-fileinfo/Makefile
@@ -0,0 +1,10 @@
+# Created by: Alex Dupre <ale@FreeBSD.org>
+# $FreeBSD$
+
+CATEGORIES= sysutils
+
+MASTERDIR= ${.CURDIR}/../../lang/php55
+
+PKGNAMESUFFIX= -fileinfo
+
+.include "${MASTERDIR}/Makefile"
diff --git a/sysutils/php55-fileinfo/files/patch-config.m4 b/sysutils/php55-fileinfo/files/patch-config.m4
new file mode 100644
index 000000000000..1348023ccf64
--- /dev/null
+++ b/sysutils/php55-fileinfo/files/patch-config.m4
@@ -0,0 +1,21 @@
+--- config.m4.orig 2010-09-07 15:45:30.000000000 +0200
++++ config.m4 2010-09-07 15:46:50.000000000 +0200
+@@ -4,6 +4,9 @@
+ PHP_ARG_ENABLE(fileinfo, for fileinfo support,
+ [ --disable-fileinfo Disable fileinfo support], yes)
+
++PHP_ARG_WITH(pcre-dir, pcre install prefix,
++[ --with-pcre-dir FILEINFO: pcre install prefix], no, no)
++
+ if test "$PHP_FILEINFO" != "no"; then
+
+ libmagic_sources=" \
+@@ -13,6 +16,8 @@
+ libmagic/is_tar.c libmagic/magic.c libmagic/print.c \
+ libmagic/readcdf.c libmagic/readelf.c libmagic/softmagic.c"
+
++ PHP_ADD_INCLUDE($PHP_PCRE_DIR/include)
++
+ PHP_NEW_EXTENSION(fileinfo, fileinfo.c $libmagic_sources, $ext_shared,,-I@ext_srcdir@/libmagic)
+ PHP_ADD_BUILD_DIR($ext_builddir/libmagic)
+
diff --git a/sysutils/php55-posix/Makefile b/sysutils/php55-posix/Makefile
new file mode 100644
index 000000000000..e2e68caa9241
--- /dev/null
+++ b/sysutils/php55-posix/Makefile
@@ -0,0 +1,10 @@
+# Created by: Alex Dupre <ale@FreeBSD.org>
+# $FreeBSD$
+
+CATEGORIES= sysutils
+
+MASTERDIR= ${.CURDIR}/../../lang/php55
+
+PKGNAMESUFFIX= -posix
+
+.include "${MASTERDIR}/Makefile"
diff --git a/sysutils/php55-posix/files/patch-posix.c b/sysutils/php55-posix/files/patch-posix.c
new file mode 100644
index 000000000000..d2365b249569
--- /dev/null
+++ b/sysutils/php55-posix/files/patch-posix.c
@@ -0,0 +1,38 @@
+--- posix.c.orig Fri Feb 23 00:40:39 2007
++++ posix.c Sun May 13 17:52:27 2007
+@@ -838,7 +838,7 @@
+ #if defined(ZTS) && defined(HAVE_GETGRNAM_R) && defined(_SC_GETGR_R_SIZE_MAX)
+ buflen = sysconf(_SC_GETGR_R_SIZE_MAX);
+ if (buflen < 1) {
+- RETURN_FALSE;
++ buflen = 1024;
+ }
+ buf = emalloc(buflen);
+ g = &gbuf;
+@@ -888,7 +888,7 @@
+
+ grbuflen = sysconf(_SC_GETGR_R_SIZE_MAX);
+ if (grbuflen < 1) {
+- RETURN_FALSE;
++ grbuflen = 1024;
+ }
+
+ grbuf = emalloc(grbuflen);
+@@ -955,7 +955,7 @@
+ #if defined(ZTS) && defined(_SC_GETPW_R_SIZE_MAX) && defined(HAVE_GETPWNAM_R)
+ buflen = sysconf(_SC_GETPW_R_SIZE_MAX);
+ if (buflen < 1) {
+- RETURN_FALSE;
++ buflen = 1024;
+ }
+ buf = emalloc(buflen);
+ pw = &pwbuf;
+@@ -1004,7 +1004,7 @@
+ #if defined(ZTS) && defined(_SC_GETPW_R_SIZE_MAX) && defined(HAVE_GETPWUID_R)
+ pwbuflen = sysconf(_SC_GETPW_R_SIZE_MAX);
+ if (pwbuflen < 1) {
+- RETURN_FALSE;
++ pwbuflen = 1024;
+ }
+ pwbuf = emalloc(pwbuflen);
+