aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils
diff options
context:
space:
mode:
authornobutaka <nobutaka@FreeBSD.org>2014-08-06 22:55:14 +0800
committernobutaka <nobutaka@FreeBSD.org>2014-08-06 22:55:14 +0800
commit493e9477f0c85a3c06a9226fd1e547660601b0ab (patch)
tree24ed14014dd7182058e97b443e6c0a7f13a76bab /sysutils
parent18d6a896c6dde1d40882ccc313a72cfcc68545d2 (diff)
downloadfreebsd-ports-gnome-493e9477f0c85a3c06a9226fd1e547660601b0ab.tar.gz
freebsd-ports-gnome-493e9477f0c85a3c06a9226fd1e547660601b0ab.tar.zst
freebsd-ports-gnome-493e9477f0c85a3c06a9226fd1e547660601b0ab.zip
Update to 1.5.0.
PR: 192312 Submitted by: antoine
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/bulk_extractor/Makefile6
-rw-r--r--sysutils/bulk_extractor/distinfo4
-rw-r--r--sysutils/bulk_extractor/files/patch-src__image_process.h15
3 files changed, 8 insertions, 17 deletions
diff --git a/sysutils/bulk_extractor/Makefile b/sysutils/bulk_extractor/Makefile
index 677b25d49d6e..9a849055b884 100644
--- a/sysutils/bulk_extractor/Makefile
+++ b/sysutils/bulk_extractor/Makefile
@@ -2,10 +2,9 @@
# $FreeBSD$
PORTNAME= bulk_extractor
-PORTVERSION= 1.4.4
-PORTREVISION= 2
+PORTVERSION= 1.5.0
CATEGORIES= sysutils
-MASTER_SITES= http://www.digitalcorpora.org/downloads/bulk_extractor/
+MASTER_SITES= http://digitalcorpora.org/downloads/bulk_extractor/
MAINTAINER= nobutaka@FreeBSD.org
COMMENT= Program that scans a disk image and extracts useful information
@@ -19,6 +18,7 @@ LIB_DEPENDS= libafflib.so:${PORTSDIR}/sysutils/afflib \
libexpat.so:${PORTSDIR}/textproc/expat2
USE_OPENSSL= yes
+USE_SQLITE= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --enable-exiv2=true
CPPFLAGS+= -I${LOCALBASE}/include
diff --git a/sysutils/bulk_extractor/distinfo b/sysutils/bulk_extractor/distinfo
index c626b6706991..9629748a3449 100644
--- a/sysutils/bulk_extractor/distinfo
+++ b/sysutils/bulk_extractor/distinfo
@@ -1,2 +1,2 @@
-SHA256 (bulk_extractor-1.4.4.tar.gz) = 9f779b0e9e938639bb2ec98af7c1cb8dd76ce845999fb13123b266fbac1d5bbb
-SIZE (bulk_extractor-1.4.4.tar.gz) = 4481240
+SHA256 (bulk_extractor-1.5.0.tar.gz) = 0b9a3388938b48584a9f953ed32b8280c2c6ae2b8635f55333bca212a75bdde2
+SIZE (bulk_extractor-1.5.0.tar.gz) = 4422317
diff --git a/sysutils/bulk_extractor/files/patch-src__image_process.h b/sysutils/bulk_extractor/files/patch-src__image_process.h
index d8ef64f302a3..b93999f012ca 100644
--- a/sysutils/bulk_extractor/files/patch-src__image_process.h
+++ b/sysutils/bulk_extractor/files/patch-src__image_process.h
@@ -1,15 +1,6 @@
---- ./src/image_process.h.orig 2014-01-15 15:00:06.000000000 +0000
-+++ ./src/image_process.h 2014-06-09 14:15:54.000000000 +0000
-@@ -128,7 +128,7 @@
- virtual int open()=0; /* open; return 0 if successful */
- virtual int pread(uint8_t *,size_t bytes,int64_t offset) const =0; /* read */
- virtual int64_t image_size() const=0;
-- virtual std::string image_fname() const { return image_fname_;}
-+ virtual const std::string &image_fname() const { return image_fname_;}
-
- /* iterator support; these virtual functions are called by iterator through (*myimage) */
- virtual image_process::iterator begin() const =0;
-@@ -154,7 +154,7 @@
+--- src/image_process.h.orig 2014-08-06 23:40:34.000000000 +0900
++++ src/image_process.h 2014-08-06 23:40:05.000000000 +0900
+@@ -157,7 +157,7 @@
****************************************************************/
#ifdef HAVE_LIBAFFLIB