aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils
diff options
context:
space:
mode:
authormm <mm@FreeBSD.org>2010-09-22 00:08:11 +0800
committermm <mm@FreeBSD.org>2010-09-22 00:08:11 +0800
commit66250384aac316bb7c7e78e17a9f60ee4eef0d73 (patch)
treeac1208411d08a7a297bc4f544163f0a43e756b59 /sysutils
parent48de0cba3d21dae83e5b1fed09e41e79380ef9ec (diff)
downloadfreebsd-ports-gnome-66250384aac316bb7c7e78e17a9f60ee4eef0d73.tar.gz
freebsd-ports-gnome-66250384aac316bb7c7e78e17a9f60ee4eef0d73.tar.zst
freebsd-ports-gnome-66250384aac316bb7c7e78e17a9f60ee4eef0d73.zip
Explicitly depend on p5-Digest-MD5 only if PERL_LEVEL < 500703
Explicitly depend on p5-Digest-SHA only if PERL_LEVEL < 501000
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/munin-master/Makefile12
-rw-r--r--sysutils/userneu-devel/Makefile13
-rw-r--r--sysutils/userneu/Makefile12
3 files changed, 27 insertions, 10 deletions
diff --git a/sysutils/munin-master/Makefile b/sysutils/munin-master/Makefile
index d525ac566eb4..47049db20b0c 100644
--- a/sysutils/munin-master/Makefile
+++ b/sysutils/munin-master/Makefile
@@ -7,6 +7,7 @@
PORTNAME= munin
PORTVERSION= 1.4.5
+PORTREVISION= 1
CATEGORIES= sysutils perl5
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}%20stable/${PORTVERSION}
PKGNAMESUFFIX= -master
@@ -16,7 +17,6 @@ COMMENT= Collector part of Munin
BUILD_DEPENDS= ${SITE_PERL}/Module/Build.pm:${PORTSDIR}/devel/p5-Module-Build \
${SITE_PERL}/Munin/Common/Defaults.pm:${PORTSDIR}/sysutils/munin-common \
- ${SITE_PERL}/${PERL_ARCH}/Digest/MD5.pm:${PORTSDIR}/security/p5-Digest-MD5 \
${SITE_PERL}/${PERL_ARCH}/Net/SSLeay.pm:${PORTSDIR}/security/p5-Net-SSLeay \
${SITE_PERL}/${PERL_ARCH}/RRDs.pm:${PORTSDIR}/databases/rrdtool \
${SITE_PERL}/${PERL_ARCH}/Storable.pm:${PORTSDIR}/converters/p5-Storable-AMF \
@@ -27,7 +27,6 @@ BUILD_DEPENDS= ${SITE_PERL}/Module/Build.pm:${PORTSDIR}/devel/p5-Module-Build \
${SITE_PERL}/Text/Balanced.pm:${PORTSDIR}/textproc/p5-Text-Balanced
RUN_DEPENDS= ${SITE_PERL}/Munin/Common/Defaults.pm:${PORTSDIR}/sysutils/munin-common \
${SITE_PERL}/${PERL_ARCH}/RRDs.pm:${PORTSDIR}/databases/rrdtool \
- ${SITE_PERL}/${PERL_ARCH}/Digest/MD5.pm:${PORTSDIR}/security/p5-Digest-MD5 \
${SITE_PERL}/${PERL_ARCH}/Net/SSLeay.pm:${PORTSDIR}/security/p5-Net-SSLeay \
${SITE_PERL}/${PERL_ARCH}/Storable.pm:${PORTSDIR}/converters/p5-Storable-AMF \
${SITE_PERL}/DateTime/HiRes.pm:${PORTSDIR}/devel/p5-DateTime-HiRes \
@@ -67,6 +66,13 @@ MAN8= munin-cron.8 \
PLIST_SUB= DBDIR=${DBDIR}
SUB_FILES= pkg-message
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500703
+RUN_DEPENDS+= p5-Digest-MD5>=2.16:${PORTSDIR}/security/p5-Digest-MD5
+BUILD_DEPENDS+= p5-Digest-MD5>=2.16:${PORTSDIR}/security/p5-Digest-MD5
+.endif
+
pre-install:
@${SETENV} ${SCRIPTS_ENV} PKG_PREFIX=${PREFIX} \
${SH} ${PKGDIR}/pkg-install ${PKGNAME} PRE-INSTALL
@@ -88,4 +94,4 @@ post-install:
${SH} ${PKGDIR}/pkg-install ${PKGNAME} POST-INSTALL
@${CAT} ${PKGMESSAGE}
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/sysutils/userneu-devel/Makefile b/sysutils/userneu-devel/Makefile
index 0f5d504e6e7f..e497d7627ec6 100644
--- a/sysutils/userneu-devel/Makefile
+++ b/sysutils/userneu-devel/Makefile
@@ -7,7 +7,7 @@
PORTNAME= userneu
PORTVERSION= 1.43
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= sysutils
MASTER_SITES= http://btw23.de/johannes/files/userneu/\
http://home.arcor.de/fehlner/fbsd_ports/\
@@ -20,8 +20,7 @@ COMMENT= Account management and creation tool
RUN_DEPENDS= \
${SITE_PERL}/Crypt/PasswdMD5.pm:${PORTSDIR}/security/p5-Crypt-PasswdMD5/ \
- ${SITE_PERL}/Crypt/RandPasswd.pm:${PORTSDIR}/security/p5-Crypt-RandPasswd/ \
- ${SITE_PERL}/${PERL_ARCH}/Digest/MD5.pm:${PORTSDIR}/security/p5-Digest-MD5/
+ ${SITE_PERL}/Crypt/RandPasswd.pm:${PORTSDIR}/security/p5-Crypt-RandPasswd/
USE_PERL5_RUN= yes
NO_BUILD= yes
@@ -36,6 +35,12 @@ LDOCS2= README INSTALL userneu.pod userneu.conf.pod
PORTDOCS= ${LDOCS1} ${LDOCS2}
EXAMPLES= userlist userneu.conf.example
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500703
+RUN_DEPENDS+= p5-Digest-MD5>=2.16:${PORTSDIR}/security/p5-Digest-MD5
+.endif
+
do-install:
cd ${WRKSRC}/doc && ${INSTALL_MAN} ${MAN8} ${MANPREFIX}/man/man8
cd ${WRKSRC}/doc && ${INSTALL_MAN} ${MAN5} ${MANPREFIX}/man/man5
@@ -49,4 +54,4 @@ do-install:
cd ${WRKSRC}/doc && ${INSTALL_DATA} ${LDOCS2} ${DOCSDIR}
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/sysutils/userneu/Makefile b/sysutils/userneu/Makefile
index cdf8ce6f3301..e42d00f4bd83 100644
--- a/sysutils/userneu/Makefile
+++ b/sysutils/userneu/Makefile
@@ -7,6 +7,7 @@
PORTNAME= userneu
PORTVERSION= 1.38
+PORTREVISION= 1
CATEGORIES= sysutils
MASTER_SITES= http://btw23.de/johannes/userneu/ \
http://home.arcor.de/fehlner/fbsd_ports/ \
@@ -18,8 +19,7 @@ COMMENT= Account management and creation tool
RUN_DEPENDS= \
${SITE_PERL}/Crypt/PasswdMD5.pm:${PORTSDIR}/security/p5-Crypt-PasswdMD5 \
- ${SITE_PERL}/Crypt/RandPasswd.pm:${PORTSDIR}/security/p5-Crypt-RandPasswd \
- ${SITE_PERL}/${PERL_ARCH}/Digest/MD5.pm:${PORTSDIR}/security/p5-Digest-MD5
+ ${SITE_PERL}/Crypt/RandPasswd.pm:${PORTSDIR}/security/p5-Crypt-RandPasswd
USE_PERL5_RUN= yes
NO_BUILD= yes
@@ -32,6 +32,12 @@ DOCS= BUGS CHANGES CREDITS REQUIREMENTS TODO \
doc/README doc/INSTALL doc/userneu.pod doc/userquick.pod
EXAMPLES= list-sample
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500703
+RUN_DEPENDS+= p5-Digest-MD5>=2.16:${PORTSDIR}/security/p5-Digest-MD5
+.endif
+
do-install:
cd ${WRKSRC}/doc && ${INSTALL_MAN} ${MAN8} ${MANPREFIX}/man/man8
cd ${WRKSRC} && ${INSTALL_SCRIPT} ${SCRIPTS} ${PREFIX}/sbin
@@ -42,4 +48,4 @@ do-install:
cd ${WRKSRC} && ${INSTALL_DATA} ${DOCS} ${DOCSDIR}
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>