aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2013-06-07 06:07:46 +0800
committerbapt <bapt@FreeBSD.org>2013-06-07 06:07:46 +0800
commit7dc6b8811bf02df508f96656af399ac948f94e08 (patch)
tree8c71d21e638ef6b6e920ca4e675f8c62ef126776 /sysutils
parent1acf7c600c38be5b2067908717a727c171684612 (diff)
downloadfreebsd-ports-gnome-7dc6b8811bf02df508f96656af399ac948f94e08.tar.gz
freebsd-ports-gnome-7dc6b8811bf02df508f96656af399ac948f94e08.tar.zst
freebsd-ports-gnome-7dc6b8811bf02df508f96656af399ac948f94e08.zip
Convert to new options framework
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/ganglia-monitor-core/Makefile21
1 files changed, 8 insertions, 13 deletions
diff --git a/sysutils/ganglia-monitor-core/Makefile b/sysutils/ganglia-monitor-core/Makefile
index 1ab0caaf0820..de9b0af5d0b8 100644
--- a/sysutils/ganglia-monitor-core/Makefile
+++ b/sysutils/ganglia-monitor-core/Makefile
@@ -1,9 +1,4 @@
-# Ports collection makefile for: ganglia-monitor-core
-# Date created: Wed Jan 23, 2003
-# Whom: Brooks Davis <brooks@freebsd.org>
-#
# $FreeBSD$
-#
PORTNAME= monitor-core
PORTVERSION= 3.1.7
@@ -25,7 +20,9 @@ LIB_DEPENDS= apr-1:${PORTSDIR}/devel/apr1 \
PKGINSTALL= ${WRKDIR}/pkg-install
-OPTIONS+= GMETAD "include gmetad" on
+OPTIONS_DEFINE= GMETAD
+OPTIONS_DEFAULT= GMETAD
+GMETAD_DESC= include gmetad
USE_PYTHON= yes
USE_AUTOTOOLS= libtool
@@ -55,14 +52,12 @@ IGNORE= the variable GMOND_CONF must point to a file when defined
GMOND_CONF= ${WRKDIR}/gmond.conf
.endif
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
USE_RC_SUBR= gmond
-.if defined (WITH_GMETAD)
+.if ${PORT_OPTIONS:MGMETAD}
USE_RC_SUBR+= gmetad
-.endif
-.if defined (WITH_GMETAD)
LIB_DEPENDS+= rrd:${PORTSDIR}/databases/rrdtool
CONFIGURE_ARGS+= --with-gmetad
PLIST_SUB+= GMETAD=
@@ -75,7 +70,7 @@ SUB_LIST+= GMETAD="\#"
USE_LDCONFIG= yes
MAN1= gmetric.1 gmond.1 gstat.1
-.if defined (WITH_GMETAD)
+.if ${PORT_OPTIONS:MGMETAD}
MAN1+= gmetad.1
.endif
MAN5= gmond.conf.5
@@ -118,7 +113,7 @@ post-build:
${WRKSRC}/gmond/gmond -t > ${WRKDIR}/gmond.conf
post-install:
-.if defined(WITH_GMETAD)
+.if ${PORT_OPTIONS:MGMETAD}
${INSTALL_SCRIPT} ${FILESDIR}/gmetasnap.sh ${PREFIX}/sbin/gmetasnap
${INSTALL_MAN} ${WRKSRC}/mans/gmetad.1 ${MANPREFIX}/man/man1
${INSTALL_DATA} ${GMETAD_CONF} ${PREFIX}/etc/gmetad.conf.sample
@@ -130,4 +125,4 @@ post-install:
${INSTALL_DATA} ${GMOND_CONF} ${PREFIX}/etc/gmond.conf.sample
${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>