aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2012-01-29 01:49:55 +0800
committermiwi <miwi@FreeBSD.org>2012-01-29 01:49:55 +0800
commit903e90401e5b5633d60c2be7362ee1d00e57680d (patch)
treea78f02f52c6e5cfa6d042418f63277db397b7629 /sysutils
parent463e2cca0183d146c60847de53182b1a50350df0 (diff)
downloadfreebsd-ports-gnome-903e90401e5b5633d60c2be7362ee1d00e57680d.tar.gz
freebsd-ports-gnome-903e90401e5b5633d60c2be7362ee1d00e57680d.tar.zst
freebsd-ports-gnome-903e90401e5b5633d60c2be7362ee1d00e57680d.zip
- Update to 1.30
PR: 164167 Submitted by: Ports Fury
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/x86info/Makefile34
-rw-r--r--sysutils/x86info/distinfo4
-rw-r--r--sysutils/x86info/files/patch-features.c11
3 files changed, 23 insertions, 26 deletions
diff --git a/sysutils/x86info/Makefile b/sysutils/x86info/Makefile
index bd003ef78d7d..5871ee9bb6f6 100644
--- a/sysutils/x86info/Makefile
+++ b/sysutils/x86info/Makefile
@@ -6,36 +6,44 @@
#
PORTNAME= x86info
-PORTVERSION= 1.29
-PORTREVISION= 0
+PORTVERSION= 1.30
CATEGORIES= sysutils
-MASTER_SITES= http://codemonkey.org.uk/projects/x86info/ \
- http://codemonkey.org.uk/projects/x86info/old/
+MASTER_SITES= http://codemonkey.org.uk/projects/x86info/%SUBDIR%/
+MASTER_SITE_SUBDIR= . old
EXTRACT_SUFX= .tgz
MAINTAINER= ports@FreeBSD.org
COMMENT= Utility to display information about the systems x86 processor(s)
+LICENSE= GPLv2
+
+ONLY_FOR_ARCHS= i386 amd64
+
LIB_DEPENDS= pci.3:${PORTSDIR}/devel/libpci
-USE_GMAKE= yes
-USE_PYTHON_BUILD= yes
USE_GNOME= pkgconfig
-LICENSE= GPLv2
+USE_PYTHON_BUILD=yes
+USE_GMAKE= yes
ALL_TARGET= x86info lsmsr
-ONLY_FOR_ARCHS= i386 amd64
-PLIST_FILES= bin/x86info bin/lsmsr
MAKE_JOBS_SAFE= yes
-MAN1= x86info.1
-MAN8= lsmsr.8
+
+MAN1= x86info.1
+MAN8= lsmsr.8
+PLIST_FILES= bin/lsmsr bin/x86info
post-patch:
- ${REINPLACE_CMD} -E -e 's,-g -O2,${CFLAGS},g' ${WRKSRC}/Makefile
+ @${REINPLACE_CMD} -e \
+ '/^CFLAGS/s| =| +=|g ; \
+ /^CFLAGS/s| -g|| ; \
+ /^CFLAGS/s| -O2|| ; \
+ /^CFLAGS/s| -Werror|| ; \
+ /^CC/s| =| ?=|' ${WRKSRC}/Makefile
.include <bsd.port.pre.mk>
+
.if ${OSVERSION} < 701102
BUILD_DEPENDS+= ${LOCALBASE}/include/cpu.h:${PORTSDIR}/sysutils/devcpu
-CFLAGS+= -I"${LOCALBASE}"/include
+CFLAGS+= -I${LOCALBASE}/include
.endif
do-install:
diff --git a/sysutils/x86info/distinfo b/sysutils/x86info/distinfo
index 82bdfbdd32db..71827c520298 100644
--- a/sysutils/x86info/distinfo
+++ b/sysutils/x86info/distinfo
@@ -1,2 +1,2 @@
-SHA256 (x86info-1.29.tgz) = 9f9a36717af60194fcab2eee39f24a1fa5a01d50b848149da3b63ed39161555c
-SIZE (x86info-1.29.tgz) = 87526
+SHA256 (x86info-1.30.tgz) = fe3009850e93a9c5fa38ed6bf74d72686043329fead8f1b2be4b5943d4fc9428
+SIZE (x86info-1.30.tgz) = 95727
diff --git a/sysutils/x86info/files/patch-features.c b/sysutils/x86info/files/patch-features.c
deleted file mode 100644
index 5b9d650d3028..000000000000
--- a/sysutils/x86info/files/patch-features.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- features.c.orig 2011-09-16 16:57:57.000000000 -0700
-+++ features.c 2011-09-16 16:58:06.000000000 -0700
-@@ -469,7 +469,7 @@
- died = sigsetjmp(out, 1);
-
- if (!died)
-- asm volatile("nopl 0(%eax)");
-+ asm volatile(".byte 0x0f,0x1f,0x00 /* nopl 0(%eax) */");
-
- printf("Long NOPs supported: %s\n", died ? "no" : "yes");
- }