aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils
diff options
context:
space:
mode:
authorgnn <gnn@FreeBSD.org>2012-02-08 04:19:30 +0800
committergnn <gnn@FreeBSD.org>2012-02-08 04:19:30 +0800
commit9a4757551adc47c3a4f2fbe26a37751ce1d61ad4 (patch)
tree0846d1e0a220447ce2db2ce471b279b84f9440cb /sysutils
parent6f99b021881647b417181df09b00850acd58eb43 (diff)
downloadfreebsd-ports-gnome-9a4757551adc47c3a4f2fbe26a37751ce1d61ad4.tar.gz
freebsd-ports-gnome-9a4757551adc47c3a4f2fbe26a37751ce1d61ad4.tar.zst
freebsd-ports-gnome-9a4757551adc47c3a4f2fbe26a37751ce1d61ad4.zip
Add a new port to track the head of the synergy development tree.
Major versions of synergy are protocol incompatible so tracking both development and stable branches, with one port for each, gives us the most flexibility. Approved by: skreuzer@
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/synergy-devel/Makefile41
-rw-r--r--sysutils/synergy-devel/distinfo2
-rw-r--r--sysutils/synergy-devel/pkg-descr10
3 files changed, 53 insertions, 0 deletions
diff --git a/sysutils/synergy-devel/Makefile b/sysutils/synergy-devel/Makefile
new file mode 100644
index 000000000000..7e62e49227ff
--- /dev/null
+++ b/sysutils/synergy-devel/Makefile
@@ -0,0 +1,41 @@
+# New ports collection makefile for: synergy-devel
+# Date created: 6 February 2012
+# Whom: George Neville-Neil <gnn@freebsd.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= synergy
+PORTVERSION= 1.4.7
+DISTVERSIONSUFFIX= -Source
+CATEGORIES= sysutils
+MASTER_SITES= GOOGLE_CODE
+PKGNAMESUFFIX= -devel
+
+MAINTAINER= gnn@FreeBSD.org
+COMMENT= Mouse and keyboard sharing utility
+
+CONFLICTS= synergy-[0-9]*
+USE_CMAKE= yes
+USE_XORG= ice xtst x11 sm
+MAKE_ENV+= PTHREAD_CFLAGS="${PTHREAD_CFLAGS}" \
+ PTHREAD_LIBS="${PTHREAD_LIBS}"
+
+CFLAGS+= -L${LOCALBASE}/lib -I${LOCALBASE}/include
+
+PLIST_FILES= bin/synergys bin/synergyc
+PORTEXAMPLES= synergy.conf.example synergy.conf.example-basic \
+ synergy.conf.example-advanced
+
+do-install:
+.for f in synergys synergyc
+ ${INSTALL_PROGRAM} ${WRKSRC}/bin/${f} ${PREFIX}/bin
+.endfor
+.if !defined(NOPORTEXAMPLES)
+ ${MKDIR} ${EXAMPLESDIR}
+.for f in ${PORTEXAMPLES}
+ ${INSTALL_DATA} ${WRKSRC}/doc/${f} ${EXAMPLESDIR}
+.endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/sysutils/synergy-devel/distinfo b/sysutils/synergy-devel/distinfo
new file mode 100644
index 000000000000..1ca19f4ddd51
--- /dev/null
+++ b/sysutils/synergy-devel/distinfo
@@ -0,0 +1,2 @@
+SHA256 (synergy-1.4.7-Source.tar.gz) = e224d2ab822dc7b6e90a87587ed7d9e32f27d05efebc8430ecf61b3610baea3b
+SIZE (synergy-1.4.7-Source.tar.gz) = 2998229
diff --git a/sysutils/synergy-devel/pkg-descr b/sysutils/synergy-devel/pkg-descr
new file mode 100644
index 000000000000..d98ead4cd965
--- /dev/null
+++ b/sysutils/synergy-devel/pkg-descr
@@ -0,0 +1,10 @@
+Development version of Synergy trackng the head of their
+development tree.
+
+Synergy lets you easily share a single mouse and keyboard between
+multiple computers with different operating systems, each with its
+own display, without special hardware. It's intended for users
+with multiple computers on their desk since each system uses its
+own display.
+
+WWW: http://synergy-foss.org/