aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2012-10-17 06:47:46 +0800
committerbapt <bapt@FreeBSD.org>2012-10-17 06:47:46 +0800
commit9d6e6d9f08c1d035bb04d3762bee954b35bdf2ec (patch)
treec0bba62d266770a9fbc94a956dbf735ea0c2a12f /sysutils
parentdd73fbe2f01b795615395c066369ab60f3254137 (diff)
downloadfreebsd-ports-gnome-9d6e6d9f08c1d035bb04d3762bee954b35bdf2ec.tar.gz
freebsd-ports-gnome-9d6e6d9f08c1d035bb04d3762bee954b35bdf2ec.tar.zst
freebsd-ports-gnome-9d6e6d9f08c1d035bb04d3762bee954b35bdf2ec.zip
Convert to new options framework
PR: ports/172424 Submitted by: Michael Gmelin <freebsd@grem.de> Feature safe: yes
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/jfbterm/Makefile37
1 files changed, 18 insertions, 19 deletions
diff --git a/sysutils/jfbterm/Makefile b/sysutils/jfbterm/Makefile
index 2473c3d1bd27..d94eaafe7688 100644
--- a/sysutils/jfbterm/Makefile
+++ b/sysutils/jfbterm/Makefile
@@ -1,7 +1,4 @@
-# New ports collection makefile for: jfbterm
-# Date created: Feb 23 2008
-# Whom: nrg milk <bsdports@gmail.com>
-#
+# Created by: nrg milk <bsdports@gmail.com>
# $FreeBSD$
PORTNAME= jfbterm
@@ -32,17 +29,19 @@ CAP_MKDB?= /usr/bin/cap_mkdb
TIC?= ${LOCALBASE}/bin/tic
TERMINFO_FILE?= ${PREFIX}/share/misc/${PORTNAME}.terminfo
-OPTIONS= ICONV "encodings support" On \
- PNG "splash .png support" On \
- TERMCAP "add entry to termcap(5) file" On \
- UNIFONT "install pan-unicode font" On
+OPTIONS_DEFINE= ICONV PNG SETUID TERMCAP UNIFONT
+OPTIONS_DEFAULT= ICONV PNG SETUID TERMCAP UNIFONT
+PNG_DESC= Splash .png support
+SETUID_DESC= Install jfbterm with setuid bit set
+TERMCAP_DESC= Add entry to termcap(5) file
+UNIFONT_DESC= Install pan-unicode font
-.if !defined(WITHOUT_SETUID)
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MSETUID}
BINMODE?= 4555
.endif
-.include <bsd.port.pre.mk>
-
.if ${OSVERSION} >= 800504
ONLY_FOR_ARCHS+=amd64
.endif
@@ -58,12 +57,12 @@ MAN1= ${PORTNAME}.1
MAN5= ${PORTNAME}.conf.5
.endif
-.if defined(WITHOUT_ICONV)
+.if !${PORT_OPTIONS:MICONV}
MAKE_ENV+= WITHOUT_ICONV=
.endif
.if !exists(/usr/include/iconv.h)
-. if !defined(WITHOUT_ICONV)
+. if ${PORT_OPTIONS:MICONV}
. if !defined(NO_SHARED)
USE_ICONV= yes
. else
@@ -74,7 +73,7 @@ BUILD_DEPENDS+= ${LOCALBASE}/include/iconv.h:${PORTSDIR}/converters/libiconv
. endif
.endif
-.if !defined(WITHOUT_PNG)
+.if ${PORT_OPTIONS:MPNG}
. if !defined(NO_SHARED)
LIB_DEPENDS+= png15:${PORTSDIR}/graphics/png
. else
@@ -84,7 +83,7 @@ BUILD_DEPENDS+= ${LOCALBASE}/lib/libpng.a:${PORTSDIR}/graphics/png
MAKE_ENV+= WITHOUT_PNG=
.endif
-.if !defined(WITHOUT_TERMCAP)
+.if ${PORT_OPTIONS:MTERMCAP}
TERMCAP_ADD_RECORD= \
${ECHO_CMD} '\# begin of ${PORTNAME}.termcap' \
>>${TERMCAP_FILE}; \
@@ -107,7 +106,7 @@ TERMCAP_ADD_RECORD= ${DO_NADA}
TERMCAP_DEL_RECORD= ${DO_NADA}
.endif
-.if !defined(WITHOUT_UNIFONT)
+.if ${PORT_OPTIONS:MUNIFONT}
RUN_DEPENDS+= ${LOCALBASE}/lib/X11/fonts/local/unifont.pcf.gz:${PORTSDIR}/x11-fonts/gnu-unifont
.endif
@@ -122,7 +121,7 @@ post-patch: .SILENT
${REINPLACE_CMD} -e 's|/usr/local|${PREFIX}|g' \
-e 's|\(share\)/${PORTNAME}/\(fonts\)|\1/misc/\2|' \
${WRKSRC}/*.[0-9] ${WRKSRC}/*.conf.sample
-.if defined(WITHOUT_TERMCAP)
+.if !${PORT_OPTIONS:MTERMCAP}
${REINPLACE_CMD} '/^term/s/:.*/: xterm/' \
${WRKSRC}/${PORTNAME}.conf.sample
.endif
@@ -143,10 +142,10 @@ do-install:
${INSTALL_DATA} ${WRKSRC}/terminfo.${PORTNAME} ${PREFIX}/share/misc/${PORTNAME}.terminfo
${MKDIR} ${PREFIX}/share/misc/fonts
${INSTALL_DATA} ${WRKSRC}/fonts/*.pcf.gz ${PREFIX}/share/misc/fonts
-. if !defined(WITHOUT_TERMCAP)
+. if ${PORT_OPTIONS:MTERMCAP}
${TERMCAP_ADD_RECORD}
. endif
-${TIC} ${TERMINFO_FILE} 2>/dev/null
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
pan title='2011-04-04 04:33:42 +0800'>2011-04-043-3/+4 * Add back PORTEPOCH. (that for some reason I misread as PORTREVISIONnox2010-12-181-0/+1 * Update to 6.0.1.2032 (which is the current version again, looks like thenox2010-12-184-491/+105 * Go back to 5.1.3535.3218 for the time being, the new version, 5.2.1.1547,nox2010-08-173-53/+137 * Chase updated distfile, at 5.2.1.1329 now.nox2010-06-203-135/+52 * - Chase updated distfile, at 5.1.3535.3218 now. [1]nox2010-05-186-14/+47 * Fix build for nonstandard PREFIX / LOCALBASE.nox2010-05-132-3/+3 * Chase updated distfile, at 5.1.3533.1731 now.nox2009-11-272-4/+4 * Put back previous Linux version check, this time with proper braces. (duh!)nox2009-10-211-4/+4 * Comment out last commit to fix INDEX-8.linimon2009-10-201-4/+4 * Add a conditional IGNORE so people using a too old Linux base get anox2009-10-201-0/+8 * Chase updated distfile, at 5.1.3509.4636 now.nox2009-09-252-4/+4 * Chase updated distfile, at 5.1.3506.3999 now.nox2009-09-113-371/+120 * - Limit the stack size for Google Earth. Linux glibc threading behavesnox2009-08-072-2/+14 * Chase updated distfile, at 5.0.11733.9347 now.nox2009-05-092-4/+4 * Chase updated distfile, at 5.0.11729.1014 now.nox2009-05-053-8/+7 * - Convert linux dri dependency to USE_LINUX_APPSnox2009-04-121-1/+2 * Welcome to the new linux ports infrastructure which allows usingbsam2009-03-201-1/+1 * Update to 5.0.11337.1968, adding Mars and oceansnox2009-02-053-120/+228 * Fix non-root build by moving the chown to a pre-su-install targetnox2009-01-251-0/+2 * In preparation for adding new linux (Fedora 8) infrastructure ports all linuxbsam2009-01-221-3/+2 * Get rid of the custom do-fetch target (which didn't cover all cases)nox2009-01-122-17/+7 * Add missing dependencynox2008-09-251-1/+2 * Fix a typo which causes files not to be owned by root:wheelnox2008-09-191-1/+2 * Chase updated distfile, at 4.3.7284.3916 nownox2008-07-132-5/+4 * Bump portrevision due to upgrade of devel/gettext.edwin2008-06-061-0/+1 * Chase updated distfile, at 4.3.7204.836 now (working again on 6, at leastnox2008-05-032-8/+6 * - Chase updated distfile, at 4.3.7191.6508 now (unfortunately no longernox2008-04-203-768/+176 * Make fetchable again by updating to 4.2.205.5730nox2007-12-223-4/+13 * - Chase updated distfile, at 4.2.198.2451 nownox2007-09-183-6/+7 * - Update to 4.2.180.1134 (adding the sky and a flight simulatornox2007-09-103-1732/+771 * - Add even more ports to the new "geography" categorylaszlof2007-07-231-1/+1 * Update to 4.1.7076.4458.flz2007-06-023-51/+646 * BROKEN: Checksum mismatchkris2007-05-251-0/+2