aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils
diff options
context:
space:
mode:
authorskreuzer <skreuzer@FreeBSD.org>2009-10-13 03:33:13 +0800
committerskreuzer <skreuzer@FreeBSD.org>2009-10-13 03:33:13 +0800
commita7ece7fb54860c29012fb620908471334a98201d (patch)
treedd0fe5ca0cc8f8e2f87596ed41abb26370146c94 /sysutils
parent988605a9ace0bed057ee0844e5cfcca27e55364f (diff)
downloadfreebsd-ports-gnome-a7ece7fb54860c29012fb620908471334a98201d.tar.gz
freebsd-ports-gnome-a7ece7fb54860c29012fb620908471334a98201d.tar.zst
freebsd-ports-gnome-a7ece7fb54860c29012fb620908471334a98201d.zip
Synergy+ is a maintenance fork for implementing bug fixes to the original
Synergy, which hasn't had any source updates or new releases since 2006
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/Makefile1
-rw-r--r--sysutils/synergy-plus/Makefile30
-rw-r--r--sysutils/synergy-plus/distinfo3
-rw-r--r--sysutils/synergy-plus/pkg-descr6
-rw-r--r--sysutils/synergy-plus/pkg-plist5
5 files changed, 45 insertions, 0 deletions
diff --git a/sysutils/Makefile b/sysutils/Makefile
index 4f457f9cc88c..c562733bc84f 100644
--- a/sysutils/Makefile
+++ b/sysutils/Makefile
@@ -742,6 +742,7 @@
SUBDIR += symlinks
SUBDIR += symon
SUBDIR += synergy
+ SUBDIR += synergy-plus
SUBDIR += syscp
SUBDIR += sysgather
SUBDIR += sysinfo
diff --git a/sysutils/synergy-plus/Makefile b/sysutils/synergy-plus/Makefile
new file mode 100644
index 000000000000..53c30dc0ec11
--- /dev/null
+++ b/sysutils/synergy-plus/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: synergy-plus
+# Date created: 2009-10-11
+# Whom: Steven Kreuzer <skreuzer@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= synergy-plus
+PORTVERSION= 1.3.4
+CATEGORIES= sysutils
+MASTER_SITES= GOOGLE_CODE
+
+MAINTAINER= skreuzer@FreeBSD.org
+COMMENT= Maintenance fork for implementing bug fixes to the original Synergy
+
+CONFLICTS= synergy-1*
+
+GNU_CONFIGURE= yes
+USE_XORG= ice xtst x11 sm
+CONFIGURE_ENV= PTHREAD_CFLAGS="${PTHREAD_CFLAGS}" \
+ PTHREAD_LIBS="${PTHREAD_LIBS}"
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|-Werror||' ${WRKSRC}/configure
+
+post-install:
+ ${MKDIR} ${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/examples/synergy.conf ${EXAMPLESDIR}
+
+.include <bsd.port.mk>
diff --git a/sysutils/synergy-plus/distinfo b/sysutils/synergy-plus/distinfo
new file mode 100644
index 000000000000..29b290ca2c26
--- /dev/null
+++ b/sysutils/synergy-plus/distinfo
@@ -0,0 +1,3 @@
+MD5 (synergy-plus-1.3.4.tar.gz) = 2c565afe5f920d363eef38dd97449b73
+SHA256 (synergy-plus-1.3.4.tar.gz) = b3c3ae4cd5e907d2584b939793da3323836bcc1222c38910decce9ae68335272
+SIZE (synergy-plus-1.3.4.tar.gz) = 754640
diff --git a/sysutils/synergy-plus/pkg-descr b/sysutils/synergy-plus/pkg-descr
new file mode 100644
index 000000000000..3893ad8af509
--- /dev/null
+++ b/sysutils/synergy-plus/pkg-descr
@@ -0,0 +1,6 @@
+Synergy+ lets you easily share a single mouse and keyboard between multiple
+computers with different operating systems, without special hardware. All you
+need is a LAN connection. It's intended for users with multiple computers,
+where each system uses its own display.
+
+WWW: http://code.google.com/p/synergy-plus/
diff --git a/sysutils/synergy-plus/pkg-plist b/sysutils/synergy-plus/pkg-plist
new file mode 100644
index 000000000000..ccb1d67c8f1f
--- /dev/null
+++ b/sysutils/synergy-plus/pkg-plist
@@ -0,0 +1,5 @@
+@comment $FreeBSD$
+bin/synergyc
+bin/synergys
+%%EXAMPLESDIR%%/synergy.conf
+@dirrm %%EXAMPLESDIR%%