aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2006-12-03 22:21:55 +0800
committerpav <pav@FreeBSD.org>2006-12-03 22:21:55 +0800
commitaa11655215153ffd33fe74d32bc08d7e29da735e (patch)
treeba3708169b971cd5d7c06d3927bf70b61b546e0c /sysutils
parent6d16747cce09a3aa6fc7c9e5d5ec209e25068651 (diff)
downloadfreebsd-ports-gnome-aa11655215153ffd33fe74d32bc08d7e29da735e.tar.gz
freebsd-ports-gnome-aa11655215153ffd33fe74d32bc08d7e29da735e.tar.zst
freebsd-ports-gnome-aa11655215153ffd33fe74d32bc08d7e29da735e.zip
- Try different approach: move extracting to post-extract target
Submitted by: Ruben van Staveren <ruben@verweg.com> (maintainer)
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/linux-megacli/Makefile7
-rw-r--r--sysutils/linux-megacli2/Makefile7
2 files changed, 6 insertions, 8 deletions
diff --git a/sysutils/linux-megacli/Makefile b/sysutils/linux-megacli/Makefile
index 9545bc8f6763..c94a0cf7bff8 100644
--- a/sysutils/linux-megacli/Makefile
+++ b/sysutils/linux-megacli/Makefile
@@ -15,9 +15,6 @@ DISTNAME= Linux_MegaCli_${PORTVERSION}
MAINTAINER= ruben@verweg.com
COMMENT= LSI MegaRAID SAS controller management utility
-BUILD_DEPENDS= unzip:${PORTSDIR}/archivers/unzip \
- ${RPM2CPIO}:${PORTSDIR}/archivers/rpm
-
NO_WRKSUBDIR= yes
USE_ZIP= yes
RESTRICTED= Redistribution prohibited, see: http://lsi.com/cm/License.do
@@ -29,10 +26,12 @@ SUB_FILES= megacli.sh
RPM2CPIO?= ${LOCALBASE}/bin/rpm2cpio
EXTRACT_DEPENDS+= ${RPM2CPIO}:${PORTSDIR}/archivers/rpm
-do-build:
+post-extract:
@cd ${WRKSRC} && \
${UNZIP_CMD} MegaCliLin.zip && \
${RPM2CPIO} MegaCli-${PORTVERSION}-0.i386.rpm | ${CPIO} -id --quiet
+
+do-build:
@${BRANDELF} -t Linux ${WRKSRC}/usr/sbin/MegaCli
do-install:
diff --git a/sysutils/linux-megacli2/Makefile b/sysutils/linux-megacli2/Makefile
index 9545bc8f6763..c94a0cf7bff8 100644
--- a/sysutils/linux-megacli2/Makefile
+++ b/sysutils/linux-megacli2/Makefile
@@ -15,9 +15,6 @@ DISTNAME= Linux_MegaCli_${PORTVERSION}
MAINTAINER= ruben@verweg.com
COMMENT= LSI MegaRAID SAS controller management utility
-BUILD_DEPENDS= unzip:${PORTSDIR}/archivers/unzip \
- ${RPM2CPIO}:${PORTSDIR}/archivers/rpm
-
NO_WRKSUBDIR= yes
USE_ZIP= yes
RESTRICTED= Redistribution prohibited, see: http://lsi.com/cm/License.do
@@ -29,10 +26,12 @@ SUB_FILES= megacli.sh
RPM2CPIO?= ${LOCALBASE}/bin/rpm2cpio
EXTRACT_DEPENDS+= ${RPM2CPIO}:${PORTSDIR}/archivers/rpm
-do-build:
+post-extract:
@cd ${WRKSRC} && \
${UNZIP_CMD} MegaCliLin.zip && \
${RPM2CPIO} MegaCli-${PORTVERSION}-0.i386.rpm | ${CPIO} -id --quiet
+
+do-build:
@${BRANDELF} -t Linux ${WRKSRC}/usr/sbin/MegaCli
do-install: