aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils
diff options
context:
space:
mode:
authorleeym <leeym@FreeBSD.org>2003-09-27 09:44:04 +0800
committerleeym <leeym@FreeBSD.org>2003-09-27 09:44:04 +0800
commitb6279fd1df7f616db7521ad00b2fe08698fae4cd (patch)
tree77e829738a0d350b645897c9b13f6f6c6789c541 /sysutils
parent26acd0587049f4ac61e843a598425212ced9374a (diff)
downloadfreebsd-ports-gnome-b6279fd1df7f616db7521ad00b2fe08698fae4cd.tar.gz
freebsd-ports-gnome-b6279fd1df7f616db7521ad00b2fe08698fae4cd.tar.zst
freebsd-ports-gnome-b6279fd1df7f616db7521ad00b2fe08698fae4cd.zip
- Fix options parsing
- Bump PORTREVISION PR: 57253 Submitted by: Nicolas Jombart <ecu@ipv42.net>
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/ccze/Makefile1
-rw-r--r--sysutils/ccze/files/patch-ccze-compat.c11
2 files changed, 12 insertions, 0 deletions
diff --git a/sysutils/ccze/Makefile b/sysutils/ccze/Makefile
index 1da059db3d9c..9d4962921883 100644
--- a/sysutils/ccze/Makefile
+++ b/sysutils/ccze/Makefile
@@ -7,6 +7,7 @@
PORTNAME= ccze
PORTVERSION= 0.2.1
+PORTREVISION= 1
CATEGORIES= sysutils
MASTER_SITES= ftp://bonehunter.rulez.org/pub/ccze/stable/
diff --git a/sysutils/ccze/files/patch-ccze-compat.c b/sysutils/ccze/files/patch-ccze-compat.c
new file mode 100644
index 000000000000..3eae278dc2e7
--- /dev/null
+++ b/sysutils/ccze/files/patch-ccze-compat.c
@@ -0,0 +1,11 @@
+--- src/ccze-compat.c.orig Fri Sep 26 17:27:22 2003
++++ src/ccze-compat.c Fri Sep 26 17:27:39 2003
+@@ -275,7 +275,7 @@
+ char **valuep)
+ {
+ int i = getsubopt (optionp, tokens, valuep);
+-#if HAVE_SUBOPTARg
++#if HAVE_SUBOPTARG
+ if (!*valuep && suboptarg)
+ *valuep = strdup (suboptarg);
+ #endif