aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils
diff options
context:
space:
mode:
authorjbeich <jbeich@FreeBSD.org>2016-11-21 11:52:38 +0800
committerjbeich <jbeich@FreeBSD.org>2016-11-21 11:52:38 +0800
commitc0272fb3e3c6b1d53a93ec7b3d133ea32c04cacc (patch)
tree5fce84c6c5ed45a1c0b5a7e314364f172c014784 /sysutils
parent481962af4af97807569dbeba98920f856347114d (diff)
downloadfreebsd-ports-gnome-c0272fb3e3c6b1d53a93ec7b3d133ea32c04cacc.tar.gz
freebsd-ports-gnome-c0272fb3e3c6b1d53a93ec7b3d133ea32c04cacc.tar.zst
freebsd-ports-gnome-c0272fb3e3c6b1d53a93ec7b3d133ea32c04cacc.zip
sysutils/freefilesync: unbreak with boost 1.62 on 11.0+
In file included from algorithm.cpp:13: In file included from ../../zen/guid.h:16: In file included from /usr/local/include/boost/uuid/uuid_generators.hpp:17: In file included from /usr/local/include/boost/uuid/random_generator.hpp:17: In file included from /usr/local/include/boost/shared_ptr.hpp:17: In file included from /usr/local/include/boost/smart_ptr/shared_ptr.hpp:28: In file included from /usr/local/include/boost/smart_ptr/detail/shared_count.hpp:29: In file included from /usr/local/include/boost/smart_ptr/detail/sp_counted_base.hpp:45: In file included from /usr/local/include/boost/smart_ptr/detail/sp_counted_base_clang.hpp:18: In file included from /usr/local/include/boost/detail/sp_typeinfo.hpp:20: In file included from /usr/local/include/boost/core/typeinfo.hpp:119: In file included from /usr/local/include/boost/core/demangle.hpp:32: /usr/include/c++/v1/cxxabi.h:190:19: error: '__cxa_get_globals' is missing exception specification 'noexcept' __cxa_eh_globals *__cxa_get_globals(void); ^ ../../zen/scope_guard.h:31:30: note: previous declaration is here extern "C" __cxa_eh_globals* __cxa_get_globals() noexcept; ^ PR: 214485 Reported by: antoine (via exp-run)
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/freefilesync/Makefile1
-rw-r--r--sysutils/freefilesync/files/patch-zen_scope__guard.h11
2 files changed, 12 insertions, 0 deletions
diff --git a/sysutils/freefilesync/Makefile b/sysutils/freefilesync/Makefile
index ce84653e9d31..b6bbae562115 100644
--- a/sysutils/freefilesync/Makefile
+++ b/sysutils/freefilesync/Makefile
@@ -3,6 +3,7 @@
PORTNAME= freefilesync
PORTVERSION= 8.3
+PORTREVISION= 1
CATEGORIES= sysutils
MASTER_SITES= http://www.freefilesync.org/download/ \
http://www.freefilesync.org/archive/
diff --git a/sysutils/freefilesync/files/patch-zen_scope__guard.h b/sysutils/freefilesync/files/patch-zen_scope__guard.h
new file mode 100644
index 000000000000..b5a4f9b42f6d
--- /dev/null
+++ b/sysutils/freefilesync/files/patch-zen_scope__guard.h
@@ -0,0 +1,11 @@
+--- ../../zen/scope_guard.h.orig 2016-03-31 20:08:04 UTC
++++ ../../zen/scope_guard.h
+@@ -14,7 +14,7 @@
+ //best of Zen, Loki and C++17
+
+
+-#ifdef ZEN_WIN
++#if defined(ZEN_WIN) || (defined(_LIBCPP_VERSION) && _LIBCPP_VERSION >= 3700)
+ inline int getUncaughtExceptionCount() { return std::uncaught_exceptions(); }
+
+ #elif defined ZEN_LINUX || defined ZEN_MAC