aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils
diff options
context:
space:
mode:
authoroliver <oliver@FreeBSD.org>2004-10-22 18:51:45 +0800
committeroliver <oliver@FreeBSD.org>2004-10-22 18:51:45 +0800
commitd67268767ab34a6375422a2f9d374b2bf0609146 (patch)
tree1ae548d0270884d75400faa4703c74d413204dd3 /sysutils
parent30a83f92505aeb9e9c162b552784e94f81792b9a (diff)
downloadfreebsd-ports-gnome-d67268767ab34a6375422a2f9d374b2bf0609146.tar.gz
freebsd-ports-gnome-d67268767ab34a6375422a2f9d374b2bf0609146.tar.zst
freebsd-ports-gnome-d67268767ab34a6375422a2f9d374b2bf0609146.zip
Add xfce4-genmon-plugin 1.0, generic Monitor XFce4 panel plugin.
PR: 71640 Submitted by: Matt Lancereau <matt@bsdfly.org>
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/Makefile1
-rw-r--r--sysutils/xfce4-genmon-plugin/Makefile30
-rw-r--r--sysutils/xfce4-genmon-plugin/distinfo2
-rw-r--r--sysutils/xfce4-genmon-plugin/pkg-descr6
-rw-r--r--sysutils/xfce4-genmon-plugin/pkg-plist4
5 files changed, 43 insertions, 0 deletions
diff --git a/sysutils/Makefile b/sysutils/Makefile
index a32a23790920..6bf0bcc48586 100644
--- a/sysutils/Makefile
+++ b/sysutils/Makefile
@@ -486,6 +486,7 @@
SUBDIR += xfce4-battery-plugin
SUBDIR += xfce4-cpugraph-plugin
SUBDIR += xfce4-fsguard-plugin
+ SUBDIR += xfce4-genmon-plugin
SUBDIR += xfce4-mcs-manager
SUBDIR += xfce4-mcs-plugins
SUBDIR += xfce4-minicmd-plugin
diff --git a/sysutils/xfce4-genmon-plugin/Makefile b/sysutils/xfce4-genmon-plugin/Makefile
new file mode 100644
index 000000000000..e6cb590f5671
--- /dev/null
+++ b/sysutils/xfce4-genmon-plugin/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: xfce4-genmon-plugin
+# Date created: 2004-09-12
+# Whom: Matt Lancereau <matt@bsdfly.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= xfce4-genmon-plugin
+PORTVERSION= 1.0
+CATEGORIES= sysutils xfce
+MASTER_SITES= http://download.berlios.de/xfce-goodies/ \
+ http://matt.nerim.net/xfce-goodies/
+DIST_SUBDIR= xfce4
+
+MAINTAINER= matt@bsdfly.org
+COMMENT= Generic Monitor XFce4 panel plugin
+
+BUILD_DEPENDS= xfce4-panel:${PORTSDIR}/x11-wm/xfce4-panel
+LIB_DEPENDS= xfce4util.1:${PORTSDIR}/x11/libxfce4util \
+ xfcegui4.1:${PORTSDIR}/x11-toolkits/libxfce4gui \
+ startup-notification-1.0:${PORTSDIR}/x11/startup-notification
+RUN_DEPENDS= xfce4-panel:${PORTSDIR}/x11-wm/xfce4-panel
+
+USE_GNOME= gtk20 libxml2
+USE_X_PREFIX= yes
+USE_INC_LIBTOOL_VER=15
+INSTALLS_SHLIB= yes
+CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
+
+.include <bsd.port.mk>
diff --git a/sysutils/xfce4-genmon-plugin/distinfo b/sysutils/xfce4-genmon-plugin/distinfo
new file mode 100644
index 000000000000..34c87c820c43
--- /dev/null
+++ b/sysutils/xfce4-genmon-plugin/distinfo
@@ -0,0 +1,2 @@
+MD5 (xfce4/xfce4-genmon-plugin-1.0.tar.gz) = d1d511fc18fa129465bf19e0fa70c3a8
+SIZE (xfce4/xfce4-genmon-plugin-1.0.tar.gz) = 228562
diff --git a/sysutils/xfce4-genmon-plugin/pkg-descr b/sysutils/xfce4-genmon-plugin/pkg-descr
new file mode 100644
index 000000000000..896780449070
--- /dev/null
+++ b/sysutils/xfce4-genmon-plugin/pkg-descr
@@ -0,0 +1,6 @@
+The GenMon plugin cyclically spawns the indicated script/program,
+captures its output and displays it as a string into the panel.
+
+Author: Roger Seguin <roger_seguin@msn.com>
+
+WWW: http://xfce-goodies.berlios.de/
diff --git a/sysutils/xfce4-genmon-plugin/pkg-plist b/sysutils/xfce4-genmon-plugin/pkg-plist
new file mode 100644
index 000000000000..8bac852ad11d
--- /dev/null
+++ b/sysutils/xfce4-genmon-plugin/pkg-plist
@@ -0,0 +1,4 @@
+lib/xfce4/panel-plugins/libgenmon.so
+lib/xfce4/panel-plugins/libgenmon.la
+lib/xfce4/panel-plugins/libgenmon.a
+@unexec rmdir %D/lib/xfce4/panel-plugins 2>/dev/null || true