aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils
diff options
context:
space:
mode:
authorcperciva <cperciva@FreeBSD.org>2005-03-06 19:32:22 +0800
committercperciva <cperciva@FreeBSD.org>2005-03-06 19:32:22 +0800
commite2fa56cff9412e4aed960c732d563af3e85e0889 (patch)
tree8cef87e38852421a5e929a8cf78cd84e344447d0 /sysutils
parent5b5e8d7aad606b0cb50128f184969497f3bfe88a (diff)
downloadfreebsd-ports-gnome-e2fa56cff9412e4aed960c732d563af3e85e0889.tar.gz
freebsd-ports-gnome-e2fa56cff9412e4aed960c732d563af3e85e0889.tar.zst
freebsd-ports-gnome-e2fa56cff9412e4aed960c732d563af3e85e0889.zip
Set IGNORE for est and estctrl on recent -CURRENTs, since njl has added
them to the base system (as part of cpufreq, and under the name "powerd", respectively). Approved by: pav
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/est/Makefile8
-rw-r--r--sysutils/estctrl/Makefile8
2 files changed, 14 insertions, 2 deletions
diff --git a/sysutils/est/Makefile b/sysutils/est/Makefile
index dcae913da7be..fd9164b16b4a 100644
--- a/sysutils/est/Makefile
+++ b/sysutils/est/Makefile
@@ -23,6 +23,12 @@ RC_SCRIPTS_SUB= PREFIX=${PREFIX} RC_SUBR=${RC_SUBR}
PLIST_FILES= modules/est.ko \
etc/rc.d/est.sh
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} > 600015
+IGNORE= "est now contained in the base system (see cpufreq(4))"
+.endif
+
post-extract:
${SED} ${RC_SCRIPTS_SUB:S/$/!g/:S/^/ -e s!%%/:S/=/%%!/} \
${FILESDIR}/est.sh > ${WRKDIR}/est.sh
@@ -34,4 +40,4 @@ post-install:
${INSTALL_SCRIPT} ${WRKDIR}/est.sh ${PREFIX}/etc/rc.d/est.sh
${CAT} ${PKGMESSAGE}
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/sysutils/estctrl/Makefile b/sysutils/estctrl/Makefile
index 1cb2b51785d6..2fbb65e3ec11 100644
--- a/sysutils/estctrl/Makefile
+++ b/sysutils/estctrl/Makefile
@@ -26,6 +26,12 @@ PLIST_FILES= sbin/estctrl \
MAKE_ENV= BINDIR=${PREFIX}/sbin
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} > 600015
+IGNORE= "estctrl now contained in the base system (see powerd(8))"
+.endif
+
post-extract:
${SED} ${RC_SCRIPTS_SUB:S/$/!g/:S/^/ -e s!%%/:S/=/%%!/} \
${FILESDIR}/estctrl.sh > ${WRKDIR}/estctrl.sh
@@ -34,4 +40,4 @@ post-install:
${INSTALL_SCRIPT} ${WRKDIR}/estctrl.sh ${PREFIX}/etc/rc.d/estctrl.sh
${CAT} ${PKGMESSAGE}
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>