aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils
diff options
context:
space:
mode:
authormartymac <martymac@FreeBSD.org>2012-06-11 15:26:27 +0800
committermartymac <martymac@FreeBSD.org>2012-06-11 15:26:27 +0800
commite7fff8da9e6894af6b77f20ee9685447caa1dedf (patch)
tree5b6a68bc380b2e4fc17efc4f7aac9d9d7d878732 /sysutils
parent7be4f3be9827543be9394f540203e6bc7a55054d (diff)
downloadfreebsd-ports-gnome-e7fff8da9e6894af6b77f20ee9685447caa1dedf.tar.gz
freebsd-ports-gnome-e7fff8da9e6894af6b77f20ee9685447caa1dedf.tar.zst
freebsd-ports-gnome-e7fff8da9e6894af6b77f20ee9685447caa1dedf.zip
- Switch to OptionsNg
- Force LFS support when option activated - Add CONFLICTS with audio/waon - Add LFS description to bsd.options.desc.mk
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/pv/Makefile19
1 files changed, 13 insertions, 6 deletions
diff --git a/sysutils/pv/Makefile b/sysutils/pv/Makefile
index dbf5b7e99bf3..2a70daba5700 100644
--- a/sysutils/pv/Makefile
+++ b/sysutils/pv/Makefile
@@ -7,6 +7,7 @@
PORTNAME= pv
PORTVERSION= 1.2.0
+PORTREVISION= 1
CATEGORIES= sysutils
MASTER_SITES= ${MASTER_SITE_GOOGLE_CODE} \
SF/${PROJECTHOST}/${PROJECTHOST}/${PORTVERSION}
@@ -14,9 +15,11 @@ MASTER_SITES= ${MASTER_SITE_GOOGLE_CODE} \
MAINTAINER= martymac@FreeBSD.org
COMMENT= A pipe throughput monitor
-PROJECTHOST= pipeviewer
LICENSE= ART20
+CONFLICTS= waon-[0-9]*
+
+PROJECTHOST= pipeviewer
USE_BZIP2= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
@@ -25,15 +28,19 @@ MAN1= pv.1
PLIST_FILES= bin/pv
PORTDOCS= README INSTALL NEWS PACKAGE \
TODO VERSION release-checklist
-OPTIONS= LFS "Use large filesystem support" on \
- NLS "Use Native Language Support" off
+
+OPTIONS_DEFINE= NLS LFS
+OPTIONS_DEFAULT= LFS
.include <bsd.port.pre.mk>
-.if defined(WITHOUT_LFS)
+.if ${PORT_OPTIONS:MLFS}
+CONFIGURE_ARGS+= --enable-lfs
+.else
CONFIGURE_ARGS+= --disable-lfs
.endif
-.if defined(WITH_NLS)
+
+.if ${PORT_OPTIONS:MNLS}
CONFIGURE_ARGS+= --enable-static-nls
.else
CONFIGURE_ARGS+= --disable-nls
@@ -45,7 +52,7 @@ post-patch:
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/pv ${PREFIX}/bin/
${INSTALL_MAN} ${WRKSRC}/doc/quickref.1 ${MAN1PREFIX}/man/man1/pv.1
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
${MKDIR} ${DOCSDIR}
.for doc in ${PORTDOCS}
${INSTALL_DATA} ${WRKSRC}/doc/${doc} ${DOCSDIR}