aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils
diff options
context:
space:
mode:
authorstas <stas@FreeBSD.org>2006-10-02 21:34:33 +0800
committerstas <stas@FreeBSD.org>2006-10-02 21:34:33 +0800
commitff13fdabb5470addebbffa38303fa56390c304e3 (patch)
tree222ebeda147d0486c9ad5663dab0fa86b63e1f18 /sysutils
parent7a7f13fc128345e0890c85cc91e7f71b655163ae (diff)
downloadfreebsd-ports-gnome-ff13fdabb5470addebbffa38303fa56390c304e3.tar.gz
freebsd-ports-gnome-ff13fdabb5470addebbffa38303fa56390c304e3.tar.zst
freebsd-ports-gnome-ff13fdabb5470addebbffa38303fa56390c304e3.zip
- Honour CC and CXX
- Fix compiling with gcc 4.1 Approved by: sem (mentor)
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/rfstool/Makefile3
-rw-r--r--sysutils/rfstool/files/patch-reiserfs.h11
2 files changed, 14 insertions, 0 deletions
diff --git a/sysutils/rfstool/Makefile b/sysutils/rfstool/Makefile
index 3f50e1fcc788..303f9ab55603 100644
--- a/sysutils/rfstool/Makefile
+++ b/sysutils/rfstool/Makefile
@@ -25,6 +25,9 @@ MAKEFILE= makefile.gcc3x
MAKEFILE= makefile.gcc2x
.endif
+post-extract:
+ @${REINPLACE_CMD} -e "s,g++,\$${CXX},g" ${WRKSRC}/${MAKEFILE}
+
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/rfstool ${PREFIX}/bin
diff --git a/sysutils/rfstool/files/patch-reiserfs.h b/sysutils/rfstool/files/patch-reiserfs.h
new file mode 100644
index 000000000000..21e8ea1b6eae
--- /dev/null
+++ b/sysutils/rfstool/files/patch-reiserfs.h
@@ -0,0 +1,11 @@
+--- reiserfs.h.orig Mon Oct 2 13:58:35 2006
++++ reiserfs.h Mon Oct 2 13:58:39 2006
+@@ -268,7 +268,7 @@
+ {
+ }
+
+- ReiserFsBlock::~ReiserFsBlock()
++ ~ReiserFsBlock()
+ {
+ delete m_lpbMemory;
+ }