aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils
diff options
context:
space:
mode:
authormatthew <matthew@FreeBSD.org>2015-08-05 04:29:28 +0800
committermatthew <matthew@FreeBSD.org>2015-08-05 04:29:28 +0800
commit905f0d29bbaeab31d68371ba76b46534785fd19b (patch)
tree6c3f3529f01b3dfff9cc7c2c174a73cd3244a212 /sysutils
parente66c8df65ac6b87ccff08ccaf5819ce2cdae3760 (diff)
downloadfreebsd-ports-gnome-905f0d29bbaeab31d68371ba76b46534785fd19b.tar.gz
freebsd-ports-gnome-905f0d29bbaeab31d68371ba76b46534785fd19b.tar.zst
freebsd-ports-gnome-905f0d29bbaeab31d68371ba76b46534785fd19b.zip
* Update to 8.11.0
- Upstream has incorporated one part of the patches to runtime/stream.c - regenerate patches with 'make makepatch' * Modernize port - Use OPTION helpers - USE_AUTOTOOLS -> USES+= autoreconf * Set INSTALL_TARGET=install-strip rather than stripping in post-install: - Previously optional modules wouldn't have been stripped * Update pkg-message.in to use the now standard 'Rainier script' configuration file syntax (http://www.rsyslog.com/doc/rainerscript.html). * Add new option to enable the mmnormalize module. (http://www.rsyslog.com/doc/v8-stable/configuration/modules/mmnormalize.html) This enables converting some not-standard log formats to RFC3164 or RFC5424 styles, amongst other possible transformations. * Tweak PORTSCOUT setting PR: 202080 Approved by: brd (maintainer)
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/rsyslog8/Makefile99
-rw-r--r--sysutils/rsyslog8/distinfo4
-rw-r--r--sysutils/rsyslog8/files/patch-grammar_rainerscript.c4
-rw-r--r--sysutils/rsyslog8/files/patch-plugins__mmexternal__mmexternal.c2
-rw-r--r--sysutils/rsyslog8/files/patch-plugins__omprog__omprog.c2
-rw-r--r--sysutils/rsyslog8/files/patch-plugins_imfile_imfile.c2
-rw-r--r--sysutils/rsyslog8/files/patch-plugins_impstats_impstats.c4
-rw-r--r--sysutils/rsyslog8/files/patch-runtime_nsd__ptcp.c2
-rw-r--r--sysutils/rsyslog8/files/patch-runtime_stream.c13
-rw-r--r--sysutils/rsyslog8/files/pkg-message.in6
10 files changed, 51 insertions, 87 deletions
diff --git a/sysutils/rsyslog8/Makefile b/sysutils/rsyslog8/Makefile
index f1af349fd7ab..ae6364784ced 100644
--- a/sysutils/rsyslog8/Makefile
+++ b/sysutils/rsyslog8/Makefile
@@ -1,7 +1,7 @@
# $FreeBSD$
PORTNAME= rsyslog
-PORTVERSION= 8.10.0
+PORTVERSION= 8.11.0
CATEGORIES= sysutils
MASTER_SITES= http://www.rsyslog.com/files/download/rsyslog/
@@ -18,12 +18,12 @@ LIB_DEPENDS= libee.so:${PORTSDIR}/devel/libee \
libuuid.so:${PORTSDIR}/misc/e2fsprogs-libuuid
USE_LDCONFIG= yes
-USE_AUTOTOOLS= autoconf
-PORTSCOUT= limit:^8\.8
+PORTSCOUT= limit:^8\.
PKGNAMESUFFIX= 8
-OPTIONS_DEFINE= DBI DOCS GNUTLS GSSAPI MYSQL PGSQL RELP SNMP
+OPTIONS_DEFINE= DBI DOCS GNUTLS GSSAPI MYSQL PGSQL RELP SNMP \
+ NORMALIZE
DBI_DESC= LibDBI output module for rsyslog
GNUTLS_DESC= GNUTLS module for rsyslog
@@ -32,69 +32,46 @@ MYSQL_DESC= MySQL output module for rsyslog
PGSQL_DESC= PostgreSQL output module for rsyslog
RELP_DESC= RELP input/output module for rsyslog
SNMP_DESC= SNMP trap sender for rsyslog
+NORMALIZE_DESC= Message normalization module for rsyslog
-USES= libtool pkgconfig
+USES= libtool pkgconfig autoreconf
-.include <bsd.port.options.mk>
+DBI_LIB_DEPENDS= libdbi.so:${PORTSDIR}/databases/libdbi
+DBI_CONFIGURE_ENABLE= libdbi
+DBI_PLIST_FILES= lib/rsyslog/omlibdbi.so
-.if ${PORT_OPTIONS:MDBI}
-LIB_DEPENDS+= libdbi.so:${PORTSDIR}/databases/libdbi
-CONFIGURE_ARGS+=--enable-libdbi
-PLIST_FILES+= lib/rsyslog/omlibdbi.so
-.else
-CONFIGURE_ARGS+=--disable-libdbi
-.endif
+GNUTLS_LIB_DEPENDS= libgnutls.so:${PORTSDIR}/security/gnutls \
+ libgcrypt.so:${PORTSDIR}/security/libgcrypt
+GNUTLS_CONFIGURE_ENABLE=gnutls
+GNUTLS_PLIST_FILES= lib/rsyslog/lmnsd_gtls.so
-.if ${PORT_OPTIONS:MGNUTLS}
-LIB_DEPENDS+= libgnutls.so:${PORTSDIR}/security/gnutls \
- libgcrypt.so:${PORTSDIR}/security/libgcrypt
-CONFIGURE_ARGS+=--enable-gnutls
-PLIST_FILES+= lib/rsyslog/lmnsd_gtls.so
-.else
-CONFIGURE_ARGS+=--disable-gnutls
-.endif
+GSSAPI_CONFIGURE_ENABLE=gssapi-krb5
+GSSAPI_PLIST_FILES= lib/rsyslog/imgssapi.so \
+ lib/rsyslog/lmgssutil.so \
+ lib/rsyslog/omgssapi.so
-.if ${PORT_OPTIONS:MGSSAPI}
-CONFIGURE_ARGS+=--enable-gssapi-krb5
-PLIST_FILES+= lib/rsyslog/imgssapi.so \
- lib/rsyslog/lmgssutil.so \
- lib/rsyslog/omgssapi.so
-.else
-CONFIGURE_ARGS+=--disable-gssapi-krb5
-.endif
+MYSQL_USE= MYSQL=yes
+MYSQL_CONFIGURE_ENABLE= mysql
+MYSQL_PLIST_FILES= lib/rsyslog/ommysql.so
-.if ${PORT_OPTIONS:MMYSQL}
-USE_MYSQL= yes
-CONFIGURE_ARGS+=--enable-mysql
-PLIST_FILES+= lib/rsyslog/ommysql.so
-.else
-CONFIGURE_ARGS+=--disable-mysql
-.endif
+PGSQL_USES= pgsql
+PGSQL_CONFIGURE_ENABLE= pgsql
+PGSQL_PLIST_FILES= lib/rsyslog/ompgsql.so
-.if ${PORT_OPTIONS:MPGSQL}
-USES+= pgsql
-CONFIGURE_ARGS+=--enable-pgsql
-PLIST_FILES+= lib/rsyslog/ompgsql.so
-.else
-CONFIGURE_ARGS+=--disable-pgsql
-.endif
+RELP_LIB_DEPENDS= librelp.so:${PORTSDIR}/devel/librelp
+RELP_CONFIGURE_ENABLE= relp
+RELP_PLIST_FILES= lib/rsyslog/imrelp.so \
+ lib/rsyslog/omrelp.so
-.if ${PORT_OPTIONS:MRELP}
-LIB_DEPENDS+= librelp.so:${PORTSDIR}/devel/librelp
-CONFIGURE_ARGS+=--enable-relp
-PLIST_FILES+= lib/rsyslog/imrelp.so \
- lib/rsyslog/omrelp.so
-.else
-CONFIGURE_ARGS+=--disable-relp
-.endif
+SNMP_LIB_DEPENDS= libnetsnmp.so:${PORTSDIR}/net-mgmt/net-snmp
+SNMP_CONFIGURE_ENABLE= snmp
+SNMP_PLIST_FILES= lib/rsyslog/omsnmp.so
-.if ${PORT_OPTIONS:MSNMP}
-LIB_DEPENDS+= libnetsnmp.so:${PORTSDIR}/net-mgmt/net-snmp
-CONFIGURE_ARGS+=--enable-snmp
-PLIST_FILES+= lib/rsyslog/omsnmp.so
-.else
-CONFIGURE_ARGS+=--disable-snmp
-.endif
+NORMALIZE_LIB_DEPENDS= liblognorm.so:${PORTSDIR}/devel/liblognorm
+NORMALIZE_CONFIGURE_ENABLE= mmnormalize
+NORMALIZE_PLIST_FILES= lib/rsyslog/mmnormalize.so
+
+.include <bsd.port.options.mk>
.ifdef WITH_MYSQL_MICROSECONDS
EXTRA_PATCHES+= ${FILESDIR}/extra-patch-mysql-microseconds
@@ -109,6 +86,7 @@ CFLAGS+= -I${LOCALBASE}/include
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
GNU_CONFIGURE= yes
+INSTALL_TARGET= install-strip
.ifdef WITH_DEBUG
CONFIGURE_ARGS+=--enable-rtinst --enable-debug
@@ -136,9 +114,4 @@ post-patch:
@${REINPLACE_CMD} -e 's,/lib/rsyslog,${PREFIX}/lib/rsyslog,' ${WRKSRC}/tools/syslogd.c
@${FIND} ${WRKSRC} -name '*.bak' -delete
-post-install:
-.for l in im3195 imdiag imfile imklog immark impstats imtcp imudp imuxsock lmcry_gcry lmnet lmnetstrms lmnsd_ptcp lmregexp lmstrmsrv lmtcpclt lmtcpsrv lmzlibw mmexternal ommail omprog omstdout omtesting omuxsock
- ${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/rsyslog/${l}.so
-.endfor
-
.include <bsd.port.post.mk>
diff --git a/sysutils/rsyslog8/distinfo b/sysutils/rsyslog8/distinfo
index 2d21ce5d7b8c..ffd19053bab0 100644
--- a/sysutils/rsyslog8/distinfo
+++ b/sysutils/rsyslog8/distinfo
@@ -1,2 +1,2 @@
-SHA256 (rsyslog-8.10.0.tar.gz) = b92df3f367108219e2fffccd463bf49d75cb8ab3ceaa52e9789f85eace066912
-SIZE (rsyslog-8.10.0.tar.gz) = 2013205
+SHA256 (rsyslog-8.11.0.tar.gz) = bc64d8ba1e3fb8cfe21eadd5fb0938381bb37ed72cef9d6f14d376d2bac9bf78
+SIZE (rsyslog-8.11.0.tar.gz) = 2060890
diff --git a/sysutils/rsyslog8/files/patch-grammar_rainerscript.c b/sysutils/rsyslog8/files/patch-grammar_rainerscript.c
index f061df0641f1..60d773982a43 100644
--- a/sysutils/rsyslog8/files/patch-grammar_rainerscript.c
+++ b/sysutils/rsyslog8/files/patch-grammar_rainerscript.c
@@ -1,6 +1,6 @@
---- grammar/rainerscript.c.orig 2014-12-02 10:15:16 UTC
+--- grammar/rainerscript.c.orig 2015-06-30 12:26:24 UTC
+++ grammar/rainerscript.c
-@@ -34,6 +34,7 @@
+@@ -35,6 +35,7 @@
#include <sys/stat.h>
#include <sys/types.h>
#include <libestr.h>
diff --git a/sysutils/rsyslog8/files/patch-plugins__mmexternal__mmexternal.c b/sysutils/rsyslog8/files/patch-plugins__mmexternal__mmexternal.c
index 8a1a7a170c58..c9c92cfcebe6 100644
--- a/sysutils/rsyslog8/files/patch-plugins__mmexternal__mmexternal.c
+++ b/sysutils/rsyslog8/files/patch-plugins__mmexternal__mmexternal.c
@@ -1,4 +1,4 @@
---- plugins/mmexternal/mmexternal.c.orig 2014-11-25 15:45:35 UTC
+--- plugins/mmexternal/mmexternal.c.orig 2015-04-30 08:50:16 UTC
+++ plugins/mmexternal/mmexternal.c
@@ -31,7 +31,7 @@
#include <errno.h>
diff --git a/sysutils/rsyslog8/files/patch-plugins__omprog__omprog.c b/sysutils/rsyslog8/files/patch-plugins__omprog__omprog.c
index d0bbe115ad21..04df04f65898 100644
--- a/sysutils/rsyslog8/files/patch-plugins__omprog__omprog.c
+++ b/sysutils/rsyslog8/files/patch-plugins__omprog__omprog.c
@@ -1,4 +1,4 @@
---- plugins/omprog/omprog.c.orig 2014-11-25 15:45:35 UTC
+--- plugins/omprog/omprog.c.orig 2015-04-30 08:50:16 UTC
+++ plugins/omprog/omprog.c
@@ -36,7 +36,7 @@
#include <errno.h>
diff --git a/sysutils/rsyslog8/files/patch-plugins_imfile_imfile.c b/sysutils/rsyslog8/files/patch-plugins_imfile_imfile.c
index 00291058acbd..41a27788d595 100644
--- a/sysutils/rsyslog8/files/patch-plugins_imfile_imfile.c
+++ b/sysutils/rsyslog8/files/patch-plugins_imfile_imfile.c
@@ -1,4 +1,4 @@
---- plugins/imfile/imfile.c.orig 2015-05-19 08:53:40 UTC
+--- plugins/imfile/imfile.c.orig 2015-06-30 12:26:24 UTC
+++ plugins/imfile/imfile.c
@@ -1869,12 +1869,14 @@ CODESTARTmodExit
objRelease(errmsg, CORE_COMPONENT);
diff --git a/sysutils/rsyslog8/files/patch-plugins_impstats_impstats.c b/sysutils/rsyslog8/files/patch-plugins_impstats_impstats.c
index 42d7c3b3b616..4e19f773c345 100644
--- a/sysutils/rsyslog8/files/patch-plugins_impstats_impstats.c
+++ b/sysutils/rsyslog8/files/patch-plugins_impstats_impstats.c
@@ -1,6 +1,6 @@
---- plugins/impstats/impstats.c.orig 2014-12-10 15:46:20 UTC
+--- plugins/impstats/impstats.c.orig 2015-04-30 08:50:15 UTC
+++ plugins/impstats/impstats.c
-@@ -35,6 +35,7 @@
+@@ -36,6 +36,7 @@
#include <errno.h>
#include <sys/time.h>
#include <sys/resource.h>
diff --git a/sysutils/rsyslog8/files/patch-runtime_nsd__ptcp.c b/sysutils/rsyslog8/files/patch-runtime_nsd__ptcp.c
index 36ca7b7317c6..5bea2ea80cf4 100644
--- a/sysutils/rsyslog8/files/patch-runtime_nsd__ptcp.c
+++ b/sysutils/rsyslog8/files/patch-runtime_nsd__ptcp.c
@@ -1,4 +1,4 @@
---- runtime/nsd_ptcp.c.orig 2015-01-13 22:06:22 UTC
+--- runtime/nsd_ptcp.c.orig 2015-04-30 08:50:16 UTC
+++ runtime/nsd_ptcp.c
@@ -656,7 +656,11 @@ EnableKeepAlive(nsd_t *pNsd)
if(pThis->iKeepAliveProbes > 0) {
diff --git a/sysutils/rsyslog8/files/patch-runtime_stream.c b/sysutils/rsyslog8/files/patch-runtime_stream.c
index 852f0adcface..dfd7f1ccd59d 100644
--- a/sysutils/rsyslog8/files/patch-runtime_stream.c
+++ b/sysutils/rsyslog8/files/patch-runtime_stream.c
@@ -1,15 +1,6 @@
---- runtime/stream.c.orig 2015-05-19 08:53:40 UTC
+--- runtime/stream.c.orig 2015-06-30 12:26:24 UTC
+++ runtime/stream.c
-@@ -1063,7 +1063,7 @@ tryTTYRecover(strm_t *pThis, int err)
- {
- DEFiRet;
- ISOBJ_TYPE_assert(pThis, strm);
-- if(err == ERR_TTYHUP) {
-+ if(err == ERR_TTYHUP || err == ENXIO) {
- close(pThis->fd);
- CHKiRet(doPhysOpen(pThis));
- }
-@@ -1089,12 +1089,30 @@ doWriteCall(strm_t *pThis, uchar *pBuf,
+@@ -1097,12 +1097,30 @@ doWriteCall(strm_t *pThis, uchar *pBuf,
char *pWriteBuf;
DEFiRet;
ISOBJ_TYPE_assert(pThis, strm);
diff --git a/sysutils/rsyslog8/files/pkg-message.in b/sysutils/rsyslog8/files/pkg-message.in
index abb08006e491..9a95eaa33bf9 100644
--- a/sysutils/rsyslog8/files/pkg-message.in
+++ b/sysutils/rsyslog8/files/pkg-message.in
@@ -14,9 +14,9 @@ this:
Add the following (3) lines to the beginning of the config file, for
basic functionality:
- $ModLoad immark.so # provides --MARK-- message capability
- $ModLoad imuxsock.so # provides support for local system logging
- $ModLoad imklog.so # kernel logging
+ module(load="immark") # provides --MARK-- message capability
+ module(load="imuxsock") # provides support for local system logging
+ module(load="imklog") # kernel logging
newsyslog(8) has the path of syslogd's pid file hardcoded. To
make it work seamlessly with rsyslog, add this: