aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils
diff options
context:
space:
mode:
authorbrd <brd@FreeBSD.org>2016-06-29 04:18:25 +0800
committerbrd <brd@FreeBSD.org>2016-06-29 04:18:25 +0800
commit02dc7f130c35bb086d0cd6f3382b8efaed8adbe1 (patch)
tree84766fa627b0f177ee4b48c1bac9d6e9129b93c0 /sysutils
parent6b6016d50428116fb26890f0c60fe9b95a73c265 (diff)
downloadfreebsd-ports-gnome-02dc7f130c35bb086d0cd6f3382b8efaed8adbe1.tar.gz
freebsd-ports-gnome-02dc7f130c35bb086d0cd6f3382b8efaed8adbe1.tar.zst
freebsd-ports-gnome-02dc7f130c35bb086d0cd6f3382b8efaed8adbe1.zip
In sysutils/u-boot-pine64, fix booting with boot1.efi.
Submitted by: andrew Approved by: bdrewery (implicit)
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/u-boot-pine64/Makefile1
-rw-r--r--sysutils/u-boot-pine64/files/patch-lib_efi__loader_efi__console.c12
2 files changed, 13 insertions, 0 deletions
diff --git a/sysutils/u-boot-pine64/Makefile b/sysutils/u-boot-pine64/Makefile
index 8a97b33191fb..2aacf452d6d5 100644
--- a/sysutils/u-boot-pine64/Makefile
+++ b/sysutils/u-boot-pine64/Makefile
@@ -2,6 +2,7 @@
PORTNAME= u-boot
PORTVERSION= 2016.05
+PORTREVISION= 1
CATEGORIES= sysutils
MASTER_SITES= ftp://ftp.denx.de/pub/u-boot/:uboot \
http://download.opensuse.org/repositories/devel:/ARM:/Factory:/Contrib:/Pine64/standard/src/:firmware
diff --git a/sysutils/u-boot-pine64/files/patch-lib_efi__loader_efi__console.c b/sysutils/u-boot-pine64/files/patch-lib_efi__loader_efi__console.c
new file mode 100644
index 000000000000..7d5a19e5a9d9
--- /dev/null
+++ b/sysutils/u-boot-pine64/files/patch-lib_efi__loader_efi__console.c
@@ -0,0 +1,12 @@
+--- lib/efi_loader/efi_console.c
++++ lib/efi_loader/efi_console.c
+@@ -167,6 +167,9 @@ static efi_status_t EFIAPI efi_cout_query_mode(
+ {
+ EFI_ENTRY("%p, %ld, %p, %p", this, mode_number, columns, rows);
+
++ if (mode_number != 0)
++ return EFI_EXIT(EFI_INVALID_PARAMETER);
++
+ if (!console_size_queried) {
+ /* Ask the terminal about its size */
+ int n[3];