aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils
diff options
context:
space:
mode:
authorse <se@FreeBSD.org>2017-10-17 15:37:56 +0800
committerse <se@FreeBSD.org>2017-10-17 15:37:56 +0800
commit12e252bcd786832a2ca4a5e78c7ce1dac93be7fd (patch)
tree5b2256d139f17fe17859aa8e55a12042b42985d4 /sysutils
parent860bed69a76b816d9319976bfc07f981ff381136 (diff)
downloadfreebsd-ports-gnome-12e252bcd786832a2ca4a5e78c7ce1dac93be7fd.tar.gz
freebsd-ports-gnome-12e252bcd786832a2ca4a5e78c7ce1dac93be7fd.tar.zst
freebsd-ports-gnome-12e252bcd786832a2ca4a5e78c7ce1dac93be7fd.zip
New port for the FUSE support library version 3.
This version is not compatible with version 2 file system user modules and is meant to co-exist with the older version of the library. Reviewed by: antoine (mentor)
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/Makefile1
-rw-r--r--sysutils/fusefs-libs3/Makefile29
-rw-r--r--sysutils/fusefs-libs3/distinfo3
-rw-r--r--sysutils/fusefs-libs3/files/patch-doc_meson.build10
-rw-r--r--sysutils/fusefs-libs3/pkg-descr6
-rw-r--r--sysutils/fusefs-libs3/pkg-message1
-rw-r--r--sysutils/fusefs-libs3/pkg-plist9
7 files changed, 59 insertions, 0 deletions
diff --git a/sysutils/Makefile b/sysutils/Makefile
index cf63423a71e3..2182e80867f6 100644
--- a/sysutils/Makefile
+++ b/sysutils/Makefile
@@ -361,6 +361,7 @@
SUBDIR += fusefs-httpfs
SUBDIR += fusefs-ifuse
SUBDIR += fusefs-libs
+ SUBDIR += fusefs-libs3
SUBDIR += fusefs-lkl
SUBDIR += fusefs-mhddfs
SUBDIR += fusefs-mp3fs
diff --git a/sysutils/fusefs-libs3/Makefile b/sysutils/fusefs-libs3/Makefile
new file mode 100644
index 000000000000..9e0ef224c130
--- /dev/null
+++ b/sysutils/fusefs-libs3/Makefile
@@ -0,0 +1,29 @@
+# Created by: Stefan Esser
+# $FreeBSD$
+
+PORTNAME= fusefs-libs3
+DISTVERSIONPREFIX= fuse-
+DISTVERSION= 3.2.0
+CATEGORIES= sysutils
+
+MAINTAINER= se@freebsd.org
+COMMENT= FUSE library version 3 for filesystems implemented in userspace
+
+LICENSE= LGPL21
+LICENSE_FILE= ${WRKSRC}/COPYING.LIB
+
+USES= meson
+USE_LDCONFIG= yes
+
+USE_GITHUB= yes
+GH_ACCOUNT= libfuse
+GH_PROJECT= libfuse
+GH_TAGNAME= d92bf83
+
+.include <bsd.port.pre.mk>
+
+.if ${OPSYS} == DragonFly
+IGNORE= fusefs has not been implemented on DragonFly
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/sysutils/fusefs-libs3/distinfo b/sysutils/fusefs-libs3/distinfo
new file mode 100644
index 000000000000..bbecd7364da5
--- /dev/null
+++ b/sysutils/fusefs-libs3/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1508224399
+SHA256 (libfuse-libfuse-fuse-3.2.0-d92bf83_GH0.tar.gz) = 4c8e3a89ad7bae082dfb7a16250a5a325791ad74829f38cb8a4472be8c25d7b5
+SIZE (libfuse-libfuse-fuse-3.2.0-d92bf83_GH0.tar.gz) = 731045
diff --git a/sysutils/fusefs-libs3/files/patch-doc_meson.build b/sysutils/fusefs-libs3/files/patch-doc_meson.build
new file mode 100644
index 000000000000..96c9c19a74e8
--- /dev/null
+++ b/sysutils/fusefs-libs3/files/patch-doc_meson.build
@@ -0,0 +1,10 @@
+--- doc/meson.build.orig 2017-09-12 13:50:16 UTC
++++ doc/meson.build
+@@ -1,5 +1,7 @@
+ # Attention, emacs, please use -*- mode: python -*-
+ # (even though this isn't actually Python code)
+
++if not platform.endswith('bsd')
+ install_man('fusermount3.1', 'mount.fuse.8')
++endif
+
diff --git a/sysutils/fusefs-libs3/pkg-descr b/sysutils/fusefs-libs3/pkg-descr
new file mode 100644
index 000000000000..652b9be8ed2f
--- /dev/null
+++ b/sysutils/fusefs-libs3/pkg-descr
@@ -0,0 +1,6 @@
+FUSE makes it possible to implement a filesystem in a userspace program.
+
+This version 3 of the fuse library is not compatible with file-systems
+developed for version 2.
+
+WWW: https://github.com/libfuse/libfuse
diff --git a/sysutils/fusefs-libs3/pkg-message b/sysutils/fusefs-libs3/pkg-message
new file mode 100644
index 000000000000..13b7f2ee9224
--- /dev/null
+++ b/sysutils/fusefs-libs3/pkg-message
@@ -0,0 +1 @@
+Install the fuse kernel module to use this port.
diff --git a/sysutils/fusefs-libs3/pkg-plist b/sysutils/fusefs-libs3/pkg-plist
new file mode 100644
index 000000000000..6ccdbbe35355
--- /dev/null
+++ b/sysutils/fusefs-libs3/pkg-plist
@@ -0,0 +1,9 @@
+include/fuse3/cuse_lowlevel.h
+include/fuse3/fuse.h
+include/fuse3/fuse_common.h
+include/fuse3/fuse_lowlevel.h
+include/fuse3/fuse_opt.h
+lib/libfuse3.so
+lib/libfuse3.so.3
+lib/libfuse3.so.3.2.0
+libdata/pkgconfig/fuse3.pc