aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils
diff options
context:
space:
mode:
authorru <ru@FreeBSD.org>2005-12-17 00:23:40 +0800
committerru <ru@FreeBSD.org>2005-12-17 00:23:40 +0800
commit13881ee8a30038ed6181c050079d7f967c7e0b4c (patch)
treec12e1f2ed0cf598139c118ca5d4e51c93cb8929d /sysutils
parent8236aae4a66d81dba930759424bf18f969978be1 (diff)
downloadfreebsd-ports-gnome-13881ee8a30038ed6181c050079d7f967c7e0b4c.tar.gz
freebsd-ports-gnome-13881ee8a30038ed6181c050079d7f967c7e0b4c.tar.zst
freebsd-ports-gnome-13881ee8a30038ed6181c050079d7f967c7e0b4c.zip
- Enable smb(4) support (on amd64 and i386 for now).
- Fix PCI ID for AMD-8111's SMBus 1.0 supported by amdpm(4).
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/mbmon/Makefile2
-rw-r--r--sysutils/mbmon/files/patch-configure24
-rw-r--r--sysutils/mbmon/files/patch-getMB-smb_ioctl.c24
-rw-r--r--sysutils/mbmon/files/patch-pci_pm.h13
-rw-r--r--sysutils/xmbmon/Makefile2
-rw-r--r--sysutils/xmbmon/files/patch-configure24
-rw-r--r--sysutils/xmbmon/files/patch-getMB-smb_ioctl.c24
-rw-r--r--sysutils/xmbmon/files/patch-pci_pm.h13
8 files changed, 124 insertions, 2 deletions
diff --git a/sysutils/mbmon/Makefile b/sysutils/mbmon/Makefile
index eb215db794f4..139afddb9b78 100644
--- a/sysutils/mbmon/Makefile
+++ b/sysutils/mbmon/Makefile
@@ -7,7 +7,7 @@
PORTNAME= xmbmon
PORTVERSION= 205
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= sysutils
MASTER_SITES= http://www.nt.phys.kyushu-u.ac.jp/shimizu/download/xmbmon/
.if defined(WITHOUT_X11)
diff --git a/sysutils/mbmon/files/patch-configure b/sysutils/mbmon/files/patch-configure
new file mode 100644
index 000000000000..b6c3e5612a89
--- /dev/null
+++ b/sysutils/mbmon/files/patch-configure
@@ -0,0 +1,24 @@
+$FreeBSD$
+
+--- configure.orig Fri Aug 13 10:22:18 2004
++++ configure Fri Dec 16 17:50:05 2005
+@@ -3486,8 +3486,9 @@
+
+
+ case "${host}" in
+- i?86-*-freebsd*)
++ i?86-*-freebsd* | amd64-*-freebsd*)
+ CC=cc
++ HOSTDEF="-DSMBUS_IOCTL"
+ ;;
+ i?86-*-linux-*)
+ CC=gcc
+@@ -3946,7 +3947,7 @@
+ done
+
+
+-for ac_header in machine/smb.h
++for ac_header in dev/smbus/smb.h machine/smb.h
+ do
+ as_ac_Header=`echo "ac_cv_header_$ac_header" | $as_tr_sh`
+ if eval "test \"\${$as_ac_Header+set}\" = set"; then
diff --git a/sysutils/mbmon/files/patch-getMB-smb_ioctl.c b/sysutils/mbmon/files/patch-getMB-smb_ioctl.c
new file mode 100644
index 000000000000..7fe81da58542
--- /dev/null
+++ b/sysutils/mbmon/files/patch-getMB-smb_ioctl.c
@@ -0,0 +1,24 @@
+$FreeBSD$
+
+--- getMB-smb_ioctl.c.orig Sat Jul 5 18:15:24 2003
++++ getMB-smb_ioctl.c Fri Dec 16 17:56:54 2005
+@@ -5,6 +5,7 @@
+ #ifdef HAVE_SMBUS
+ /* assume SMBus ioctl support, only for FreeBSD */
+
++#include <sys/param.h>
+ #include <stdlib.h>
+ #include <stdio.h>
+ #include <fcntl.h>
+@@ -13,7 +14,11 @@
+ #include <sys/types.h>
+ #include <sys/ioctl.h>
+
++#if __FreeBSD_version >= 500000
++#include <dev/smbus/smb.h>
++#else
+ #include <machine/smb.h>
++#endif
+
+ #include "methods.h"
+
diff --git a/sysutils/mbmon/files/patch-pci_pm.h b/sysutils/mbmon/files/patch-pci_pm.h
new file mode 100644
index 000000000000..d8ca17ec2f59
--- /dev/null
+++ b/sysutils/mbmon/files/patch-pci_pm.h
@@ -0,0 +1,13 @@
+$FreeBSD$
+
+--- pci_pm.h.orig Wed Jul 14 18:02:49 2004
++++ pci_pm.h Fri Dec 16 18:13:15 2005
+@@ -68,7 +68,7 @@
+ #define ID_AMD756 0x740B1022
+ #define ID_AMD766 0x74131022
+ #define ID_AMD768 0x74431022
+-#define ID_AMD8111 0x746A1022
++#define ID_AMD8111 0x746B1022
+ #define ID_NFORCE 0x01B410DE
+ #define ID_NFORCE2 0x006410DE
+ #define ID_ALI7101 0x710110B9
diff --git a/sysutils/xmbmon/Makefile b/sysutils/xmbmon/Makefile
index eb215db794f4..139afddb9b78 100644
--- a/sysutils/xmbmon/Makefile
+++ b/sysutils/xmbmon/Makefile
@@ -7,7 +7,7 @@
PORTNAME= xmbmon
PORTVERSION= 205
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= sysutils
MASTER_SITES= http://www.nt.phys.kyushu-u.ac.jp/shimizu/download/xmbmon/
.if defined(WITHOUT_X11)
diff --git a/sysutils/xmbmon/files/patch-configure b/sysutils/xmbmon/files/patch-configure
new file mode 100644
index 000000000000..b6c3e5612a89
--- /dev/null
+++ b/sysutils/xmbmon/files/patch-configure
@@ -0,0 +1,24 @@
+$FreeBSD$
+
+--- configure.orig Fri Aug 13 10:22:18 2004
++++ configure Fri Dec 16 17:50:05 2005
+@@ -3486,8 +3486,9 @@
+
+
+ case "${host}" in
+- i?86-*-freebsd*)
++ i?86-*-freebsd* | amd64-*-freebsd*)
+ CC=cc
++ HOSTDEF="-DSMBUS_IOCTL"
+ ;;
+ i?86-*-linux-*)
+ CC=gcc
+@@ -3946,7 +3947,7 @@
+ done
+
+
+-for ac_header in machine/smb.h
++for ac_header in dev/smbus/smb.h machine/smb.h
+ do
+ as_ac_Header=`echo "ac_cv_header_$ac_header" | $as_tr_sh`
+ if eval "test \"\${$as_ac_Header+set}\" = set"; then
diff --git a/sysutils/xmbmon/files/patch-getMB-smb_ioctl.c b/sysutils/xmbmon/files/patch-getMB-smb_ioctl.c
new file mode 100644
index 000000000000..7fe81da58542
--- /dev/null
+++ b/sysutils/xmbmon/files/patch-getMB-smb_ioctl.c
@@ -0,0 +1,24 @@
+$FreeBSD$
+
+--- getMB-smb_ioctl.c.orig Sat Jul 5 18:15:24 2003
++++ getMB-smb_ioctl.c Fri Dec 16 17:56:54 2005
+@@ -5,6 +5,7 @@
+ #ifdef HAVE_SMBUS
+ /* assume SMBus ioctl support, only for FreeBSD */
+
++#include <sys/param.h>
+ #include <stdlib.h>
+ #include <stdio.h>
+ #include <fcntl.h>
+@@ -13,7 +14,11 @@
+ #include <sys/types.h>
+ #include <sys/ioctl.h>
+
++#if __FreeBSD_version >= 500000
++#include <dev/smbus/smb.h>
++#else
+ #include <machine/smb.h>
++#endif
+
+ #include "methods.h"
+
diff --git a/sysutils/xmbmon/files/patch-pci_pm.h b/sysutils/xmbmon/files/patch-pci_pm.h
new file mode 100644
index 000000000000..d8ca17ec2f59
--- /dev/null
+++ b/sysutils/xmbmon/files/patch-pci_pm.h
@@ -0,0 +1,13 @@
+$FreeBSD$
+
+--- pci_pm.h.orig Wed Jul 14 18:02:49 2004
++++ pci_pm.h Fri Dec 16 18:13:15 2005
+@@ -68,7 +68,7 @@
+ #define ID_AMD756 0x740B1022
+ #define ID_AMD766 0x74131022
+ #define ID_AMD768 0x74431022
+-#define ID_AMD8111 0x746A1022
++#define ID_AMD8111 0x746B1022
+ #define ID_NFORCE 0x01B410DE
+ #define ID_NFORCE2 0x006410DE
+ #define ID_ALI7101 0x710110B9